Bluetooth HCI reset fail during airplane mode switch stress tests

Bug #1948898 reported by You-Sheng Yang
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Hirsute
High
You-Sheng Yang
Impish
High
You-Sheng Yang
linux-oem-5.10 (Ubuntu)
Undecided
Unassigned
Focal
High
You-Sheng Yang
Hirsute
Undecided
Unassigned
Impish
Undecided
Unassigned
linux-oem-5.13 (Ubuntu)
Undecided
Unassigned
Focal
High
You-Sheng Yang
Hirsute
Undecided
Unassigned
Impish
Undecided
Unassigned

Bug Description

Bug 1928838 fixed possible kernel panic when doing rfkill block on Intel Bluetooth controller. The fix was also upstreamed in v5.14-rc1 as commit 0ea9fd001a14e ("Bluetooth: Shutdown controller after workqueues are flushed or cancelled") and was backported to v5.10.51, v5.12.18, and v5.13.3. However, as indicated in https://<email address hidden>/ , it caused a regression to mtkbtsdio and was then fixed in upstream commit 0ea53674d07f (" Bluetooth: Move shutdown callback before flushing tx and rx queue") since v5.15-rc1 and has been backported to v5.14.3. Current statuses:

* v5.10.x:
  * 0ea9fd001a14e: backported(v5.10.51), reverted(v5.10.57)
  * 0ea53674d07f: backported(v5.10.65), reverted(v5.10.66)
* v5.11.x: N/A
* v5.12.x:
  * 0ea9fd001a14e: backported(v5.12.18)
* v5.13.x:
  * 0ea9fd001a14e: backported(v5.13.3), reverted(v5.13.9)
  * 0ea53674d07f: backported(v5.13.17), reverted(v5.13.18)
* v5.14.x:
  * 0ea9fd001a14e: committed(v5.14-rc1)
  * 0ea53674d07f: backported(v5.14.3)
* v5.15.x:
  * 0ea53674d07f: committed(v5.15-rc1)

As a result, this affects 5.10/11/13 kernels.

You-Sheng Yang (vicamo)
tags: added: oem-priority originate-from-1940428 somerville
Revision history for this message
You-Sheng Yang (vicamo) wrote : Re: [Bug 1948898] [NEW] Bluetooth HCI reset fail during airplane mode switch stress tests
Changed in linux (Ubuntu):
status: New → Fix Released
Changed in linux-oem-5.10 (Ubuntu):
status: New → Invalid
Changed in linux-oem-5.10 (Ubuntu Hirsute):
status: New → Invalid
Changed in linux-oem-5.10 (Ubuntu Impish):
status: New → Invalid
Changed in linux-oem-5.13 (Ubuntu):
status: New → Invalid
You-Sheng Yang (vicamo)
Changed in linux (Ubuntu Focal):
status: New → Invalid
Changed in linux-oem-5.13 (Ubuntu Focal):
assignee: nobody → You-Sheng Yang (vicamo)
importance: Undecided → High
status: New → In Progress
Changed in linux-oem-5.13 (Ubuntu Hirsute):
status: New → Invalid
Changed in linux-oem-5.13 (Ubuntu Impish):
status: New → Invalid
Changed in linux-oem-5.10 (Ubuntu Focal):
assignee: nobody → You-Sheng Yang (vicamo)
importance: Undecided → High
status: New → In Progress
Changed in linux (Ubuntu Hirsute):
assignee: nobody → You-Sheng Yang (vicamo)
importance: Undecided → High
status: New → In Progress
Changed in linux (Ubuntu Impish):
assignee: nobody → You-Sheng Yang (vicamo)
importance: Undecided → High
status: New → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers