Fail to detect audio output from external monitor

Bug #1948767 reported by Chris Chiu
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Hirsute
Undecided
Unassigned
Impish
Undecided
Unassigned
linux-oem-5.13 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Hirsute
Undecided
Unassigned
Impish
Undecided
Unassigned
linux-oem-5.14 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Hirsute
Undecided
Unassigned
Impish
Undecided
Unassigned

Bug Description

[SRU Justification]

[Impact]
Few recent AMD systems shows "snd_hda_intel 0000:00:1f.3: azx_get_response timeout" and fail to detect the HDMI/DP audio output device when connects to external monitor. It will work magically when re-loading the driver.

[Fix]
Backport the upstream fix c0f1886de7e1 ("Allow repeatedly probing on codec configuration errors) from 5.15.0 rc. It adds the capability for retrying the probe upon codec probe errors on the certain AMD platforms.

[Test]
1. Connect the external monitor to particular affected AMD systems with HDMI or DisplayPort.
2. Go to Audio Settings to check if the HDMI/DP audio output device exist or not.

[Where problems could occur]
Should be low risk, it adds the chance for retrying codec probe and won't affect machines which used to work.

========== Original Bug Description ==========

Can not detect DP audio output
[Steps to reproduce]
1) install dell-bto-focal-fossa-grimer-rkl-X72-20210929-8.iso and boot into OS
2) switch to on-demand mode
3) connect an external monitor via DP Port
4) check sound setting --> Output Device
5) switch to performance mode
6) check sound setting --> Output Device

[Expected result]
System can detect DP audio output when external monitor connected

[Actual result]
Can not detect DP audio output
This issue can be reproduce in on-demand and performance mode.
[Failure rate]
1/1

[Additional information]
CID: 202101-28624
SKU: PRH-DVT-C6
Image: canonical-oem-somerville-focal-amd64-20200502-85+fossa-grimer-rkl+X72
system-manufacturer: Dell Inc.
system-product-name: OptiPlex 5490 AIO
bios-version: 1.4.1
CPU: 11th Gen Intel(R) Core(TM) i7-11700 @ 2.50GHz (16x)
GPU: 00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:4c8a] (rev 04)
01:00.0 3D controller [0302]: NVIDIA Corporation Device [10de:1f99] (rev a1)
kernel-version: 5.14.0-2006-oem
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu27.16
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gdm 1081 F.... pulseaudio
                      u 1592 F.... pulseaudio
CasperMD5CheckResult: skip
DistributionChannelDescriptor:
 # This is the distribution channel descriptor for the OEM CDs
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-focal-amd64-20200502-85+fossa-proposed-release+X88
DistroRelease: Ubuntu 20.04
InstallationDate: Installed on 2021-10-27 (1 days ago)
InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 20200502-05:58
MachineType: Dell Inc. OptiPlex 5490 AIO
NonfreeKernelModules: nvidia_modeset nvidia
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.10.0-1020-oem root=UUID=d0e48268-091a-436d-8b79-2420e385c5c8 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 5.10.0-1020.21-oem 5.10.25
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-5.10.0-1020-oem N/A
 linux-backports-modules-5.10.0-1020-oem N/A
 linux-firmware 1.187.10
Tags: focal
Uname: Linux 5.10.0-1020-oem x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: N/A
_MarkForUpload: True
dmi.bios.date: 08/17/2021
dmi.bios.release: 1.4
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.4.1
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 13
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.4.1:bd08/17/2021:br1.4:svnDellInc.:pnOptiPlex5490AIO:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct13:cvr:
dmi.product.family: OptiPlex
dmi.product.name: OptiPlex 5490 AIO
dmi.product.sku: 0A48
dmi.sys.vendor: Dell Inc.

Chris Chiu (mschiu77)
Changed in linux-oem-5.13 (Ubuntu Hirsute):
status: New → Invalid
Changed in linux-oem-5.13 (Ubuntu Impish):
status: New → Invalid
Changed in linux-oem-5.14 (Ubuntu Hirsute):
status: New → Invalid
Changed in linux-oem-5.14 (Ubuntu Impish):
status: New → Invalid
Changed in linux-oem-5.13 (Ubuntu Focal):
status: New → In Progress
Changed in linux-oem-5.14 (Ubuntu Focal):
status: New → In Progress
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1948767

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Focal):
status: New → Incomplete
Changed in linux (Ubuntu Hirsute):
status: New → Incomplete
Changed in linux (Ubuntu Impish):
status: New → Incomplete
Chris Chiu (mschiu77)
Changed in linux (Ubuntu Hirsute):
status: Incomplete → In Progress
Changed in linux (Ubuntu Impish):
status: Incomplete → In Progress
tags: added: oem-priority originate-from-1946054 somerville
Revision history for this message
Chris Chiu (mschiu77) wrote : AlsaInfo.txt

apport information

tags: added: apport-collected focal
description: updated
Revision history for this message
Chris Chiu (mschiu77) wrote : CRDA.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : CurrentDmesg.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : IwConfig.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : Lspci.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : Lspci-vt.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : Lsusb.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : Lsusb-t.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : Lsusb-v.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : ProcCpuinfoMinimal.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : ProcInterrupts.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : ProcModules.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : RfKill.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : UdevDb.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : WifiSyslog.txt

apport information

Revision history for this message
Chris Chiu (mschiu77) wrote : acpidump.txt

apport information

Timo Aaltonen (tjaalton)
Changed in linux-oem-5.13 (Ubuntu Focal):
status: In Progress → Fix Committed
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.14 (Ubuntu Focal):
status: In Progress → Fix Committed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-oem-5.13/5.13.0-1019.23 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Changed in linux (Ubuntu Hirsute):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Impish):
status: In Progress → Fix Committed
Chris Chiu (mschiu77)
tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package linux-oem-5.13 - 5.13.0-1019.23

---------------
linux-oem-5.13 (5.13.0-1019.23) focal; urgency=medium

  * focal/linux-oem-5.13: 5.13.0-1019.23 -proposed tracker (LP: #1949076)

  * Fail to detect audio output from external monitor (LP: #1948767)
    - ALSA: hda: intel: Allow repeatedly probing on codec configuration errors

  * Intel I225-IT ethernet controller: igc: probe of 0000:02:00.0 failed with
    error -1 (LP: #1945576)
    - igc: Remove _I_PHY_ID checking
    - igc: Remove phy->type checking

  * Fix Screen freeze after resume from suspend with iGPU [1002:6987]
    (LP: #1949050)
    - drm/amdgpu: reenable BACO support for 699F:C7 polaris12 SKU
    - drm/amdgpu: add missing cleanups for Polaris12 UVD/VCE on suspend
    - drm/amdgpu: Fix crash on device remove/driver unload

  * Need support of Qualcomm WCN6856 (LP: #1939528)
    - Revert "UBUNTU: SAUCE: Bluetooth: btusb: Add support using different nvm for
      variant WCN6855 controller"
    - Revert "UBUNTU: SAUCE: cfg80211: save power spectral density(psd) of
      regulatory rule"
    - Revert "UBUNTU: SAUCE: cfg80211: add definition for 6 GHz power spectral
      density(psd)"
    - Revert "UBUNTU: SAUCE: ath11k: set correct NL80211_FEATURE_DYNAMIC_SMPS for
      WCN6855"
    - Revert "mac80211: save transmit power envelope element and power constraint"
    - Revert "mac80211: add parse regulatory info in 6 GHz operation information"
    - Revert "ieee80211: add power type definition for 6 GHz"
    - Revert "mac80211: use ieee802_11_parse_elems() in ieee80211_prep_channel()"
    - Revert "mac80211: always allocate struct ieee802_11_elems"
    - Revert "mac80211: mlme: find auth challenge directly"
    - Revert "mac80211: move CRC into struct ieee802_11_elems"
    - Revert "mac80211: mesh: clean up rx_bcn_presp API"
    - Revert "ath11k: support SMPS configuration for 6 GHz"
    - Revert "ath11k: add 6 GHz params in peer assoc command"
    - Revert "ieee80211: Add new A-MPDU factor macro for HE 6 GHz peer caps"
    - Revert "ath11k: copy cap info of 6G band under WMI_HOST_WLAN_5G_CAP for
      WCN6855"
    - Revert "ath11k: enable 6G channels for WCN6855"
    - Revert "ath11k: re-enable ht_cap/vht_cap for 5G band for WCN6855"
    - Revert "ath11k: fix survey dump collection in 6 GHz"
    - Revert "ath11k: fix packet drops due to incorrect 6 GHz freq value in rx
      status"
    - Revert "ath11k: add channel 2 into 6 GHz channel list"
    - Revert "ath11k: qmi: avoid error messages when dma allocation fails"
    - Revert "mac80211: parse transmit power envelope element"
    - Revert "ieee80211: add definition for transmit power envelope element"
    - Revert "ieee80211: add definition of regulatory info in 6 GHz operation
      information"
    - Revert "mac80211: notify driver on mgd TX completion"
    - Revert "ath11k: don't call ath11k_pci_set_l1ss for WCN6855"
    - Revert "ath11k: add support for WCN6855"
    - Revert "ath11k: add support to get peer id for WCN6855"
    - Revert "ath11k: setup WBM_IDLE_LINK ring once again"
    - Revert "ath11k: setup REO for WCN6855"
    - Revert "ath11k: add dp support for WCN6855"
    - Revert "ath11k:...

Read more...

Changed in linux-oem-5.13 (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-5.14 - 5.14.0-1007.7

---------------
linux-oem-5.14 (5.14.0-1007.7) focal; urgency=medium

  * focal/linux-oem-5.14: 5.14.0-1007.7 -proposed tracker (LP: #1949349)

  * Intel I225-IT ethernet controller: igc: probe of 0000:02:00.0 failed with
    error -1 (LP: #1945576)
    - igc: Remove _I_PHY_ID checking
    - igc: Remove phy->type checking

  * Fix Screen freeze after resume from suspend with iGPU [1002:6987]
    (LP: #1949050)
    - drm/amdgpu: reenable BACO support for 699F:C7 polaris12 SKU
    - drm/amdgpu: add missing cleanups for Polaris12 UVD/VCE on suspend
    - drm/amdgpu: Fix crash on device remove/driver unload

  * Fail to detect audio output from external monitor (LP: #1948767)
    - ALSA: hda: intel: Allow repeatedly probing on codec configuration errors

  * Fix System hangs on black screen when reboot (LP: #1949321)
    - SAUCE: drm/i915: Don't request GMBUS to generate irqs when called while irqs
      are off
    - SAUCE: drm/i915/hdmi: Turn DP++ TMDS output buffers back on in
      encoder->shutdown()

 -- Timo Aaltonen <email address hidden> Mon, 01 Nov 2021 12:38:15 +0200

Changed in linux-oem-5.14 (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux/5.13.0-22.22 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-impish' to 'verification-done-impish'. If the problem still exists, change the tag 'verification-needed-impish' to 'verification-failed-impish'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-impish
tags: added: verification-needed-hirsute
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux/5.11.0-41.45 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-hirsute' to 'verification-done-hirsute'. If the problem still exists, change the tag 'verification-needed-hirsute' to 'verification-failed-hirsute'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Chris Chiu (mschiu77)
tags: added: verification-done-hirsute verification-done-impish
removed: verification-needed-hirsute verification-needed-impish
Changed in linux-oem-5.13 (Ubuntu):
status: New → Invalid
Changed in linux-oem-5.14 (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers