Headphone microphone not working on particular Dell laptops

Bug #1947092 reported by Chris Chiu
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Hirsute
Undecided
Unassigned
Impish
Undecided
Unassigned
linux-oem-5.13 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Hirsute
Undecided
Unassigned
Impish
Undecided
Unassigned
linux-oem-5.14 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Hirsute
Undecided
Unassigned
Impish
Undecided
Unassigned

Bug Description

[SRU Justification]

[Impact]
The Dell Latitude 5430 series with Realtek audio codec ALC3254 fail to detect the headphone microphone and thus unable to do recording.

[Fix]
The realtek audio quirk ALC269_FIXUP_DELL4_MIC_NO_PRESENCE is required since the NID used for headphone microphone should be 0x1b instead of 0x1a, which is used for former ALC225/295 variants.

[Test Case]
1. Plug in the headphone microphone on the particular Dell Latitude 5430 laptop
2. Make sure it's detected in Audio Settings. (pulseaudio)
3. Record the sound via the headphone microphone and check the recorded content.

[Where problems could occur]
No. Since the audio quirk only affect the machine with particular subsystem ID.

Chris Chiu (mschiu77)
Changed in linux-oem (Ubuntu Hirsute):
status: New → Invalid
Changed in linux-oem (Ubuntu Impish):
status: New → Invalid
no longer affects: linux-oem (Ubuntu)
Changed in linux-oem-5.13 (Ubuntu Hirsute):
status: New → Invalid
Changed in linux-oem-5.13 (Ubuntu Impish):
status: New → Invalid
Changed in linux-oem-5.14 (Ubuntu Hirsute):
status: New → Invalid
Changed in linux-oem-5.14 (Ubuntu Impish):
status: New → Invalid
no longer affects: linux-oem (Ubuntu Focal)
no longer affects: linux-oem (Ubuntu Hirsute)
no longer affects: linux-oem (Ubuntu Impish)
Changed in linux (Ubuntu Focal):
status: New → In Progress
Changed in linux-oem-5.13 (Ubuntu Focal):
status: New → In Progress
Changed in linux-oem-5.14 (Ubuntu Focal):
status: New → In Progress
Changed in linux (Ubuntu Hirsute):
status: New → In Progress
Changed in linux (Ubuntu Impish):
status: New → In Progress
Chris Chiu (mschiu77)
tags: added: oem-priority originate-from-1940584 somerville
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.13 (Ubuntu Focal):
status: In Progress → Fix Committed
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.14 (Ubuntu Focal):
status: In Progress → Fix Committed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-oem-5.13/5.13.0-1018.22 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package linux-oem-5.13 - 5.13.0-1019.23

---------------
linux-oem-5.13 (5.13.0-1019.23) focal; urgency=medium

  * focal/linux-oem-5.13: 5.13.0-1019.23 -proposed tracker (LP: #1949076)

  * Fail to detect audio output from external monitor (LP: #1948767)
    - ALSA: hda: intel: Allow repeatedly probing on codec configuration errors

  * Intel I225-IT ethernet controller: igc: probe of 0000:02:00.0 failed with
    error -1 (LP: #1945576)
    - igc: Remove _I_PHY_ID checking
    - igc: Remove phy->type checking

  * Fix Screen freeze after resume from suspend with iGPU [1002:6987]
    (LP: #1949050)
    - drm/amdgpu: reenable BACO support for 699F:C7 polaris12 SKU
    - drm/amdgpu: add missing cleanups for Polaris12 UVD/VCE on suspend
    - drm/amdgpu: Fix crash on device remove/driver unload

  * Need support of Qualcomm WCN6856 (LP: #1939528)
    - Revert "UBUNTU: SAUCE: Bluetooth: btusb: Add support using different nvm for
      variant WCN6855 controller"
    - Revert "UBUNTU: SAUCE: cfg80211: save power spectral density(psd) of
      regulatory rule"
    - Revert "UBUNTU: SAUCE: cfg80211: add definition for 6 GHz power spectral
      density(psd)"
    - Revert "UBUNTU: SAUCE: ath11k: set correct NL80211_FEATURE_DYNAMIC_SMPS for
      WCN6855"
    - Revert "mac80211: save transmit power envelope element and power constraint"
    - Revert "mac80211: add parse regulatory info in 6 GHz operation information"
    - Revert "ieee80211: add power type definition for 6 GHz"
    - Revert "mac80211: use ieee802_11_parse_elems() in ieee80211_prep_channel()"
    - Revert "mac80211: always allocate struct ieee802_11_elems"
    - Revert "mac80211: mlme: find auth challenge directly"
    - Revert "mac80211: move CRC into struct ieee802_11_elems"
    - Revert "mac80211: mesh: clean up rx_bcn_presp API"
    - Revert "ath11k: support SMPS configuration for 6 GHz"
    - Revert "ath11k: add 6 GHz params in peer assoc command"
    - Revert "ieee80211: Add new A-MPDU factor macro for HE 6 GHz peer caps"
    - Revert "ath11k: copy cap info of 6G band under WMI_HOST_WLAN_5G_CAP for
      WCN6855"
    - Revert "ath11k: enable 6G channels for WCN6855"
    - Revert "ath11k: re-enable ht_cap/vht_cap for 5G band for WCN6855"
    - Revert "ath11k: fix survey dump collection in 6 GHz"
    - Revert "ath11k: fix packet drops due to incorrect 6 GHz freq value in rx
      status"
    - Revert "ath11k: add channel 2 into 6 GHz channel list"
    - Revert "ath11k: qmi: avoid error messages when dma allocation fails"
    - Revert "mac80211: parse transmit power envelope element"
    - Revert "ieee80211: add definition for transmit power envelope element"
    - Revert "ieee80211: add definition of regulatory info in 6 GHz operation
      information"
    - Revert "mac80211: notify driver on mgd TX completion"
    - Revert "ath11k: don't call ath11k_pci_set_l1ss for WCN6855"
    - Revert "ath11k: add support for WCN6855"
    - Revert "ath11k: add support to get peer id for WCN6855"
    - Revert "ath11k: setup WBM_IDLE_LINK ring once again"
    - Revert "ath11k: setup REO for WCN6855"
    - Revert "ath11k: add dp support for WCN6855"
    - Revert "ath11k:...

Read more...

Changed in linux-oem-5.13 (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers