system can't detect external microphone with the codec alc274

Bug #1731822 reported by Hui Wang
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Critical
Hui Wang
linux-oem (Ubuntu)
Critical
Hui Wang
Xenial
Undecided
Unassigned

Bug Description

After installing the latest artful kernel (Ubuntu-4.13.0-16.19), and boot up the system with this kernel, we plug a headset to the headset jack, then open the gnome-sound-setting, but we can not see the headset microphone in it, there is only one internal microphone in it, as a result we can't record the sound with the headset microphone.

This Dell machine has audio codec alc274, it needs to apply a fixup like ALC269_FIXUP_DELL1_MIC_NO_PRESENCE.

After applying this fixup in the kernel driver, the headset mic can be detected and works fine.

Hui Wang (hui.wang)
Changed in linux (Ubuntu):
assignee: nobody → Hui Wang (hui.wang)
Changed in hwe-next:
importance: Undecided → Critical
Changed in linux (Ubuntu):
importance: Undecided → Critical
tags: added: artful originate-from-1728816 somerville
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1731822

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Hui Wang (hui.wang)
Changed in hwe-next:
status: New → Triaged
Hui Wang (hui.wang)
description: updated
Stefan Bader (smb)
affects: linux (Ubuntu) → linux-oem (Ubuntu)
Hui Wang (hui.wang)
Changed in linux-oem (Ubuntu):
status: Incomplete → Fix Committed
Changed in hwe-next:
status: Triaged → Fix Committed
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

fixed in -1009

Changed in linux-oem (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux-oem (Ubuntu Xenial):
status: New → Fix Released
Changed in hwe-next:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers