Acer, Inc ID 5986:055a is useless after 14.04.2 installed.

Bug #1433906 reported by Gabriel Zhi Chen on 2015-03-19
288
This bug affects 52 people
Affects Status Importance Assigned to Milestone
HWE Next
High
Unassigned
Fedora
Fix Released
Undecided
linux (Arch Linux)
New
Undecided
Unassigned
linux (Ubuntu)
High
Joseph Salisbury
Xenial
High
Arpan Das
Yakkety
Undecided
Unassigned
linux-lts-vivid (Ubuntu)
High
Unassigned
Yakkety
Undecided
Unassigned
linux-lts-xenial (Ubuntu)
High
Unassigned
Yakkety
Undecided
Unassigned

Bug Description

CID : 201411-16166 Lenovo E450 (I+A) with 14.04.2 (utopic)
CID : 201408-15472 Lenovo E555 (A+A) with 14.04.2 (utopic)

Steps:
1. Install 14.04.2 on E450 or E555.
2. Log in system and open a terminal.
3. $ gst-launch-0.10 v4l2src ! xvimagesink

Expected result:
Camara is activated

Actual result:
$ gst-launch-0.10 v4l2src ! xvimagesink
Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Cannot identify device '/dev/video0'.
Additional debug info:
v4l2_calls.c(497): gst_v4l2_open (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src0:
system error: No such file or directory
Setting pipeline to NULL ...
Freeing pipeline ...

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.16.0-30-generic 3.16.0-30.40~14.04.1 [modified: boot/vmlinuz-3.16.0-30-generic]
ProcVersionSignature: Ubuntu 3.16.0-30.40~14.04.1-generic 3.16.7-ckt3
Uname: Linux 3.16.0-30-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.14.1-0ubuntu3.7
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Mar 19 02:21:31 2015
InstallationDate: Installed on 2015-03-16 (2 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
SourcePackage: linux-lts-utopic
UpgradeStatus: No upgrade log present (probably fresh install)

CVE References

Gabriel Zhi Chen (gabrielzchen) wrote :
description: updated
tags: added: blocks-hwcert
Keng-Yu Lin (lexical) wrote :

@Gabriel, can you attach more logs like apport-log does? (at least need `lsusb` `/var/log/kern.log` `/var/log/syslog`)

Gabriel Zhi Chen (gabrielzchen) wrote :
Gabriel Zhi Chen (gabrielzchen) wrote :
Gabriel Zhi Chen (gabrielzchen) wrote :
Keng-Yu Lin (lexical) wrote :

Mar 25 00:29:21 201501-16541 kernel: [ 6.428942] uvcvideo: Found UVC 1.00 device Integrated Camera (5986:055a)
Mar 25 00:29:21 201501-16541 kernel: [ 6.429042] uvcvideo: No valid video chain found.
Mar 25 00:29:21 201501-16541 kernel: [ 6.429112] usbcore: registered new interface driver uvcvideo
Mar 25 00:29:21 201501-16541 kernel: [ 6.429114] USB Video Class driver (1.1.1)
Mar 25 00:29:21 201501-16541 kernel: [ 6.478495] dev_addr: 30:10:b3:c9:76:ae
Mar 25 00:29:21 201501-16541 kernel: [ 6.478505] RT Customized ID: 0x12
Mar 25 00:29:21 201501-16541 kernel: [ 6.518553] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input8

Changed in hwe-next:
importance: Undecided → High
Changed in linux-lts-utopic (Ubuntu):
importance: Undecided → High
Keng-Yu Lin (lexical) on 2015-04-07
Changed in hwe-next:
assignee: nobody → AceLan Kao (acelankao)
status: New → Confirmed
tags: added: 201501-16542
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-lts-utopic (Ubuntu):
status: New → Confirmed
Changed in linux-lts-vivid (Ubuntu):
status: New → Confirmed
1 comments hidden view all 123 comments
Stuart McGinn (stuart-mcginn) wrote :

Samir Ibradžić (sibradzic) - I read the details of your patch, but not sure how to apply it (limited Linux skills!!). I'm having the same issue with this camera on Ubuntu 15.04. Laptop is a new Thinkpad E550.

Will your patch work on 15.04 while we wait for a fix to come through? Any instruction on how to apply it would be great, as not having the webcam working is causing me a real problem.

Many thanks!

An Laoch (diarmuid) wrote :

I have the same problem with the Lenovo E550 and Ubuntu 14.04. Could really do with getting this fixed.

sib (alexsibeth) wrote :

I would also like to add that I am having the same problem with Lenovo E550, European edition on Ubuntu 14.04 and 15.04, clean installs.

Gary G. (happyrat1) wrote :

Also affects me with a Lenovo Thinkpad E550 running KXstudio 14.04

Current workaround is an old Logitech UVC desktop webcam perched on top of my laptop.

NOT Pretty! :P

Gary

Stefano (stefanogarzarella) wrote :

I have the same BUG on Lenovo L450 with Ubuntu 14.04 LTS and linux 3.19.0-30-generic.

Arne Beer (i-arne) wrote :

Same Problem over here. Just gut a brand new Lenovo L450.

Dmesg:
[61622.189509] usbcore: deregistering interface driver uvcvideo
[61626.768820] uvcvideo: Found UVC 1.00 device Integrated Camera (5986:055a)
[61626.768935] uvcvideo: No valid video chain found.
[61626.769190] usbcore: registered new interface driver uvcvideo
[61626.769192] USB Video Class driver (1.1.1)

lsusb -vvv Output:
http://pastebin.com/fy5gmtvb

Pierre Equoy (pieq) wrote :

A similar issue [1] has been reported on the Launchpad Answers website for Lenovo ThinkPad Edge E550.

[1] https://answers.launchpad.net/ubuntu-certification/+question/272285

sarthak (sarthak0415) wrote :

I have the same problem. Its frustrating and I have to switch between windows and ubuntu again and again.

output of `lsb_release -a`
``` $bash
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.3 LTS
Release: 14.04
Codename: trusty

` uname -a `
```$bash
Linux sarthak-ThinkPad-E550 3.19.0-31-generic #36~14.04.1-Ubuntu SMP Thu Oct 8 10:21:08 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

` sudo lsusb `
```$bash
Bus 003 Device 002: ID 8087:8001 Intel Corp.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 5986:055a Acer, Inc
Bus 001 Device 003: ID 8087:0a2a Intel Corp.
Bus 001 Device 002: ID 138a:0011 Validity Sensors, Inc. VFS5011 Fingerprint Reader
Bus 001 Device 005: ID 05c6:f003 Qualcomm, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Changed in linux-lts-utopic (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Changed in hwe-next:
assignee: AceLan Kao (acelankao) → nobody
status: Confirmed → Won't Fix
Radim (krivosik) wrote :

Hello all,
I have the same problem with webcam on my Lenovo E555. Ubuntu 15.04.

Bus 006 Device 002: ID 5986:055a Acer, Inc

BR
Radim

Henrik Ingo (hingo) wrote :

Hi

I've been analyzing this and proposed some solutions. See http://sourceforge.net/p/linux-uvc/mailman/message/34681976/

I don't know what the kernel maintainers want from a fix, but for those of us who use (K)ubuntu on a Lenovo, I think it would make us very happy to simply do my last proposal: set entity[id=3]->baSourceID = 4 and we get a working web cam. I will send such a patch shortly.

Henrik Ingo (hingo) wrote :

Hi

I've submitted a patch that fixes this issue. Maybe give it a few days for comments, but would be great if Ubuntu could incorporate this patch ahead of upstream, since a lot of us seem to be using Lenovo. (Thinkpad used to be known as a brand that just worked with Linux, sad to see it's no longer true...)

http://sourceforge.net/p/linux-uvc/mailman/message/34684737/

tags: added: patch
Gary G. (happyrat1) wrote :

While it's wonderful that a patch has been created, could someone out there PLEASE wrap it up in a nice and simple .DEB package so the rest of us idiots can install it without having to manually recompile the kernel?

After all, most of us *buntu users are simpletons who can't work a BASH shell if our lives depended on it, at least if you go by the continual dumbing down of the interface with each successive version :P

hannes s (temporaer) wrote :

If you want to try yourself, this is what worked for me on a E550, Ubuntu 15.10:

uname -a
# check your current kernel version, then download the same version
# note, no root!
apt-get source linux-image-extra-4.2.0-19-generic
# install packages needed to build the kernel
sudo apt-get build-dep linux-image-extra-4.2.0-19-generic
sudo apt-get install git
cd linux-4.2.0
wget -O webcam.patch https://launchpadlibrarian.net/229627414/0001-uvcvideo-Acer-Integrated-Camera-5986-055a-add-UVC_QU.patch
git apply webcam.patch

you can now change the version in debian/changelog, adding "-webcam" or something of the like, which makes it easier to identify your kernel package.

DEB_BUILD_OPTIONS=parallel=4 AUTOBUILD=1 NOEXTRAS=1 fakeroot debian/rules binary-generic
# now wait until kernel is built, this takes some time
sudo dpkg -i ../linux-headers*.deb ../linux-image*.deb

Then, reboot.
You'll have to repeat this process if Ubuntu updates kernel.

Hi Henrik,

Thanks for your post. I am not familiar with patches. Can you tell me how
to apply it?

Best regards,
Victor.

2015-12-10 21:24 GMT+01:00 Henrik Ingo <email address hidden>:

> ** Patch added:
> "0001-uvcvideo-Acer-Integrated-Camera-5986-055a-add-UVC_QU.patch"
>
> https://bugs.launchpad.net/ubuntu/+source/linux-lts-utopic/+bug/1433906/+attachment/4532782/+files/0001-uvcvideo-Acer-Integrated-Camera-5986-055a-add-UVC_QU.patch
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1433906
>
> Title:
> Acer, Inc ID 5986:055a is useless after 14.04.2 installed.
>
> Status in HWE Next:
> Won't Fix
> Status in linux-lts-utopic package in Ubuntu:
> Confirmed
> Status in linux-lts-vivid package in Ubuntu:
> Confirmed
> Status in linux package in Arch Linux:
> New
> Status in Fedora:
> Unknown
>
> Bug description:
> CID : 201411-16166 Lenovo E450 (I+A) with 14.04.2 (utopic)
> CID : 201408-15472 Lenovo E555 (A+A) with 14.04.2 (utopic)
>
> Steps:
> 1. Install 14.04.2 on E450 or E555.
> 2. Log in system and open a terminal.
> 3. $ gst-launch-0.10 v4l2src ! xvimagesink
>
> Expected result:
> Camara is activated
>
> Actual result:
> $ gst-launch-0.10 v4l2src ! xvimagesink
> Setting pipeline to PAUSED ...
> ERROR: Pipeline doesn't want to pause.
> ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Cannot
> identify device '/dev/video0'.
> Additional debug info:
> v4l2_calls.c(497): gst_v4l2_open ():
> /GstPipeline:pipeline0/GstV4l2Src:v4l2src0:
> system error: No such file or directory
> Setting pipeline to NULL ...
> Freeing pipeline ...
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: linux-image-3.16.0-30-generic 3.16.0-30.40~14.04.1 [modified:
> boot/vmlinuz-3.16.0-30-generic]
> ProcVersionSignature: Ubuntu 3.16.0-30.40~14.04.1-generic 3.16.7-ckt3
> Uname: Linux 3.16.0-30-generic x86_64
> NonfreeKernelModules: fglrx
> ApportVersion: 2.14.1-0ubuntu3.7
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Thu Mar 19 02:21:31 2015
> InstallationDate: Installed on 2015-03-16 (2 days ago)
> InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64
> (20150218.1)
> SourcePackage: linux-lts-utopic
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hwe-next/+bug/1433906/+subscriptions
>

Ralf Lübben (ralfluebben) wrote :

Hi,

a few command lines that install the patch, the patch mentioned above is attached as file

# download patches to ~/Software/CameraPatch/
# mkdir ~/debian/src

cd ~/debian/src

#get the source
apt-get source linux-image-$(uname -r)
cd linux-4.2.0
cp ~/Software/CameraPatch/*.patch ./

# aplly the patch
patch -p1 < uvc.patch

cd drivers/media/usb/uvc/

# compile the module
make -C /lib/modules/$(uname -r)/build M=$(pwd) modules

# install the module
sudo make -C /lib/modules/$(uname -r)/build M=$(pwd) modules_install

# depmod from modules_install fails, redo it
sudo depmod

#unload/load module, the camera should work
sudo rmmod uvcvideo
sudo modprobe uvcvideo

Changed in linux-lts-utopic (Ubuntu):
status: Confirmed → Triaged
Changed in linux-lts-vivid (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Vladimir (kovalchyk-vm) on 2016-02-05
information type: Public → Public Security
information type: Public Security → Public
Henrik Ingo (hingo) wrote :

Hi

Just wanted to ask Canonical guys: It's encouraging to see some activity on this ticket, is there any chance this will actually get into Ubuntu before next .04 release? (Or, if next release is an LTS, is there any chance this will get in right after that?)

(Yeah, I'm lazy, I don't even compile my own kernel from source, let alone my parents'...)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-lts-wily (Ubuntu):
status: New → Confirmed
iBen (iben) wrote :

I have upgraded to 16.04 Xenial and the bug still exists.

What is more, I cannot install the patched kernel module, because it exits with and SSL error:

make: Entering directory '/usr/src/linux-headers-4.4.0-21-generic'
  INSTALL /home/user1/debian/src/linux-4.4.0/drivers/media/usb/uvc/uvcvideo.ko
At main.c:222:
- SSL error:02001002:system library:fopen:No such file or directory: bss_file.c:175
- SSL error:2006D080:BIO routines:BIO_new_file:no such file: bss_file.c:178
sign-file: certs/signing_key.pem: No such file or directory
  DEPMOD 4.4.0-21-generic

Any suggestions?

sarthak (sarthak0415) wrote :

Is the patch working for anyone?
If yes then please give me the instructions(or .deb file) .

I tried the one suggested by Ralf but it dosent work somehow.

output of ` uname -a `
```$bash
Linux sarthak-ThinkPad-E550 3.19.0-31-generic #36~14.04.1-Ubuntu SMP Thu Oct 8 10:21:08 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
```

iBen (iben) wrote :

OK, I had to manually generate the cert for the kernel source, after that it let me install the patched module.

Camera works with the patched module on Xenial, kernel 4.4.0.21.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-lts-xenial (Ubuntu):
status: New → Confirmed
Vipin (vipinmsx-z) wrote :

Its affecting fresh install of 16.04 LTS. Canonical, please fix it.

@iBen : Could you please tell me how to create cert for kernel source ?

Reinhard Kreuzer (rkreuzer) wrote :

Hi,

I'm using a Lenovo Thinkpad E555 with Ubuntu 16.04 Unity.
I applied the patch from Ralf Lübben and now the webcam works.
Though, the patch didn't work at first due to wrong path '--- a/drivers/...' and '+++ b/driver/...', but typing the full path manually after it asked me to worked fine.

Thank you,
Reinhard

Victor van der Lee (vic-vdlee) wrote :

Can someone please post the solution for someone (like me) who doesn't
write code ?

Thank you,
Victor.

2016-05-05 13:51 GMT+02:00 Reinhard Kreuzer <email address hidden>:

> Hi,
>
> I'm using a Lenovo Thinkpad E555 with Ubuntu 16.04 Unity.
> I applied the patch from Ralf Lübben and now the webcam works.
> Though, the patch didn't work at first due to wrong path '---
> a/drivers/...' and '+++ b/driver/...', but typing the full path manually
> after it asked me to worked fine.
>
> Thank you,
> Reinhard
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1433906
>
> Title:
> Acer, Inc ID 5986:055a is useless after 14.04.2 installed.
>
> Status in HWE Next:
> Won't Fix
> Status in linux-lts-utopic package in Ubuntu:
> Triaged
> Status in linux-lts-vivid package in Ubuntu:
> Triaged
> Status in linux-lts-wily package in Ubuntu:
> Confirmed
> Status in linux-lts-xenial package in Ubuntu:
> Confirmed
> Status in linux package in Arch Linux:
> New
> Status in Fedora:
> Unknown
>
> Bug description:
> CID : 201411-16166 Lenovo E450 (I+A) with 14.04.2 (utopic)
> CID : 201408-15472 Lenovo E555 (A+A) with 14.04.2 (utopic)
>
> Steps:
> 1. Install 14.04.2 on E450 or E555.
> 2. Log in system and open a terminal.
> 3. $ gst-launch-0.10 v4l2src ! xvimagesink
>
> Expected result:
> Camara is activated
>
> Actual result:
> $ gst-launch-0.10 v4l2src ! xvimagesink
> Setting pipeline to PAUSED ...
> ERROR: Pipeline doesn't want to pause.
> ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Cannot
> identify device '/dev/video0'.
> Additional debug info:
> v4l2_calls.c(497): gst_v4l2_open ():
> /GstPipeline:pipeline0/GstV4l2Src:v4l2src0:
> system error: No such file or directory
> Setting pipeline to NULL ...
> Freeing pipeline ...
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: linux-image-3.16.0-30-generic 3.16.0-30.40~14.04.1 [modified:
> boot/vmlinuz-3.16.0-30-generic]
> ProcVersionSignature: Ubuntu 3.16.0-30.40~14.04.1-generic 3.16.7-ckt3
> Uname: Linux 3.16.0-30-generic x86_64
> NonfreeKernelModules: fglrx
> ApportVersion: 2.14.1-0ubuntu3.7
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Thu Mar 19 02:21:31 2015
> InstallationDate: Installed on 2015-03-16 (2 days ago)
> InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64
> (20150218.1)
> SourcePackage: linux-lts-utopic
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hwe-next/+bug/1433906/+subscriptions
>

Teq (suse-teq) wrote :

Same problem on fresh install of Xubuntu 16.04 on ThinkPad E450.
Still no resolution for this?

Should I try to struggle with the patch or wait and hope?

Nish Aravamudan (nacc) wrote :

To clarify to everyone possibly affected by this bug, and in reviewing the thread @Henrik provided, it seems like the upstream community (linux-uvc) has reviewed the patch and asked for some modifications (April 27, 2016). So that is why the patch has not made its way into Ubuntu kernels yet, as it's not yet fixed upstream.

@Henrik, do you have any update on that side of things? Thank you for helping make Linux & Ubuntu better!

Henrik Ingo (hingo) wrote :

Hi

The update is that after receiving the latest review (which itself took some time), it's taken quite long for me to context switch back to implement the requested changes. I do have an editor open in front of me right now, so hopefully it can happen in the next few days.

The review comments were about code organization and style. I do expect the next patch to be approved (with minor comments, at most). The upstream list is quite silent, so might take additional time for it to be committed to the kernel though.

Both patches I've sent do fix the actual problem though.

Brad Figg (brad-figg) on 2016-05-26
no longer affects: linux-lts-xenial (Ubuntu Xenial)
no longer affects: linux-lts-wily (Ubuntu Xenial)
no longer affects: linux-lts-vivid (Ubuntu Xenial)
no longer affects: linux-lts-utopic (Ubuntu Xenial)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1433906

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Brad Figg (brad-figg) wrote :

@henrik,

As soon as you have your new patches ready, add them to this bug and we'll get them into test kernels and then into updated kernels.

Thanks for the work on this. Sorry that it's taken so long to get our attention.

ApportVersion: 2.14.1-0ubuntu3.21
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: vd 1651 F.... pulseaudio
 /dev/snd/controlC1: vd 1651 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
HibernationDevice: RESUME=UUID=b89d281e-a7ba-48c4-87e8-87281273b903
InstallationDate: Installed on 2015-12-16 (161 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
MachineType: LENOVO 20DFCTO1WW
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-74-generic root=UUID=8e84fc20-1020-48d4-8d17-8d0bc455e570 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-74.118-generic 3.13.11-ckt30
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-74-generic N/A
 linux-backports-modules-3.13.0-74-generic N/A
 linux-firmware 1.127.22
Tags: trusty trusty
Uname: Linux 3.13.0-74-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 07/15/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: J5ET46WW (1.17 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20DFCTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: SDK0E50512 STD
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrJ5ET46WW(1.17):bd07/15/2015:svnLENOVO:pn20DFCTO1WW:pvrThinkPadE550:rvnLENOVO:rn20DFCTO1WW:rvrSDK0E50512STD:cvnLENOVO:ct10:cvrNone:
dmi.product.name: 20DFCTO1WW
dmi.product.version: ThinkPad E550
dmi.sys.vendor: LENOVO

tags: added: apport-collected
Changed in linux (Ubuntu Xenial):
status: New → Confirmed
Changed in linux-lts-wily (Ubuntu):
importance: Undecided → High
Changed in linux-lts-xenial (Ubuntu):
importance: Undecided → High
Changed in linux-lts-wily (Ubuntu):
status: Confirmed → Triaged
Changed in linux-lts-xenial (Ubuntu):
status: Confirmed → Triaged
Changed in linux (Ubuntu Xenial):
status: Confirmed → Triaged
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in linux (Ubuntu Xenial):
importance: Undecided → High
Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: kernel-da-key
Arpan Das (arpandas19) on 2016-08-31
Changed in linux (Ubuntu Xenial):
assignee: nobody → Arpan Das (arpandas19)
assignee: Arpan Das (arpandas19) → nobody
assignee: nobody → Arpan Das (arpandas19)
no longer affects: linux-lts-utopic (Ubuntu)
no longer affects: linux-lts-wily (Ubuntu)
Changed in linux (Ubuntu):
assignee: nobody → Joseph Salisbury (jsalisbury)
status: Triaged → In Progress
43 comments hidden view all 123 comments
vipin ms (vipinmsx) wrote :

For those who are waiting for patch, here is the step to temporarily load the module.

---
# Download kernel sources
mkdir ~/debian/src -p
cd ~/debian/src
apt-get source linux-image-$(uname -r)
cd linux-lts-xenial-4.4.0/ << it can be any kernel.
wget https://launchpadlibrarian.net/230434847/uvc.patch
patch -p1 < uvc.patch
cd drivers/media/usb/uvc/
make -C /lib/modules/$(uname -r)/build M=$(pwd) modules

The above step will create a file named uvcvideo.ko in "drivers/media/usb/uvc/" directory. Simply copy and load the module to fix the cam issue.

check your running kernel.

$ uname -r
4.4.0-42-generic

copy module

sudo cp uvcvideo.ko /lib/modules/4.4.0-42-generic/kernel/drivers/media/usb/uvc/ -v

unload old module and load new one:

sudo rmmod uvcvideo; sudo modprobe uvcvideo

Done. Check your cam now.

Thanks gmicsko for sharing the workaround.

On Tue, Nov 22, 2016 at 5:59 PM, vipin ms <email address hidden>
wrote:

> cd linux-lts-xenial-4.4.0/ << it can be any kernel.

what does this line mean
cd linux-lts-xenial-4.4.0/ << it can be any kernel. ?

sarthak (sarthak0415) wrote :

Got it, but you should use '#' while writing comment '<<' are a little
misleading.
The patch is working fine on ubuntu 14.04 on Thinkpad e550 (kernel:
4.4.0-47-generic).

Thanks for sharing the patch and the instructions.

On Tue, Nov 22, 2016 at 7:09 PM, sarthak agarwal <email address hidden>
wrote:

>
> On Tue, Nov 22, 2016 at 5:59 PM, vipin ms <email address hidden>
> wrote:
>
>> cd linux-lts-xenial-4.4.0/ << it can be any kernel.
>
>
> what does this line mean
> cd linux-lts-xenial-4.4.0/ << it can be any kernel. ?
>

yash (yashx1) wrote :

The current *LTS 16.04* release have kernel version as *4.4.0-38-generic.
[more <https://wiki.ubuntu.com/XenialXerus/ReleaseNotes#Linux_kernel_4.4>] *
In case you are using latest release *16.10 *the kernel version will
be* 4.8.x-generic.
[more <https://wiki.ubuntu.com/YakketyYak/ReleaseNotes#Linux_kernel_4.8>]*

That is why* "**it can be any kernel**".*
Cheers.

On Tue, Nov 22, 2016 at 7:09 PM, sarthak <email address hidden> wrote:

> On Tue, Nov 22, 2016 at 5:59 PM, vipin ms <email address hidden>
> wrote:
>
> > cd linux-lts-xenial-4.4.0/ << it can be any kernel.
>
>
> what does this line mean
> cd linux-lts-xenial-4.4.0/ << it can be any kernel. ?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1433906
>
> Title:
> Acer, Inc ID 5986:055a is useless after 14.04.2 installed.
>
> Status in HWE Next:
> Won't Fix
> Status in linux package in Ubuntu:
> In Progress
> Status in linux-lts-vivid package in Ubuntu:
> Triaged
> Status in linux-lts-xenial package in Ubuntu:
> Triaged
> Status in linux source package in Xenial:
> Triaged
> Status in linux package in Arch Linux:
> New
> Status in Fedora:
> Unknown
>
> Bug description:
> CID : 201411-16166 Lenovo E450 (I+A) with 14.04.2 (utopic)
> CID : 201408-15472 Lenovo E555 (A+A) with 14.04.2 (utopic)
>
> Steps:
> 1. Install 14.04.2 on E450 or E555.
> 2. Log in system and open a terminal.
> 3. $ gst-launch-0.10 v4l2src ! xvimagesink
>
> Expected result:
> Camara is activated
>
> Actual result:
> $ gst-launch-0.10 v4l2src ! xvimagesink
> Setting pipeline to PAUSED ...
> ERROR: Pipeline doesn't want to pause.
> ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Cannot
> identify device '/dev/video0'.
> Additional debug info:
> v4l2_calls.c(497): gst_v4l2_open (): /GstPipeline:pipeline0/
> GstV4l2Src:v4l2src0:
> system error: No such file or directory
> Setting pipeline to NULL ...
> Freeing pipeline ...
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: linux-image-3.16.0-30-generic 3.16.0-30.40~14.04.1 [modified:
> boot/vmlinuz-3.16.0-30-generic]
> ProcVersionSignature: Ubuntu 3.16.0-30.40~14.04.1-generic 3.16.7-ckt3
> Uname: Linux 3.16.0-30-generic x86_64
> NonfreeKernelModules: fglrx
> ApportVersion: 2.14.1-0ubuntu3.7
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Thu Mar 19 02:21:31 2015
> InstallationDate: Installed on 2015-03-16 (2 days ago)
> InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64
> (20150218.1)
> SourcePackage: linux-lts-utopic
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hwe-next/+bug/1433906/+subscriptions
>

--
*Yashaswi **Kumar *

*Software DeveloperContact: +917503629597*

Sebastiano (sebo90) wrote :

Hi guys,

I am trying to follow the instructions of vipinmsx, but when I type:
> apt-get source linux-image-$(uname -r)
I get:
> Reading package lists... Done
> Picking 'linux' as source package instead of 'linux-image-4.4.0-51-generic'
> E: Unable to find a source package for linux

What can I do?

I have Thinkpad E450 with Ubuntu 16.04 64bit

Thanks!

vipin ms (vipinmsx) wrote :

make sure that for every deb entry in /etc/apt/sources.list you have a matching deb-src entry. The rest of the line must be identical.

something like deb-src http://in.archive.ubuntu.com/ubuntu xenial main. enable deb-src in /etc/apt/sources.list [removing the comments will help to enable it]

Sebastiano (sebo90) wrote :

Thanks vipinmsx!

I enabled:

deb-src http://in.archive.ubuntu.com/ubuntu/ xenial main restricted

in file /etc/apt/sources.list (line number 6). I followed all your instructions and camera is working fine for me!

Thank you again!

Henrik Ingo (hingo) wrote :

The patch that fixes this bug was merged upstream yesterday: https://github.com/torvalds/linux/commit/e950267ab802c8558f1100eafd4087fd039ad634

vipin ms (vipinmsx) wrote :

wow, cool. So will it be available in ubuntu 14.04,16.04 etc updates?

Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Xenial):
status: Triaged → In Progress
Luis Henriques (henrix) on 2016-12-19
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Committed
Luis Henriques (henrix) on 2016-12-21
Changed in linux (Ubuntu Yakkety):
status: New → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'. If the problem still exists, change the tag 'verification-needed-xenial' to 'verification-failed-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-yakkety' to 'verification-done-yakkety'. If the problem still exists, change the tag 'verification-needed-yakkety' to 'verification-failed-yakkety'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-yakkety

After kernel upgrade to 4.4.0.58.45, the issue can not be reproduced. Thank you all.

tags: added: verification-done-yakkety

Please refer to Screenshot.png in attachment. Thanks.

The cameras of 201411-16166 Lenovo E450 (I+A) and 201408-15472 Lenovo E555 (A+A) work normally after upgrade kernel to 4.4.0.58.45

tags: added: verification-done-xenial
removed: verification-done-yakkety
Po-Hsu Lin (cypressyew) on 2016-12-23
tags: removed: verification-needed-xenial
vipin ms (vipinmsx) wrote :

After installing the proposed kernel in Xenial, camera works like a charm.

vipin ms (vipinmsx) wrote :

when will the fix available in ubuntu repo ?

Luis Henriques (henrix) wrote :

Can we have this bug verified in yakkety too, please?

vipin ms (vipinmsx) wrote :

it's already done in #96 update.

Install image Ubuntu 16.10 (Yakkety) on 201408-15472 Lenovo E555 (A+A), verified the webcam does not work with kernel version 4.8.0.22.31

tags: added: verification-failed-yakkety
removed: verification-needed-yakkety

Installed linux kernel 4.8.0-34-generic (4.8.0-34.36) and 4.8.0-34-lowlatency (4.8.0-34.36) on E555.

Webcam works smoothly under 4.8.0-34-lowlatency (4.8.0-34.36);
Webcam can not work under 4.8.0-34-generic (4.8.0-34.36).

Luis Henriques (henrix) wrote :

It seems that you also have some other random HW failures (as per an IRC chat with PHLin). Is it possible that for some reason your upgrade failed and that you installed the linux-image-4.8.0-34-generic package but not the linux-image-extra-4.8.0-34-generic?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-lts-vivid (Ubuntu Yakkety):
status: New → Confirmed
Changed in linux-lts-xenial (Ubuntu Yakkety):
status: New → Confirmed
1 comments hidden view all 123 comments

I have the same problem on Ubuntu 16.04.1 with Lenovo Thinkpad E-550

vipin ms (vipinmsx) wrote :

I have Thinkpad E550 and the proposed kernel fixed the cam issue. @yousefvand what are the issues you are seeing? You might be missing some steps or not following the steps correctly.

Following PHLin's suggestion, I install kernel related packages by '$ sudo apt-get dist-upgrade'. Then reboot system, select kernel 4.8.0-34.36 in grub and press 'Enter'. System works normally; Cheese and gst-launcher are good. So the issue has been fixed. Add tag 'verification-done-yakkety'. Thank you all.

tags: added: verification-done-yakkety
removed: verification-failed-yakkety
1 comments hidden view all 123 comments

I thought I had this same problem, but my camera is the 5986:055e ('e' instead of 'a'), and it is still not working on kernel 4.8.0-34-generic #36-Ubuntu.

Po-Hsu Lin (cypressyew) wrote :

@Richard,
as that's a different device, and this 4.8 proposed kernel didn't fix you issue, would you mind to open a new bug report for it with command "ubuntu-bug linux" in a terminal (Ctrl + Alt + t)?

Thanks!

Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package linux-lts-xenial - 4.4.0-59.80~14.04.1

---------------
linux-lts-xenial (4.4.0-59.80~14.04.1) trusty; urgency=low

  [ John Donnelly ]

  * Release Tracking Bug
    - LP: #1654286

  * [2.1.1] MAAS has nvme0n1 set as boot disk, curtin fails (LP: #1651602)
    - (fix) nvme: only require 1 interrupt vector, not 2+

linux (4.4.0-58.79) xenial; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1651402

  * Support ACPI probe for IIO sensor drivers from ST Micro (LP: #1650123)
    - SAUCE: iio: st_sensors: match sensors using ACPI handle
    - SAUCE: iio: st_accel: Support sensor i2c probe using acpi
    - SAUCE: iio: st_pressure: Support i2c probe using acpi
    - [Config] CONFIG_HTS221=m, CONFIG_HTS221_I2C=m, CONFIG_HTS221_SPI=m

  * Fix channel data parsing in ST Micro sensor IIO drivers (LP: #1650189)
    - SAUCE: iio: common: st_sensors: fix channel data parsing

  * ST Micro lng2dm 3-axis "femto" accelerometer support (LP: #1650112)
    - SAUCE: iio: st-accel: add support for lis2dh12
    - SAUCE: iio: st_sensors: support active-low interrupts
    - SAUCE: iio: accel: Add support for the h3lis331dl accelerometer
    - SAUCE: iio: st_sensors: verify interrupt event to status
    - SAUCE: iio: st_sensors: support open drain mode
    - SAUCE: iio:st_sensors: fix power regulator usage
    - SAUCE: iio: st_sensors: switch to a threaded interrupt
    - SAUCE: iio: accel: st_accel: Add lis3l02dq support
    - SAUCE: iio: st_sensors: fix scale configuration for h3lis331dl
    - SAUCE: iio: accel: st_accel: add support to lng2dm
    - SAUCE: iio: accel: st_accel: inline per-sensor data
    - SAUCE: Documentation: dt: iio: accel: add lng2dm sensor device binding

  * ST Micro hts221 relative humidity sensor support (LP: #1650116)
    - SAUCE: iio: humidity: add support to hts221 rh/temp combo device
    - SAUCE: Documentation: dt: iio: humidity: add hts221 sensor device binding
    - SAUCE: iio: humidity: remove
    - SAUCE: iio: humidity: Support acpi probe for hts211

  * crypto : tolerate new crypto hardware for z Systems (LP: #1644557)
    - s390/zcrypt: Introduce CEX6 toleration

  * Acer, Inc ID 5986:055a is useless after 14.04.2 installed. (LP: #1433906)
    - uvcvideo: uvc_scan_fallback() for webcams with broken chain

  * vmxnet3 driver could causes kernel panic with v4.4 if LRO enabled.
    (LP: #1650635)
    - vmxnet3: segCnt can be 1 for LRO packets

  * system freeze when swapping to encrypted swap partition (LP: #1647400)
    - mm, oom: rework oom detection
    - mm: throttle on IO only when there are too many dirty and writeback pages

  * Kernel Fixes to get TCMU File Backed Optical to work (LP: #1646204)
    - target/user: Use sense_reason_t in tcmu_queue_cmd_ring
    - target/user: Return an error if cmd data size is too large
    - target/user: Fix comments to not refer to data ring
    - SAUCE: (no-up) target/user: Fix use-after-free of tcmu_cmds if they are
      expired

  * CVE-2016-9756
    - KVM: x86: drop error recovery in em_jmp_far and em_ret_far

  * Dell Precision 5520 & 3520 freezes at login screent (LP: #1650054)
    - ACPI / blacklist: add _REV quirks for Dell Pre...

Read more...

Changed in linux-lts-xenial (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package linux - 4.4.0-59.80

---------------
linux (4.4.0-59.80) xenial; urgency=low

  [ John Donnelly ]

  * Release Tracking Bug
    - LP: #1654282

  * [2.1.1] MAAS has nvme0n1 set as boot disk, curtin fails (LP: #1651602)
    - (fix) nvme: only require 1 interrupt vector, not 2+

linux (4.4.0-58.79) xenial; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1651402

  * Support ACPI probe for IIO sensor drivers from ST Micro (LP: #1650123)
    - SAUCE: iio: st_sensors: match sensors using ACPI handle
    - SAUCE: iio: st_accel: Support sensor i2c probe using acpi
    - SAUCE: iio: st_pressure: Support i2c probe using acpi
    - [Config] CONFIG_HTS221=m, CONFIG_HTS221_I2C=m, CONFIG_HTS221_SPI=m

  * Fix channel data parsing in ST Micro sensor IIO drivers (LP: #1650189)
    - SAUCE: iio: common: st_sensors: fix channel data parsing

  * ST Micro lng2dm 3-axis "femto" accelerometer support (LP: #1650112)
    - SAUCE: iio: st-accel: add support for lis2dh12
    - SAUCE: iio: st_sensors: support active-low interrupts
    - SAUCE: iio: accel: Add support for the h3lis331dl accelerometer
    - SAUCE: iio: st_sensors: verify interrupt event to status
    - SAUCE: iio: st_sensors: support open drain mode
    - SAUCE: iio:st_sensors: fix power regulator usage
    - SAUCE: iio: st_sensors: switch to a threaded interrupt
    - SAUCE: iio: accel: st_accel: Add lis3l02dq support
    - SAUCE: iio: st_sensors: fix scale configuration for h3lis331dl
    - SAUCE: iio: accel: st_accel: add support to lng2dm
    - SAUCE: iio: accel: st_accel: inline per-sensor data
    - SAUCE: Documentation: dt: iio: accel: add lng2dm sensor device binding

  * ST Micro hts221 relative humidity sensor support (LP: #1650116)
    - SAUCE: iio: humidity: add support to hts221 rh/temp combo device
    - SAUCE: Documentation: dt: iio: humidity: add hts221 sensor device binding
    - SAUCE: iio: humidity: remove
    - SAUCE: iio: humidity: Support acpi probe for hts211

  * crypto : tolerate new crypto hardware for z Systems (LP: #1644557)
    - s390/zcrypt: Introduce CEX6 toleration

  * Acer, Inc ID 5986:055a is useless after 14.04.2 installed. (LP: #1433906)
    - uvcvideo: uvc_scan_fallback() for webcams with broken chain

  * vmxnet3 driver could causes kernel panic with v4.4 if LRO enabled.
    (LP: #1650635)
    - vmxnet3: segCnt can be 1 for LRO packets

  * system freeze when swapping to encrypted swap partition (LP: #1647400)
    - mm, oom: rework oom detection
    - mm: throttle on IO only when there are too many dirty and writeback pages

  * Kernel Fixes to get TCMU File Backed Optical to work (LP: #1646204)
    - target/user: Use sense_reason_t in tcmu_queue_cmd_ring
    - target/user: Return an error if cmd data size is too large
    - target/user: Fix comments to not refer to data ring
    - SAUCE: (no-up) target/user: Fix use-after-free of tcmu_cmds if they are
      expired

  * CVE-2016-9756
    - KVM: x86: drop error recovery in em_jmp_far and em_ret_far

  * Dell Precision 5520 & 3520 freezes at login screent (LP: #1650054)
    - ACPI / blacklist: add _REV quirks for Dell Precision 5520 and 3520

  * CVE-2016-979...

Read more...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package linux - 4.8.0-34.36

---------------
linux (4.8.0-34.36) yakkety; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1651800

  * Miscellaneous Ubuntu changes
    - SAUCE: Do not build the xr-usb-serial driver for s390

linux (4.8.0-33.35) yakkety; urgency=low

  [ Thadeu Lima de Souza Cascardo ]

  * Release Tracking Bug
    - LP: #1651721

  [ Luis Henriques ]

  * crypto : tolerate new crypto hardware for z Systems (LP: #1644557)
    - s390/zcrypt: Introduce CEX6 toleration

  * Several new Asus laptops are missing touchpad support (LP: #1650895)
    - HID: asus: Add i2c touchpad support

  * Acer, Inc ID 5986:055a is useless after 14.04.2 installed. (LP: #1433906)
    - uvcvideo: uvc_scan_fallback() for webcams with broken chain

  * cdc_ether fills kernel log (LP: #1626371)
    - cdc_ether: Fix handling connection notification

  * Kernel Fixes to get TCMU File Backed Optical to work (LP: #1646204)
    - SAUCE: target/user: Fix use-after-free of tcmu_cmds if they are expired

  * CVE-2016-9756
    - KVM: x86: drop error recovery in em_jmp_far and em_ret_far

  * On boot excessive number of kworker threads are running (LP: #1649905)
    - slub: move synchronize_sched out of slab_mutex on shrink

  * Ethernet not work after upgrade from kernel 3.19 to 4.4 [10ec:8168]
    (LP: #1648279)
    - ACPI / blacklist: Make Dell Latitude 3350 ethernet work

  * Ubuntu 16.10 netboot install fails with "Oops: Exception in kernel mode,
    sig: 5 [#1] " (lpfc) (LP: #1648873)
    - scsi: lpfc: fix oops/BUG in lpfc_sli_ringtxcmpl_put()

  * CVE-2016-9793
    - net: avoid signed overflows for SO_{SND|RCV}BUFFORCE

  * [Hyper-V] Kernel panic not functional on 32bit Ubuntu 14.10, 15.04, and
    15.10 (LP: #1400319)
    - Drivers: hv: avoid vfree() on crash

  * d-i is missing usb support for platforms that use the xhci-platform driver
    (LP: #1625222)
    - d-i initrd needs additional usb modules to support the merlin platform

  * overlayfs no longer supports nested overlayfs mounts, but there is a fix
    upstream (LP: #1647007)
    - ovl: fix d_real() for stacked fs

  * Yakkety: arm64: CONFIG_ARM64_ERRATUM_845719 isn't enabled (LP: #1647793)
    - [Config] CONFIG_ARM64_ERRATUM_845719=y

  * Ubuntu16.10 - EEH on BELL3 adapter fails to recover (serial/tty)
    (LP: #1646857)
    - serial: 8250_pci: Detach low-level driver during PCI error recovery

  * Driver for Exar USB UART (LP: #1645591)
    - SAUCE: xr-usb-serial: Driver for Exar USB serial ports
    - SAUCE: xr-usb-serial: interface for switching modes
    - SAUCE: cdc-acm: Exclude Exar USB serial ports

  * [Bug] (Purley) x86/hpet: Reduce HPET counter read contention (LP: #1645928)
    - x86/hpet: Reduce HPET counter read contention

  * Need Alps upstream their new touchpad driver (LP: #1571530)
    - Input: ALPS - add touchstick support for SS5 hardware
    - Input: ALPS - handle 0-pressure 1F events
    - Input: ALPS - allow touchsticks to report pressure
    - Input: ALPS - set DualPoint flag for 74 03 28 devices

  * CONFIG_NR_CPUS=256 is too low (LP: #1579205)
    - [Config] Increase the NR_CPUS to 512 for amd64 to support systems with a...

Read more...

Changed in linux (Ubuntu Yakkety):
status: Fix Committed → Fix Released
jessib (bissej) wrote :

Thanks so much! Now working for me on 14.04

Teq (br-ulicny) wrote :

Thank you, now working for me as well on 16.04

Same here on 16.04! Many thanks.

2017-01-16 6:25 GMT+01:00 Teq <email address hidden>:

> Thank you, now working for me as well on 16.04
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1433906
>
> Title:
> Acer, Inc ID 5986:055a is useless after 14.04.2 installed.
>
> Status in HWE Next:
> Won't Fix
> Status in linux package in Ubuntu:
> Fix Committed
> Status in linux-lts-vivid package in Ubuntu:
> Triaged
> Status in linux-lts-xenial package in Ubuntu:
> Fix Released
> Status in linux source package in Xenial:
> Fix Released
> Status in linux source package in Yakkety:
> Fix Released
> Status in linux-lts-vivid source package in Yakkety:
> Confirmed
> Status in linux-lts-xenial source package in Yakkety:
> Confirmed
> Status in linux package in Arch Linux:
> New
> Status in Fedora:
> Unknown
>
> Bug description:
> CID : 201411-16166 Lenovo E450 (I+A) with 14.04.2 (utopic)
> CID : 201408-15472 Lenovo E555 (A+A) with 14.04.2 (utopic)
>
> Steps:
> 1. Install 14.04.2 on E450 or E555.
> 2. Log in system and open a terminal.
> 3. $ gst-launch-0.10 v4l2src ! xvimagesink
>
> Expected result:
> Camara is activated
>
> Actual result:
> $ gst-launch-0.10 v4l2src ! xvimagesink
> Setting pipeline to PAUSED ...
> ERROR: Pipeline doesn't want to pause.
> ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Cannot
> identify device '/dev/video0'.
> Additional debug info:
> v4l2_calls.c(497): gst_v4l2_open (): /GstPipeline:pipeline0/
> GstV4l2Src:v4l2src0:
> system error: No such file or directory
> Setting pipeline to NULL ...
> Freeing pipeline ...
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: linux-image-3.16.0-30-generic 3.16.0-30.40~14.04.1 [modified:
> boot/vmlinuz-3.16.0-30-generic]
> ProcVersionSignature: Ubuntu 3.16.0-30.40~14.04.1-generic 3.16.7-ckt3
> Uname: Linux 3.16.0-30-generic x86_64
> NonfreeKernelModules: fglrx
> ApportVersion: 2.14.1-0ubuntu3.7
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Thu Mar 19 02:21:31 2015
> InstallationDate: Installed on 2015-03-16 (2 days ago)
> InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64
> (20150218.1)
> SourcePackage: linux-lts-utopic
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hwe-next/+bug/1433906/+subscriptions
>

Mauricio López (mlopezqc) wrote :

It is working perfectly on my Lenovo Thinkpad E550. Thank you very much.

Sebastiano (sebo90) wrote :

It is working perfectly on my Lenovo Thinkpad E450. Thank you very much.

Rodney (rodneyboc) wrote :

fixed already in the latest 16.04, im using lenovo e550.

Changed in fedora:
importance: Unknown → Undecided
status: Unknown → Fix Released
Po-Hsu Lin (cypressyew) wrote :

Closing EOL tasks

Changed in linux-lts-vivid (Ubuntu):
status: Triaged → Won't Fix
Changed in linux-lts-vivid (Ubuntu Yakkety):
status: Confirmed → Won't Fix
Changed in linux-lts-xenial (Ubuntu Yakkety):
status: Confirmed → Fix Released
Displaying first 40 and last 40 comments. View all 123 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.