[Dell Inspiron 3521] Brightness control does not work on 12.04.5

Bug #1354253 reported by Po-Hsu Lin on 2014-08-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Edward Lin
linux-lts-trusty (Ubuntu)
Medium
Edward Lin

Bug Description

CID: 201208-11538 Dell Inspiron 3521

This system was certified:
http://www.ubuntu.com/certification/hardware/201208-11538
Brightness control does not work on this system
The brightness level indicator would change with hotkey events, but the brightness itself does not.

Debugging information:
ubuntu@201208-11538:~$ ls /sys/class/backlight
acpi_video0 intel_backlight

ubuntu@201208-11538:~$ grep -r . /proc/acpi
/proc/acpi/battery/BAT1/alarm:alarm: unsupported
/proc/acpi/battery/BAT1/state:present: yes
/proc/acpi/battery/BAT1/state:capacity state: ok
/proc/acpi/battery/BAT1/state:charging state: charged
/proc/acpi/battery/BAT1/state:present rate: unknown
/proc/acpi/battery/BAT1/state:remaining capacity: 2437 mAh
/proc/acpi/battery/BAT1/state:present voltage: 17043 mV
/proc/acpi/battery/BAT1/info:present: yes
/proc/acpi/battery/BAT1/info:design capacity: 2800 mAh
/proc/acpi/battery/BAT1/info:last full capacity: 2437 mAh
/proc/acpi/battery/BAT1/info:battery technology: rechargeable
/proc/acpi/battery/BAT1/info:design voltage: 14800 mV
/proc/acpi/battery/BAT1/info:design capacity warning: 240 mAh
/proc/acpi/battery/BAT1/info:design capacity low: 72 mAh
/proc/acpi/battery/BAT1/info:cycle count: 0
/proc/acpi/battery/BAT1/info:capacity granularity 1: 264 mAh
/proc/acpi/battery/BAT1/info:capacity granularity 2: 3780 mAh
/proc/acpi/battery/BAT1/info:model number: DELL FW1MN27C
/proc/acpi/battery/BAT1/info:serial number: 0106
/proc/acpi/battery/BAT1/info:battery type: LiIon
/proc/acpi/battery/BAT1/info:OEM info: Simplo
/proc/acpi/button/lid/LID0/state:state: open
/proc/acpi/wakeup:Device S-state Status Sysfs node
/proc/acpi/wakeup:P0P1 S0 *disabled
/proc/acpi/wakeup:EHC1 S0 *enabled pci:0000:00:1d.0
/proc/acpi/wakeup:XHC S0 *enabled pci:0000:00:14.0
/proc/acpi/wakeup:RP01 S3 *disabled pci:0000:00:1c.0
/proc/acpi/wakeup:RP02 S0 *disabled pci:0000:00:1c.1
/proc/acpi/wakeup:PEG0 S4 *disabled
/proc/acpi/wakeup:PEGP S4 *disabled
/proc/acpi/wakeup:PEG1 S4 *disabled
/proc/acpi/wakeup:PEG2 S4 *disabled
/proc/acpi/wakeup:PEG3 S4 *disabled
/proc/acpi/wakeup:LID0 S3 *enabled

ubuntu@201208-11538:~$ dmesg | grep 'ACPI: Video'
ubuntu@201208-11538:~$

Linux version 3.13.0-32-generic (buildd@phianna) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #57~precise1-Ubuntu SMP Tue Jul 15 03:51:20 UTC 2014

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.13.0-32-generic 3.13.0-32.57~precise1 [modified: boot/vmlinuz-3.13.0-32-generic]
ProcVersionSignature: Ubuntu 3.13.0-32.57~precise1-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
Date: Thu Aug 7 22:09:38 2014
InstallationMedia: Ubuntu 12.04.5 LTS "Precise Pangolin" - Release amd64 (20140806)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-lts-trusty
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) wrote :
Changed in hwe-next:
assignee: nobody → Edward Lin (airken)
Changed in linux-lts-trusty (Ubuntu):
assignee: Anthony Wong (anthonywong) → Edward Lin (airken)
Edward Lin (airken) wrote :

@Po-Hsu Lin
Can you try the kernel parameter mentioned in bug 1354313 #3

Po-Hsu Lin (cypressyew) wrote :

Parameter:
video.use_native_backlight=1 - works
acpi_video=vendor - not working

tags: added: regression-release
Edward Lin (airken) wrote :

please ignore comment 7

Edward Lin (airken) wrote :

"acpi_video=vendor" is wrong.
Sorry for the mistake.

The right one should be "acpi_backlight=vendor".

Po-Hsu Lin (cypressyew) wrote :

"acpi_backlight=vendor" works

Edward Lin (airken) on 2014-09-04
Changed in linux-lts-trusty (Ubuntu):
status: New → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Po-Hsu Lin (cypressyew) wrote :

Verified with 12.04.5 + proposed update.
Brightness works.

tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (16.5 KiB)

This bug was fixed in the package linux-lts-trusty - 3.13.0-37.64~precise1

---------------
linux-lts-trusty (3.13.0-37.64~precise1) precise; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1372747

  [ dann frazier ]

  * [Config] CONFIG_HW_RANDOM_XGENE=m on arm64

  [ Edward Lin ]

  * SAUCE: Add use_native_backlight quirk for Dell Inspiron 5721/3521
    - LP: #1354253, #1354313

  [ Tim Gardner ]

  * SAUCE: Fix nfs oops stable regression
    - LP: #1348670
  * [Config] Add mpt3sas to d-i
    - LP: #1368907
  * [Config] CONFIG_X86_16BIT=y
    - LP: #1371601

  [ Timo Aaltonen ]

  * SAUCE: i915_bdw: Rebase to v3.15.8
    - LP: #1359213

  [ Upstream Kernel Changes ]

  * Revert "x86-64, modify_ldt: Make support for 16-bit segments a runtime
    option"
    - LP: #1371601
  * mmc: rtsx: add R1-no-CRC mmc command type handle
    - LP: #1365378
  * rpc_pipe: remove the clntXX dir if creating the pipe fails
    - LP: #1365869
  * sunrpc: add an "info" file for the dummy gssd pipe
    - LP: #1365869
  * rpc_pipe: fix cleanup of dummy gssd directory when notification fails
    - LP: #1365869
  * hwrng: xgene - add support for APM X-Gene SoC RNG support
    - LP: #1365593
  * Documentation: rng: Add X-Gene SoC RNG driver documentation
    - LP: #1365593
  * arm64: dts: add random number generator dts node to APM X-Gene
    platform.
    - LP: #1365593
  * xen/balloon: cancel ballooning if adding new memory failed
    - LP: #1304001
  * x86/xen: resume timer irqs early
    - LP: #1368724
  * xen/manage: Always freeze/thaw processes when suspend/resuming
    - LP: #1368724
  * scsi_transport_sas: move bsg destructor into sas_rphy_remove
    - LP: #1368991
  * drm/i915: Enable 5.4Ghz (HBR2) link rate for Displayport 1.2-capable
    devices
    - LP: #1369633
  * bnx2x: Fix link for KR with swapped polarity lane
    - LP: #1370716
  * drm: add DRM_CAPs for cursor size
    - LP: #1359213
  * drm/dp: Add AUX channel infrastructure
    - LP: #1359213
  * drm/dp: Add drm_dp_dpcd_read_link_status()
    - LP: #1359213
  * drm/dp: Add DisplayPort link helpers
    - LP: #1359213
  * drm/dp: Allow registering AUX channels as I2C busses
    - LP: #1359213
  * drm/dp: let drivers specify the name of the I2C-over-AUX adapter
    - LP: #1359213
  * drm/dp: make aux retries less chatty
    - LP: #1359213
  * Bluetooth: Enable Atheros 0cf3:311e for firmware upload
    - LP: #1371477
  * bnx2x: fix crash during TSO tunneling
    - LP: #1371601
  * inetpeer: get rid of ip_id_count
    - LP: #1371601
  * ip: make IP identifiers less predictable
    - LP: #1371601
  * tcp: Fix integer-overflows in TCP veno
    - LP: #1371601
  * tcp: Fix integer-overflow in TCP vegas
    - LP: #1371601
  * macvlan: Initialize vlan_features to turn on offload support.
    - LP: #1371601
  * net: Correctly set segment mac_len in skb_segment().
    - LP: #1371601
  * iovec: make sure the caller actually wants anything in
    memcpy_fromiovecend
    - LP: #1371601
  * batman-adv: Fix out-of-order fragmentation support
    - LP: #1371601
  * sctp: fix possible seqlock seadlock in sctp_packet_transmit()
    - LP: #1371601
  * sparc64: Fix argument sign extension for ...

Changed in linux-lts-trusty (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Daniel Manrique (roadmr) on 2014-12-16
Changed in linux-lts-trusty (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers