DVD RW ROM eject button doesn't work when inserting a DVD/CD rw disc

Bug #1228751 reported by Hui Wang on 2013-09-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HWE Next
High
Hui Wang
Quantal
High
Hui Wang
Raring
High
Hui Wang
Saucy
High
Hui Wang
linux (Ubuntu)
High
Hui Wang
Quantal
Medium
Hui Wang
Raring
Medium
Hui Wang
Saucy
High
Hui Wang

Bug Description

When inserting a DVD/CD RW disc into the DVD RW ROM, the system will auto mount it and the eject button won't work anymore.

This design is not correct if the file system on the RW disc is read-only, e.g. iso9660 or UDF read-only partition.

Hui Wang (hui.wang) on 2013-09-22
tags: added: blocks-hwcert-enablement
Changed in linux (Ubuntu):
assignee: nobody → Hui Wang (hui.wang)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1228751

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Tim Gardner (timg-tpi) on 2013-09-26
Changed in linux (Ubuntu Saucy):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Raring):
assignee: nobody → Hui Wang (hui.wang)
status: New → In Progress
Changed in linux (Ubuntu Quantal):
assignee: nobody → Hui Wang (hui.wang)
status: New → In Progress
Andy Whitcroft (apw) on 2013-09-27
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Andy Whitcroft (apw) on 2013-09-27
Changed in linux (Ubuntu Raring):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Saucy):
importance: Undecided → High
Changed in linux (Ubuntu Raring):
importance: Undecided → Medium
Changed in linux (Ubuntu Quantal):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.11.0-9.16

---------------
linux (3.11.0-9.16) saucy; urgency=low

  [ Andy Whitcroft ]

  * Revert "SAUCE: (no-up) scsi: hyper-v storage -- mark as preferring READ
    CAPACITY (16) at SPC-2"
  * Revert "SAUCE: (no-up) scsi: hyper-v storage -- mark as VPD capable at
    SPC-2"
  * Revert "SAUCE: (no-up) scsi: add scsi device flag to request READ
    CAPACITY (16) be preferred"
  * Revert "SAUCE: (no-up) scsi: add scsi device flag to request VPD pages
    be used at SPC-2"

  [ Seth Forshee ]

  * SAUCE: (no-up) ACPI: Disable Windows 8 compatibility for some Lenovo
    ThinkPads
    - LP: #1183856

  [ Tim Gardner ]

  * [Config] CONFIG_CRYPTO_CRCT10DIF=y, CONFIG_CRYPTO_CRCT10DIF_PCLMUL=m
  * [packaging] Bump ABI for every new release
  * rebase to v3.11.2
  * Release tracker
    - LP: #1231999

  [ Upstream Kernel Changes ]

  * scsi: hyper-v storsvc switch up to SPC-3
  * perf/x86: Add Silvermont (22nm Atom) support
    - LP: #1091539
  * perf/x86/intel: Fix Silvermont offcore masks
    - LP: #1091539
  * modules: add support for soft module dependencies
    - LP: #1188010
  * Reinstate "crypto: crct10dif - Wrap crc_t10dif function all to use
    crypto transform framework"
    - LP: #1188010
  * skge: fix broken driver
    - LP: #1216745
  * Input: cypress_ps2 - Return zero finger count if palm is detected.
    - LP: #1229361
  * udf: Standardize return values in mount sequence
    - LP: #1228751
  * udf: Refuse RW mount of the filesystem instead of making it RO
    - LP: #1228751
  * rebase to v3.11.2
 -- Tim Gardner <email address hidden> Mon, 23 Sep 2013 07:41:07 -0600

Changed in linux (Ubuntu Saucy):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
tags: added: verification-needed-raring
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-raring' to 'verification-done-raring'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Hui Wang (hui.wang) wrote :

 Both quantal kernel and raring kernel were verified. And the tags were changed.

tags: added: verification-done-quantal verification-done-raring
removed: verification-needed-quantal verification-needed-raring
Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers