hwdb-send won't send an xml file if it cannot find one

Bug #115559 reported by Andrew Fenn on 2007-05-19
4
Affects Status Importance Assigned to Milestone
Ubuntu Device Database
New
Undecided
Unassigned

Bug Description

andrew@andrew-laptop:~$ hwdb-send
hwdb.ubuntu.com

md5sum: /tmp/hwdb_data.xml: No such file or directory
Traceback (most recent call last):
  File "/usr/bin/hwdb-send", line 39, in <lambda>
    ok.connect("clicked", lambda w: self.connect())
  File "/usr/bin/hwdb-send", line 65, in connect
    os.system('mv /tmp/hwdb_data.xml /tmp/'+md5sum[0]+'.xml')
IndexError: list index out of range

hwdb-send should compile an XML file using the command "hwdb-xml -a" if it can not find the xml-file required.

drink (martin-espinoza) wrote :

I have the same problem, but it looks like it IS compiling the XML file. sometimes.

I ran it before (older version) and I wanted to run it again in order to send another file. Creating the xml file ahead of time (with hwdb-xml -a, and redirecting to /tmp/hwdb_data.xml) does not help.

Anyway my attachment has what it put on my desktop. It only told me to mail one in once, though. I think that it worked (halfway - not the upload of course) after I tried manually creating the file. If this is the file that I manually created, then at least it put it on my desktop that time.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers