unity does not display authentication window for pkexec, making gnome-system-log unusable from the Dash

Bug #957641 reported by Rocko on 2012-03-17
120
This bug affects 34 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
Unity
Confirmed
Undecided
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

The /usr/share/applications/gnome-system-log.desktop file recently changed to have "EXEC=pkexec gnome-system-log", and now it is not possible to run it from the unity launcher icon or from the 'matching applications' list in the dash (note that it matches 'log file viewer' and not 'gnome-system-log'). No error is displayed anywhere that I can see (eg in ~.xsession-errors).

Running 'pkexec gnome-system-log' from gnome-terminal prompts the user for authentication to get sudo privileges, so it appears likely that either unity tries to run the command and it fails, or runs it but doesn't display the authentication window.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.6.0-0ubuntu4
Uname: Linux 3.3.0-rc7-git-20120316.1313 x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,mousepoll,gnomecompat,imgpng,snap,grid,wall,move,place,vpswitch,session,compiztoolbox,extrawm,resize,regex,animation,workarounds,unitymtgrabhandles,expo,fade,scale,ezoom,unityshell]
Date: Sat Mar 17 10:27:11 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 LANGUAGE=en_AU:en
 TERM=xterm
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-03-13 (3 days ago)

Rocko (rockorequin) wrote :
Omer Akram (om26er) wrote :

using unity from staging ppa + everything upto date I am unable to reproduce the issue that you described. Can you record a video to show the problem that you are facing.

Changed in unity (Ubuntu):
status: New → Incomplete
Rocko (rockorequin) wrote :

record-my-desktop isn't playing nicely at the moment - it just freezes when I hit alt-f2. What happens if you try: alt-f2 then 'pkexec gnome-system-log'? For me, the alt-f2 window closes but nothing runs.

Rocko (rockorequin) wrote :

I've confirmed the problem also exists in a virtual machine.

I updated the VM to the staging PPA (https://launchpad.net/~unity-team/+archive/staging?field.series_filter=precise; unity is now at version 5.6.0+bzr2123ubuntu0+670) and it still exhibits the problem.

Changed in unity (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

thank you for your bug report, that was an error in that .desktop and not a bug in unity, the issue got resolved with an update, closing the bug

Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Rocko (rockorequin) wrote :

Do you mean that unity now displays an authentication window if you specify pkexec in a desktop file? Or is not displaying the authentication window and silently failing an intentional feature of unity?

Sebastien Bacher (seb128) wrote :

the fact that dialog was not displayed has nothing to do with unity, it's pkexec which requires a config file allowing to keep the display for the command being run, the bug was in gnome-system-log

the fact that unity doesn't display command line errors in a graphical way when an application fails to start is another issue which got reported and is already being tracked in another ticket

Rocko (rockorequin) wrote :

Thanks, that's good to know.

Tiago Neiva (tneiva) wrote :

Sebastian: you say was? or is? I'm still having this bug in 12.10

Tiago Neiva (tneiva) wrote :

I found this in debian bug reports:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=690337

it may be of interest

Changed in unity (Ubuntu):
status: Invalid → Confirmed
Tiago Neiva (tneiva) wrote :

When I call gnome-system-log from the dash I get the following error in .xsession-errors:

Refusing to render service to dead parents.

Franck (alci) wrote :

Hi,

I'm running Quantal up-to-date (as of 2012-10-31) and:

I can confirm that I cannot launch gnome-system-log from the Dash.
I can confirm the "Refusing to render service to dead parents." in .xsessions-errors

summary: - unity does not display authentication window for pkexec
+ unity does not display authentication window for pkexec, making gnome-
+ system-log unasable from the Dash

Also notice the debian bug report refered by Tiago in comment #10 has itself a link to:

https://bugzilla.gnome.org/show_bug.cgi?id=686059

(about "double forking" and breaking pkexec)

summary: unity does not display authentication window for pkexec, making gnome-
- system-log unasable from the Dash
+ system-log unusable from the Dash
Bill Turner, wb4alm (wb4alm) wrote :

Problem still exists in Ubuntu 12.10 when attemping to start gnome-system-log. Gnome-system-log will run from a terminal however.

Savio (abhijeet) wrote :

I just update to ubuntu 12.10 from 12.04 and same problem also effects me. Can anyone give workaround.

Rocko (rockorequin) wrote :

For a workaround, "sudo gedit /usr/share/applications/gnome-system-log.desktop", remove the word pkexec from the EXEC= line, and save the changes.

Nate R (nate-ridderman) wrote :

Thanks for the workaround, Rocko! Worked like a charm.

Savio (abhijeet) wrote :

Thank you for Workaround Rocko

Balló György (ballogy) wrote :

It happens on Arch Linux also under Unity with all .desktop files that use pkexec in their Exec= line. It's probably related to this: https://bugzilla.gnome.org/show_bug.cgi?id=675789

Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
status: New → Confirmed
Changed in hundredpapercuts:
status: New → Confirmed
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
Changed in hundredpapercuts:
assignee: Papercuts Ninjas (papercuts-ninja) → nobody
status: Confirmed → Triaged
importance: Undecided → Low
Adolfo Jayme (fitojb) on 2014-05-25
Changed in unity (Ubuntu):
importance: Low → Medium
Changed in hundredpapercuts:
importance: Low → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.