Add keywords to .desktop files

Reported by Nicolas Delvaux on 2012-03-09
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
LibreOffice Productivity Suite
Fix Released
Low
One Hundred Papercuts
Low
Unassigned
libreoffice (Ubuntu)
Wishlist
Unassigned

Bug Description

You should, for example, be able to find Calc in the Unity dash if you type "Excel".
One may ask Average Joe to "create a slideshow", so "slide" should find Impress.

Of course, you could find many more potential keywords (and this is even more useful in some other languages).

So, please add a "keywords" section in libreoffice-*.desktop files.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice-core 1:3.5.0-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
ApportVersion: 1.94.1-0ubuntu1
Architecture: i386
CheckboxSubmission: 8cf001b4b1d1f2fddc8b471a28b5eaa6
CheckboxSystem: d89cfecb506be0562834433b44d8bcb5
Date: Fri Mar 9 14:51:15 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111222)
SourcePackage: libreoffice
UpgradeStatus: Upgraded to precise on 2012-02-16 (21 days ago)

Nicolas Delvaux (malizor) wrote :

Please propose appropriate mapping of keywords and file a bug upstream as per: http://wiki.documentfoundation.org/BugReport
and link the bug here. The bug qualifes as "EasyHack" (libreoffice equivalent of PaperCuts).

Note however that "Excel" and comparable keywords are trademarked and thus can cause trouble.

Changed in libreoffice (Ubuntu):
importance: Undecided → Wishlist
Changed in df-libreoffice:
status: New → Incomplete

Originally filled at https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/950834

The Desktop Entry Specification now provide a "Keywords" section.
Extract from the spec[1]:

"A list of strings which may be used in addition to other metadata to describe this entry. This can be useful e.g. to facilitate searching through entries."

This entry is used, for example, by Unity (Ubuntu default desktop) to find apps that the user search in a semantic way.

Here is my proposal (think as "if user search $keyword, he should find $app):
Writer: odt;docx;Text;Letter;CV;
Calc: ods;xls;xlsx;Accounting;Stats;Chart;
Impress: odp;ppt;pptx;Slide;Slideshow;Presentation;
Draw: odg;Vector;Schema;Diagram;
Math: Equation;
Base: Data;

It would also be cool to add words such as "Excel", "PowerPoint", etc. because they became kind of common nouns for some people. We may also add "Oracle", "MySQL", "PostgreSQL", etc. to Base.
But I don't know if it is doable because these words are trademarked.

[1] http://standards.freedesktop.org/desktop-entry-spec/latest/ar01s05.html#key-keywords

Nicolas Delvaux (malizor) wrote :

The upstream bug is: https://www.libreoffice.org/bugzilla/show_bug.cgi?id=47157

However, I imagine that upstream will be to late for Precise...
Is a downstream patch conceivable (as we currently have for quicklists)?

Changed in df-libreoffice:
importance: Undecided → Unknown
status: Incomplete → Unknown
Nicolas Delvaux (malizor) wrote :

(Launchpad seems to have troubles with https links...)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

Keywords are not intended only for Unity: they also work, for example, with Gnome-Shell.

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → New
Robert Roth (evfool) on 2012-05-09
Changed in hundredpapercuts:
status: New → Confirmed
Chris Wilson (notgary) on 2012-06-10
Changed in hundredpapercuts:
milestone: none → quantal-2-productivity
importance: Undecided → Low
Changed in df-libreoffice:
importance: Medium → Low
status: New → Confirmed

fix committed upstream for 3.7.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Committed

Marco Biscaro committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9d844ce3f8e411bfb4237372b1a6d4aec21a0a65

fdo#47157 adding Keywords to .desktop files

please mark this resolved after sending the license statement as per:
 http://wiki.documentfoundation.org/Development/Developers

Was there any discussion about including keywords such as Word, Excel and Powerpoint?

Unfortunately, many users seem to be used to the Microsoft jargon.
So one may search for Excel when wanting to use a spreadsheet.

In fact, Word is not necessary because it is already in the "GenericName" entry (as "Word Processor"), so Writer will appear if one search for "Word".

The problem remains for Excel and PowerPoint.
However, "excel" is a common noun, so adding it should be fine.
And for PowerPoint, why not adding "point" and "power" (in this order if you prefer) ? These are both common nouns and users should just have to type the firsts letters (such as "pow") before finding Impress, so it should be enough.

What do you think?

@Björn Michaelsen: done!

@Nicolas Delvaux: I don't know if we can use Excel or PowerPoint in keywords: "Microsoft requires that its trademarks be used properly and under license, in appropriate circumstances."[1]

[1] http://www.microsoft.com/about/legal/en/us/IntellectualProperty/Trademarks/Usage/Office.aspx

Changed in df-libreoffice:
status: Confirmed → Fix Released
Chris Wilson (notgary) on 2012-08-29
Changed in hundredpapercuts:
status: Confirmed → Fix Released

@Marco Biscaro: I agree that we probably can't use "PowerPoint" and "Excel", that's why I proposed to use only common nouns as a workaround.

I really think we should find a solution to this (see my others comments).

Is there anyone with a legal background at the Document Foundation who could advise us?

@ Alex
Greetings
Please, give advice to us here. See previous comment

I strongly believe that Excel and PowerPoint should be listed as Keywords. LibreOffice does read and write Excel & PowerPoint files and someone looking for an app to do that on Linux should see LibreOffice as an option.

The use of the trademarks is for interoperability. Searching for Excel or PowerPoint in the GNOME Activities Overview or Unity's Dash currently doesn't turn up any results at all which doesn't seem right.

Also, is this patch something that can be backported to the 3.6 series?

One question: we could (if there is no legal implications) add Excel to calc.desktop and PowerPoint to impress.desktop, because Calc and Impress are *compatible with* Excel and PowerPoint. Should we add Access to base.desktop and Visio to draw.desktop, since they are *alternatives to* Access and Visio (but not compatible with)?

(In reply to comment #9)
> @ Alex
> Greetings
> Please, give advice to us here. See previous comment

Hi ALL,

Ten years ago, this probably wouldn't have been high on many people's agendas. However, things have moved on, and caselaw has come in most countries, certainly those where LO is already used quite widely, where such use of trademarks could be considered to be problematic :

- under the "meta-tag", or "Google Adwords" doctrine approach, which has most notably been important in Europe ;

- under various trademark dilution doctrines ;

- actions tending to cause a mark to become generic despite the TM owner's indications/attempts to dissuade that (note that the MS page pointed to by Bjoern takes particular pains to tell users how to use the mark in order to avoid this problem, even though it may not be specifically mentioned).

So, my personal take on this would be to leave well alone and not use them.

Alex

Changed in df-libreoffice:
status: Fix Released → Confirmed

Well if unity/gnome-shell additionally parsed the desktop mime-type record and split application/FOO and application/vnd.BAR.FOO to make FOO a search term then that'd be quite useful.

Anyway, lets leave this specific bug as "fixed" and file additional ones if necessary for extra search terms.

Marco Biscaro committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=90524e0f8c6c7a8e6e5e8c0bc48afc2025336e63&g=libreoffice-3-6

fdo#47157 adding Keywords to .desktop files

It will be available in LibreOffice 3.6.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

I have created another patch with more keywords at https://gerrit.libreoffice.org/#/c/953/ before I read Caolan's comment (#14).

I can't see any legal problem with using Microsoft trade names here. The trademarks policy (#7) speaks about user-visible text, not about Code.

Changed in df-libreoffice:
status: Confirmed → Fix Released

Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d8b07e5ba238d529a7610dd302269ee05c5e8fbc

fdo#47157 Add more keywords to .desktop files

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:4.0.0~beta2-0ubuntu2

---------------
libreoffice (1:4.0.0~beta2-0ubuntu2) raring; urgency=low

  * Build using the internal libmspub for a first build.
 -- Matthias Klose <email address hidden> Tue, 19 Feb 2013 00:05:26 +0100

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.