shortcut for closing power statistics app not working

Bug #923292 reported by myszek123 on 2012-01-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
U.W.D.Dhananjaya
gnome-power
In Progress
Low
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

Different app but the same type of problem as in #900753. Power statiscits app does not close after ctrl+q (and/or ctrl+w) is hit. Very common shortcut so it'd probably be handled also by Power Statistics app.

Related branches

Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → quantal-11-misc
importance: Undecided → Low
Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
Changed in gnome-power:
importance: Unknown → Low
status: Unknown → New
U.W.D.Dhananjaya (dedunumax) wrote :

terminal also have same issue

Changed in hundredpapercuts:
assignee: nobody → U.W.D.Dhananjaya (dedunumax)
Dmitry Shachnev (mitya57) wrote :

Why not submit this upstream?

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
U.W.D.Dhananjaya (dedunumax) wrote :

Shoud I send this to upstream now?

Yes, please do. A patch against the latest gnome-power-manager git
should work. (Forwarding patches upstream lets us save hours of
maintenance work).

On 2/18/13, U.W.D.Dhananjaya <email address hidden> wrote:
> Shoud I send this to upstream now?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/923292
>
> Title:
> shortcut for closing power statistics app not working
>
> Status in Gnome Powermanager:
> New
> Status in One Hundred Paper Cuts:
> Confirmed
> Status in “gnome-power-manager” package in Ubuntu:
> Triaged
>
> Bug description:
> Different app but the same type of problem as in #900753. Power
> statiscits app does not close after ctrl+q (and/or ctrl+w) is hit.
> Very common shortcut so it'd probably be handled also by Power
> Statistics app.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-power/+bug/923292/+subscriptions
>

If you attach the patch to this bug report (https://bugzilla.gnome.org/show_bug.cgi?id=678115) that'll get it to the upstream developers.

Steve Langasek (vorlon) wrote :

dedunumax, can you please forward this patch upstream to the bug Chris indicated? The patch looks reasonable to me, but I'd be more comfortable sponsoring it into the archive if it were accepted upstream first.

U.W.D.Dhananjaya (dedunumax) wrote :

Two three days I tried to submit code to upstream but I was unable to do so :(

What was it you tried to do? The way to send patches upstream is to attach
it to the bug report that I indicated and check the box that marks it as a
patch.

On 12 March 2013 08:32, U.W.D.Dhananjaya <email address hidden> wrote:

> Two three days I tried to submit code to upstream but I was unable to do
> so :(
>
> --
> You received this bug notification because you are subscribed to One
> Hundred Paper Cuts.
> Matching subscriptions: Papercut bug mail
> https://bugs.launchpad.net/bugs/923292
>
> Title:
> shortcut for closing power statistics app not working
>
> Status in Gnome Powermanager:
> New
> Status in One Hundred Paper Cuts:
> Confirmed
> Status in “gnome-power-manager” package in Ubuntu:
> Triaged
>
> Bug description:
> Different app but the same type of problem as in #900753. Power
> statiscits app does not close after ctrl+q (and/or ctrl+w) is hit.
> Very common shortcut so it'd probably be handled also by Power
> Statistics app.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-power/+bug/923292/+subscriptions
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 3.6.0-1ubuntu1

---------------
gnome-power-manager (3.6.0-1ubuntu1) raring; urgency=low

  [ Dedunu Dhananjaya ]
  * Added key press event for ctrl+q (LP: #923292)
 -- Dmitrijs Ledkovs <email address hidden> Tue, 12 Mar 2013 14:39:00 +0000

Changed in gnome-power-manager (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-power:
status: New → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.