On newly installed Firefox, spell checking is enabled but no language is selected

Bug #894085 reported by Doug McMahon on 2011-11-23
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
firefox (Ubuntu)
Low
Unassigned

Bug Description

Test Case"
Install current daily, using the 11/26 for current test
Open FF, go to a page you can type in
Type a word, mis-spell it, No spell correction is done

Highlight the word, Check spelling is enabled
Click on Languages > no language will be selected

Selecting the language will then start spell checking, language should be slected by default

Attaching image in comment 5

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: firefox 9.0~b2+build1-0ubuntu1
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic 3.1.0
Uname: Linux 3.1.0-2-generic i686
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.26-0ubuntu1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: doug 1448 F.... pulseaudio
BuildID: 20111117222449
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6ffc000 irq 47'
   Mixer name : 'SigmaTel STAC9228'
   Components : 'HDA:83847616,10280209,00100201'
   Controls : 27
   Simple ctrls : 18
Channel: beta
Date: Wed Nov 23 12:28:22 2011
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111122)
IpRoute:
 default via 192.168.1.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.102 metric 2
Plugins:
 QuickTime Plug-in 7.6.6 - Lib=libtotem-narrowspace-plugin.so, Location=/usr/lib/mozilla/plugins
 DivX® Web Player - Lib=libtotem-mully-plugin.so, Location=/usr/lib/mozilla/plugins
 Windows Media Player Plug-in 10 (compatible; Totem) - Lib=libtotem-gmp-plugin.so, Location=/usr/lib/mozilla/plugins
 VLC Multimedia Plugin (compatible Totem 3.0.1) - Lib=libtotem-cone-plugin.so, Location=/usr/lib/mozilla/plugins
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=9.0/20111117222449 (Running)
RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:
 Nov 23 11:47:28 doug-XPS-M1330 kernel: [ 2485.996721] nautilus[1455]: segfault at 60 ip 080cc9a7 sp bfbda390 error 4 in nautilus[8048000+169000]
 Nov 23 11:54:02 doug-XPS-M1330 kernel: [ 2879.788096] CE: hpet increased min_delta_ns to 20113 nsec
 Nov 23 12:18:44 doug-XPS-M1330 kernel: [ 4362.073947] nautilus[3435]: segfault at 60 ip 080cc9a7 sp bfac3ff0 error 4 in nautilus[8048000+169000]
dmi.bios.date: 12/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd12/26/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1330
dmi.sys.vendor: Dell Inc.

Doug McMahon (mc3man) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Paul White (paulw2u) wrote :

On an upgraded Firefox, version 8 to 9, I had no spell checking for a couple of days.

When I right mouse clicked in the text field I was using I saw that "Check Spelling" was selected. Before I could toggle it off and back on again I saw that a misspelled word had become underlined. The spell checking now works. Strange.

I also saw that my dictionary was set to the incorrect version of English, that is not something I would have done purposely.

Doug McMahon (mc3man) wrote :

Can confirm what Paul has relayed. On my 12.04 install still wasn't working - mis-spelled a word, r. clicked on , in my case then clicked on Languages which was set correctly, re-clicked on the lang TWICE & spell checking now works.

Guess this could be marked invalid though maybe should stay up for a few days to .d.ck it continues to work & for others seeing the same as to possible 'fix'

Doug McMahon (mc3man) on 2011-11-27
summary: - Firefox 9* no longer does spell checking
+ Firefox 9* spell checking is enabled but no language is slected

As seen on fresh 11/26 daily install

description: updated
summary: - Firefox 9* spell checking is enabled but no language is slected
+ Firefox 9* spell checking is enabled but no language is selected
Paul White (paulw2u) wrote :

I've just installed Firefox 10 on Ubuntu 12.04 and once again the language was not selected giving the impression that spell checking does not work.

I selected my chosen language and spell chcking worked immediately.

Paul White (paulw2u) on 2011-12-24
summary: - Firefox 9* spell checking is enabled but no language is selected
+ On newly installed Firefox, spell checking is enabled but no language is
+ selected
Chris Coulson (chrisccoulson) wrote :

Can people confirm that this is just losing your dictionary choice after upgrading (eg, from 8 -> 9 or 9 -> 10)?

Paul White (paulw2u) wrote :

Yes Chris, that is how I see this bug now.

Doug McMahon (mc3man) wrote :

I don't see that once set the setting being 'lost' when upgrading FF versions, though have to admit didn't pay close attention when FF went from 9.X to 10.X in 12.04

Definitely all new installs will have spell checking enabled but no language chosen, this is seen on Alpha 1 or any daily image. (& the need/means to pick a language isn't obviously presented to many users

As a quick test just booted to A1, ( FF 9). Spell checking was enabled but no language selected.
Selected a language & checked that spell checking now worked.

Then upgraded to FF 10, the language was still selected & spell checking still worked. This also included a log out/in after the upgrade in case that was a factor.

I guess this could be further checked by use of the firefox-next ppa on 11.10/04 & see what occurs when FF upgrades.

Paul White (paulw2u) wrote :

I've just booted into Kubuntu 12.04 where I haven't actually used Firefox since updating it to version 10.

Spell checking wasn't working. I right clicked in a text box, "Check Spelling" was enabled but none of my five English dictionaries that I have installed were. On selecting a dictionary, spell checking started to work.

I'm obviously seeing something slightly different to Doug but what I am seeing has been consistent for Firefox 9 & 10 installed on Ubuntu and Kubuntu, i..e. when starting a newly upgraded Firefox, the dictionary setting is lost giving the impression that spell checking is not working.

Doug McMahon (mc3man) wrote :

As a test added the firefox-next ppa to an 11.10 install where SC worked & the language was selected., (English/US).
  After upgrading 8.X > 10.X, SC failed as there was no language selected when reopening FF

Same was true when then creating a new user, logging in & opening FF.

jerriy (jerriy-7) wrote :

In my case the problem is that the ubuntu browser (FF 9.0.1) has MULTIPLE LANGUAGES installed and it does something it never did before: it AUTOMATICALLY chooses a RANDOM (usually WRONG) language whenever I want to spell check. In the past I and I alone MANUALLY picked a language and that choice remained the chosen language until I changed it.

I want this entire stupid "auto detect and select spellcheck language" bug to be COMPLETELY incapacitated and the former (manually picking) system fully restored ASAP. It's driving me crazy that every single time I went to spell check (even after 5 minutes I have to readjust the language choice! This is ridiculous!!!

Christopher (soft-kristal) wrote :

I'm not having the same issue - did you check Preferences - Content - Languages? You could also install the addon After the Deadline until your onboard spell check is working again.

p.s. 'addon' and 'onboard' are being shown as spelling errors as I type this.

Doug McMahon (mc3man) wrote :

This is i guess the way it will be -
On any new install no language will be selected in Firefox. so no speell checking will happen till one is.
This continues in 12.10

Doug McMahon (mc3man) on 2013-07-15
tags: added: raring saucy
Changed in firefox (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in hundredpapercuts:
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
Changed in hundredpapercuts:
assignee: Papercuts Ninjas (papercuts-ninja) → nobody
status: New → Triaged
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers