[dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2

Reported by immysl on 2011-10-29
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
unity-2d
Medium
Tiago Salem Herrmann
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

This happens when I hit ALT + F2 first time after boot. But from second time onwards, it works properly.

Related branches

lp:~tiagosh/unity-2d/bugfix-883392
Merged into lp:unity-2d at revision 839
Gerry Boland: Approve on 2012-01-03
Lohith D Shivamurthy (community): Approve on 2012-01-02
lp:~tiagosh/unity-2d/unity-2d-shell-homelens
Merged into lp:unity-2d at revision 910
Albert Astals Cid: Approve on 2012-02-13
Gerry Boland: Pending requested 2012-02-10
Michał Sawicz: Pending requested 2012-02-10
Albert Astals Cid: Approve (fun) on 2012-02-10
Gerry Boland: Needs Fixing on 2012-02-03
Michał Sawicz: Abstain on 2012-02-03
Gerry Boland (gerboland) on 2011-10-31
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
Gerry Boland (gerboland) on 2011-10-31
summary: - Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
+ [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
Changed in hundredpapercuts:
status: New → Confirmed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
assignee: nobody → Lohith D Shivamurthy (dyams)
Gerry Boland (gerboland) wrote :

Please have a look at 847486 in case it is not fixed fully and causing this.

Lohith D Shivamurthy (dyams) wrote :

I can't reproduce it from the trunk.

Lohith D Shivamurthy (dyams) wrote :

This can be reproduced in daily ppa though

Lohith D Shivamurthy (dyams) wrote :

I observed that,
If you first open Dash home, i.e. hit super key,then you hit Alt-F2, you won't see this bug.
I think whenever the dash is displayed for the first time, it shows 'search'.
I can' t reproduce this bug, if i run the places from QtCreator.

Gerry Boland (gerboland) on 2011-11-19
Changed in unity-2d:
milestone: none → 5.2
Gerry Boland (gerboland) on 2011-11-24
Changed in unity-2d:
assignee: Lohith D Shivamurthy (dyams) → nobody
Albert Astals Cid (aacid) wrote :

FWIW this happens in Unity-3D too, if the first thing you do after logging in is press Alt+F2 it shows search, afterwards it shows "Run Command"

Tiago Salem Herrmann (tiagosh) wrote :

This behavior is only reproducible when places app is not running yet. It is not started by default.
If you kill unity-2d-places and then run "qdbus com.canonical.Unity2d.Dash /Dash com.canonical.Unity2d.Dash.activateLens commands.lens", dbus will launch places on demand and the bug is reproducible.

Changed in unity-2d:
assignee: nobody → Tiago Salem Herrmann (tiagosh)
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity-2d - 5.2.0-0ubuntu1

---------------
unity-2d (5.2.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Select quicklist items with just one right click (LP: #688830)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - right click on the dash icon should display a list of the lenses
      (LP: #868452)
    - Top Bar - rename the "Desktop" title in the Top Bar (displayed when no
      window has focus) to "Ubuntu Desktop" (LP: #869873)
    - Application title on quicklist should be bold (or more visible)
      (LP: #900400)
    - unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
      (LP: #831868)
    - unity-2d-places crashed with SIGSEGV in QScriptValue::call()
      (LP: #836498)
    - unity-2d-launcher crashed with SIGSEGV in geis_finish() (LP: #850893)
    - unity-2d-places crashed with SIGABRT in raise() (LP: #857575)
    - unity-2d-launcher crashed with SIGSEGV in exit() (LP: #859596)
    - [spread] layout broken since bzr revision 799 of lp:unity-2d
      (LP: #900895)
    - [workspace switcher] keyboard navigation of workspace switcher broken
      for accessibility (LP: #744978)
    - [spread] workspace switcher performance is poor, especially on low
      powered CPUs (LP: #745764)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - [dash] Huge performance hit when scrolling search results with
      accessibility enabled (LP: #862956)
    - DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
      environment making gedit and possibly others fail to start (LP: #873027)
    - Win Key can not be disabled in Unity-2d (LP: #873580)
    - [dash] Unity-2d dash very slow to open (LP: #881756)
    - [tests] LauncherViewTest hanging (LP: #894380)
    - [tests] Unit tests failing due to lack of Xserver (LP: #894381)
    - [launcher] Alt+F1 broken: does not give the focus to the launcher's
      content (LP: #901505)
    - [tests] Add Automated User Experience testing (LP: #903495)
    - [workspace switcher] Performance can be poor when using the opengl
      backend because of window texture sizes that are not limited
      (LP: #808716)
    - [dash] no way to unmaximize (LP: #860400)
    - [launcher] In non-composite mode, background is black (LP: #879288)
    - [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
      (LP: #883392)
    - [launcher] Removing icon from launcher makes it hide immediately
      (LP: #884410)
    - OpenGL disabled regardless of use-opengl setting (LP: #887957)
    - if libdir does not equal lib (LP: #888164)
    - [launcher] Launcher stuck open while mouse moved to left corner of panel
      (LP: #892004)
    - [dash] Long results label are truncated instead of elided and a few
      pixels of the next line is visible (LP: #901491)
    - [launcher] Dash icon missing...

Read more...

Changed in unity-2d (Ubuntu):
status: New → Fix Released
Adam Niedling (krychek) on 2012-03-13
Changed in hundredpapercuts:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers