Unity says "Home Folder" no matter where I am

Reported by Logan McNaughton on 2011-04-14
212
This bug affects 41 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
One Hundred Papercuts
Medium
Shiyam M
nautilus (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: nautilus

In Ubuntu Unity, Nautilus shows up as "Home Folder" in the launcher (tooltip) and in the panel (application menu) when the window is not maximized. But if I open it, then go anywhere else in the file system, it still says "Home Folder" in both places. It should either say "File Manager", or the name of the folder I'm currently looking at.

Desired resolution:
- The Nautilus icon in the Launcher should always be titled 'File Manager'.

- When a Nautilus window is in the restored state, the global menu should display 'File Manager' (when a Nautilus window is maximised the global menu will display the window title).

Logan McNaughton (loganmc10) wrote :
affects: nautilus (Ubuntu) → unity (Ubuntu)
Logan McNaughton (loganmc10) wrote :

Note that this only happens when the window is not maximized. If the window is maximized the title is shown correctly (the name of the folder you're in). When the window is maximized, it always says "Home Folder".

Logan McNaughton (loganmc10) wrote :

Sorry, when its NOT maximized, it always says "Home Folder"

summary: - Nautilus says "Home Folder" no matter where I am
+ Unity says "Home Folder" no matter where I am
description: updated
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

the launcher is matching with the icon in the default configuration, some design input would be useful on how to handle the issue

Rocko (rockorequin) wrote :

I upgraded a Maverick installation to Natty some time ago and instead of 'Home Folder' it says 'File Manager'. While we wait for design input, I think it would be far better to change it to say 'File Manager' than 'Home Folder'. 'Home Folder' is just misleading.

It should say Home Folder and should open the Home Folder whenever it's
clicked on.

Rocko (rockorequin) wrote :

@Mark: While it's fine for the launcher icon to be called 'Home Folder', should the global menu display 'Home Folder' if nautilus is displaying a different folder at the time? It's obviously wrong and somewhat confusing if the global menu says Home Folder when you are showing the contents of, for instance, /usr/src. I guess the problem is that the global menu shows the application's title but the launcher in this case is configured to show just one possible window within that application.

btw, a workaround while Ayatana figures out how to change the global menu title based on which folder is open is to manually edit the /usr/share/applications/nautilus-home.desktop file and change the title to something more generic, like 'File Manager' or 'Nautilus'.

Mattia Guidi (matguidi) wrote :

@Rocko: the workaround you suggest probably works with the English version, but on my computer (I run Ubuntu in Italian), even if I change the name of the command from "Home folder" to "Nautilus" (or whatever name), I still get "Cartella home" ("Home folder") in the global menu. I guess this happens because I should modify the translation file, but I don't know where it is located...

John Lea (johnlea) on 2011-06-24
description: updated
tags: added: udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
Matt Giuca (mgiuca) wrote :

@John Lea What was the fix?

Neil J. Patel (njpatel) on 2011-06-30
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 4.4.0
status: Confirmed → Triaged
John Lea (johnlea) on 2011-06-30
Changed in ayatana-design:
status: Fix Committed → Fix Released
Jorge O. Castro (jorge) on 2011-07-01
tags: added: backlog
Didier Roche (didrocks) on 2011-07-05
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0

Still getting this problem in an Oneiric Beta 1 LiveUSB session.

ubuntu@ubuntu:~$ dpkg -s unity | grep Version
Version: 4.10.2-0ubuntu2

John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: 4.8.0 → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Matthew Goode (happyhouse19) wrote :

This bug appears to still exist in Oneiric. Will this be solved for Precise, since it is very misleading.

Rocko (rockorequin) wrote :

Actually, the situation is even worse in Precise. In Oneiric at least the non-maximized nautilus window title shows the currently selected folder's name; in Precise it displays 'Home' for any folder.

Gao Shichao (xgdgsc) wrote :

Still a problem in precise. In my opinion, tooltip and menubar should always show the current folder name. Current tooltip of "Home Folder" is confusing and weird, and the appmenu title is OK since it's far from concentration of the program when not maximized.

Chris Wilson (notgary) on 2012-06-11
Changed in hundredpapercuts:
milestone: none → quantal-5-unity
importance: Undecided → Medium
Chris Wilson (notgary) on 2012-06-12
Changed in hundredpapercuts:
status: New → Triaged
assignee: nobody → Papercuts Ninja (papercuts-ninja)
John Lea (johnlea) on 2012-06-25
Changed in hundredpapercuts:
assignee: Papercuts Ninja (papercuts-ninja) → nobody
Changed in unity:
assignee: Neil J. Patel (njpatel) → nobody
description: updated
John Lea (johnlea) on 2012-09-03
Changed in unity:
importance: Low → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
Chris Wilson (notgary) on 2012-10-22
Changed in hundredpapercuts:
milestone: quantal-5-unity → raring-round-3
Chris Wilson (notgary) on 2012-11-28
Changed in hundredpapercuts:
milestone: none → raring-ee
Chris Wilson (notgary) on 2012-11-29
Changed in hundredpapercuts:
milestone: app-descriptions → none
Nathan Korth (computernut401) wrote :

In Precise, there are two ways to open Nautilus from the dashboard, one called Home Folder and one called Files. Files behaves correctly, but Home Folder is the one on the launcher by default. Their behavior seems to depend on which one is on the launcher. When I had Home Folder on the launcher, a new window opened through the Files icon was grouped with Home Folder and had its erroneous top-bar behavior. Now that I've removed Home Folder from my launcher and replaced it with Files, if I open a window from Home Folder through the dashboard the window is treated as a Files window and behaves properly.

Denis Washington (dwashington) wrote :

The launcher icon and title top-bar title should simply be called "Files", which is also how Nautilus calls itself in the About dialog and menus. In the 3.6 version shipped with Raring, it's even more confusing as the top-bar app menu consists only of a single item which, if opened with the "Home Folder" launcher, is also named "Home Folder" - again, regardless of the folder you are actually in.

Doug McMahon (mc3man) wrote :

Based on the bug description this is an easily fixed bug, can't see why it's taken so long or is even a papercuts item
Simply edit /debian/nautilus-home.desktop.in, change the _Name=Home Folder to _Name=File Manager & be done with this..

Matt Giuca (mgiuca) wrote :

+1

John Lea (johnlea) wrote :

@mc3man; are you volunteering to submit a patch to fix this then ;-)

Denis Washington (dwashington) wrote :

Actually, this seems to be fixed now. The Nautilus icon in the launcher now has "Files" as tooltip, and the menubar says "Files" too. I guess this bug can be closed.

Adolfo Jayme (fitoschido) wrote :

You're right, Denis: after the upload of nautilus version 1:3.6.3-0ubuntu8 to raring, the program icon in the Launcher now says "Files", fixing this bug. Though, it doesn't resolve the design decision to rename it to "File Manager", that would involve another patch to Nautilus...

Chris Wilson (notgary) on 2013-05-27
Changed in hundredpapercuts:
milestone: none → papercuts-s-unity
affects: unity → nautilus (Ubuntu)
no longer affects: unity (Ubuntu)
Shiyam M (mshiyamsam) wrote :

Hey everyone. I would like to help with this bug, but I'm new here, I'll be great if someone will help me to get started. I also have assigned me. Thanks.

Changed in hundredpapercuts:
assignee: nobody → Shiyam M (mshiyamsam)
Masoud Pourmoosa (amirmasoud) wrote :

This is fixed for me in 13.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers