Navigation between side pane and main window is difficult

Bug #709098 reported by Lars Jarlvik on 2011-01-28
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nautilus
New
Undecided
Unassigned
One Hundred Papercuts
Wishlist
Unassigned
nautilus (Ubuntu)
Wishlist
Unassigned

Bug Description

Moving focus between the side pane and the main window using only the keyboard is very difficult. Currently, you have to move focus from the side pane to the main window by first pressing the tab key followed by the down cursor key twice. This would be made far easier if it was simply <tab> that was needed to move from the said pain to the main window, and <tab> again to move back. This would mean that the <tab> would simply move focus between the side pane and main window and back again.

It should also be the case the focus is automatically given to the main window, so that the user can immediately be given the opportunity to browse their files/folders in the folder of their choice, and they can use the tab to move back to the side pane.

I think it would be a good idea to allow this functionality to work from anywhere within the main window (ie, you don't have to be in the far left row).

Thanks a lot for reporting this, however I am unable to reproduce the behaviour you describe. When I start Nautilus, I am able to navigate the folder content using the keyboard without having to first direct focus there.

This sound like there may be a problem with your system, perhaps an attribute in a configuration file has been set to a non-default value and is causing this behaviour. You should seek assistance for this issue either at http://askubuntu.com or http://ubuntuforums.org.

Changed in hundredpapercuts:
status: New → Invalid
Lars Jarlvik (lars-jarlvik) wrote :

Sorry I reported an invalid issue. Weren't reporting it from my Ubuntu at the time.

The issue is when using the side pane to navigate to one of your favorites. Instead of focusing the folder you navigated to nautilus still has focus in the side pane which results in when you try to type a folder name nautilus searches for it in the side pane instead of the folder content.

Ah, now that sounds like a valid paper cut. The problem is that if it automatically focused on the main window, then it would be more difficult to navigate through the side pane if you kept having to reset focus.

When I tested it, I was able to move focus from the side pane to the main window by first pressing the tab key followed by the down cursor key twice. This would be made far easier if it was simply <tab> that was needed to move from the said pain to the main window, and <shift>+<tab> to move back.

I think it would be a good idea to allow the reverse functionality (<shift>+<tab>) to work from anywhere within the main window (ie, you don't have to be in the far left row).

I'm going to take the liberty of rewriting your title and description to reflect this, and I'll mark it as incomplete for the time being. If you are happy with this summation, then I#ll confirm it. If not, then please provide some feedback and we'll get this mailed down ;)

summary: - Nautilus should focus folder content on startup
+ Navigation between side pane and main window is difficult
description: updated
Changed in hundredpapercuts:
status: Invalid → Incomplete
Changed in nautilus (Ubuntu):
status: New → Incomplete
Lars Jarlvik (lars-jarlvik) wrote :

Sounds good, ease tabbing between the two panes are important since it's almost always between those to you would like to tab.

But I think the folder content should automatically gain focus if the side pane are in the places mode, but not if it's in tree view mode. I don't see why the user would be interested in opening another folder from the places pane immediately after choosing a place to open.

I have updated the description with the points you raised in comment #4, and have rewritten the new description so that instead of the suggested behaviour being <tab> to move from the side pane to the main window and <shift>+<tab> to move from the main window to the side pane, I have instead requested that <tab> solely be used to move back and forth between the two views. This is one less shortcut the user has to memorize.

description: updated
Changed in hundredpapercuts:
status: Incomplete → Confirmed
Changed in nautilus (Ubuntu):
status: Incomplete → Opinion
status: Opinion → Confirmed
Changed in hundredpapercuts:
importance: Undecided → Wishlist
status: Confirmed → Triaged
Vish (vish) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream/GNOME .
Once submitted upstream , do report back here with the upstream bug number.Thanks in advance!

Changed in hundredpapercuts:
status: Triaged → Confirmed
Changed in nautilus (Ubuntu):
importance: Undecided → Wishlist
thinkpad (fellowsgarden) wrote :

what about F6 ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers