File manager's mouse icon is distracting...

Bug #689486 reported by Joshua "Youlysses " S. Grant on 2010-12-13
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Humanity
Undecided
Unassigned
One Hundred Papercuts
Low
Unassigned
Unity
Invalid
Undecided
Unassigned
humanity-icon-theme (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

every once in awhile in the unity launcher (usually when i leave from my computer for awhile and come back) i mistaken the file manager icon's pointer as the mouse's pointer.This temporarily confuses me and i believe people can infer that its the file manager without the pointer. I recommend changing the file manager icon to that of the home icon or editing the existing one ... just saying :P

I agree that the existence of a pointer icon as a part of the file manager icon is needlessly distracting, and I can envisage a situation where the pointer has moved off the screen, or is otherwise obscured and the user can mistake the icon atop the file manager icon for the actual pointer. I propose the adoption of one of the following solutions:

- The removal of the pointer icon from the file manager icon.
- The replacement of the current file manager icon with home folder icon as has been proposed in the bug description.

Changed in hundredpapercuts:
status: New → Confirmed
Alex Launi (alexlauni) wrote :

Whenever I click Unity it goes to hundredpapercuts. If someone could please set NULL back to hundredpapercuts, and Unity to NULL? I don't know what's going on with my browser, sorry for the confusion.

affects: hundredpapercuts → null
affects: unity → hundredpapercuts
Changed in hundredpapercuts:
status: New → Confirmed

Alex, why was the Unity task removed from this report?

Changed in null:
status: Confirmed → Invalid
Changed in hundredpapercuts:
importance: Undecided → Low
Omer Akram (om26er) wrote :

how about we move this bug to humanity-icon-theme?

Gord Allott (gordallott) wrote :

Invalid for unity, icon theme issue

Changed in unity:
status: New → Invalid
Omer Akram (om26er) on 2011-02-02
Changed in unity (Ubuntu):
status: New → Invalid
Vish (vish) wrote :

This is not humanity-icon theme bug. Unity needs to use an appropriate icon for representing "Folders" , (which ever it sees better) That icon is similar to the generic icon for web-browser (globe with pointer).

There are other icons of simple folder or the home icon which can be used instead, if required.

Changed in humanity-icon-theme (Ubuntu):
status: New → Invalid
Changed in humanity:
status: New → Invalid
zpletan (zpletan) wrote :

Unless I am mistaken, the icon in question is system-file-manager, which, among other things, is the icon used by nautilus. The potential for confusion also exists if Nautilus is pinned to Docky (or another dock), or if a launcher for the file browser is placed on the desktop or the panel - it is not specific to Unity, unless I missed something. As such, I am marking it valid for humanity. If this is actually not right, I will be happy to open a new bug properly. :)

Changed in humanity:
status: Invalid → New
Changed in humanity-icon-theme (Ubuntu):
status: Invalid → New
Vish (vish) wrote :

Yes, I am aware of the icon name used there.
But, simply using a "folder" alone is not appropriate for a "system-file-manager" reference. In the same way as using a globe alone is not an ideal reference for a "internet browser" .
We have discussed this , dont have any better alternate ideas here and dont intend to spend time on this. So even for docky we wont change it unless someone else has other better new idea.

Wont fix, unless someone shows us a better idea. :-)

Changed in humanity-icon-theme (Ubuntu):
status: New → Won't Fix
Changed in humanity:
status: New → Won't Fix
Vish (vish) on 2011-03-08
Changed in humanity-icon-theme (Ubuntu):
status: Won't Fix → In Progress
Changed in hundredpapercuts:
status: Confirmed → Invalid
Changed in ayatana-design:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package humanity-icon-theme - 0.5.3.5

---------------
humanity-icon-theme (0.5.3.5) natty; urgency=low

  * Network-manager icons for network-indicator; (LP: #700626)
  * Update mail-action icons to be consistent with universe; (LP: #523466)
  * Update 64px user-trash-full closer to 48px icon; (LP: #594177)
  * Update 16px search icon to not look like a radio menu dot; (LP: #662575)
  * Differentiate Root Terminal from Terminal icon; (LP: #688443)
  * File manager's mouse icon is distracting; (LP: #689486)
 -- K Vishnoo Charan Reddy <email address hidden> Tue, 08 Mar 2011 21:30:12 -0530

Changed in humanity-icon-theme (Ubuntu):
status: In Progress → Fix Released
Hernando Torque (htorque) wrote :

I'm now getting the system-file-manager icon from the GNOME theme, which really looks out of place (see attachment) in the Unity launcher (launcher item = nautilus.desktop). Is this on what you agreed now?

It's really inconsistent now...

Sebastien Bacher (seb128) wrote :

> I'm now getting the system-file-manager icon from the GNOME theme

that's because your user configuration was made from the old default and there is no migration code for unstable to unstable upgrades, just reset your launcher config or replace the nautilus launcher manually to workaround it

Hernando Torque (htorque) wrote :

All sorted out now. At first, starting Nautilus (unpinned) from the command line showed the file cabinet in the launcher, but now it's showing the house too, so it's easy to fix. :-)

Hernando Torque (htorque) wrote :

Forget the last comment - I manually changed the icon in '/usr/share/applications/nautilus.desktop' to 'user-home'. -.-

It's not just an unstable-to-unstable issue: when a user unpins the launcher item, then there's only this complete reset to get the right item back (if you don't want to fiddle around with dconf-editor & co.). Doesn't sound optimal.

Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers