MeMenu should use user's real name if available

Bug #682153 reported by Danté
68
This bug affects 32 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Manuel J. Garrido
The Me Menu
Undecided
Unassigned
indicator-me (Ubuntu)
Wishlist
Unassigned

Bug Description

Myself and friends have one major gripe with Ubuntu's MeMenu, that our real names are not used.

My name, for instance, is 'Danté', yet MeMenu uses our computer name, which is converted into 'dante'. I have friends with even more difficult names who have told me they find it slightly unsettling (and even, on some levels, insulting) that the computer does not use their proper name.

    gconftool -s /system/indicator/me/display --type int 2

That changes the MeMenu username to the User's actual name. I would suggest this to be default.

Related wiki entry:
https://wiki.ubuntu.com/MeMenu#Changes%20to%20About%20Me

Related branches

Changed in hundredpapercuts:
status: New → Confirmed
Rory Holland (blazemore)
Changed in hundredpapercuts:
status: Confirmed → Opinion
Revision history for this message
Jack Leigh (leighman) wrote :

Opinion isn't for this use-case, unless the bug has been rejected by a current package developer/maintainer.
Please make it clear that it has, if so.

Changed in hundredpapercuts:
status: Opinion → Confirmed
Paul Sladen (sladen)
summary: - MeMenu should use user's real name.
+ MeMenu should use user's real name if available
Revision history for this message
Vish (vish) wrote :

Huh, interesting! Accents do need to used and make the user comfortable in their own install. :-)

But what happens when users have very long names. Wouldnt we be wasting a lot of space?

@mpt: any suggestions?

Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → nt3-ayatana
Changed in indicator-me (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Revision history for this message
Vish (vish) wrote :

Personally, I hope someone works on <https://wiki.ubuntu.com/MeMenu#Changes%20to%20About%20Me> so that anyone could turn off(easier) the name displayed there.

Revision history for this message
Ed Hewitt (edhewitt-deactivatedaccount) wrote :

Agree, my username is 'ed' and just looks slightly stupid to have a two character name on the MeMenu.

Revision history for this message
papukaija (papukaija) wrote :

There's a related bug about adding a gui config for this at bug 438767.

description: updated
Revision history for this message
Dustin Kirkland  (kirkland) wrote :

Branch looks good, built/tested here. Uploading/sponsoring as today's patchpilot. Thanks!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-me - 0.2.10-0ubuntu2

---------------
indicator-me (0.2.10-0ubuntu2) natty; urgency=low

  * Show real name instead of username (LP: #682153)
 -- <email address hidden> (Manuel J. Garrido) Tue, 07 Dec 2010 20:37:55 +0100

Changed in indicator-me (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Ted Gould (ted) wrote :

We originally had this, but removed it because apparently in some locales it is offensive to have your computer refer to you by your full name. For instance, it should be "Mr. Gould" instead of "Ted Gould." We weren't able to get a good grasp on how to solve this so that it would be internationally acceptable so we continued with user name which is okay. There was a bug about changing it, but I'm failing to find it now. Personally, I prefer the longer name as well so it's okay in en_US ;)

Revision history for this message
Danté (dante-ashton) wrote :

Ooh! Thanks everyone! I'll go off and tell my slightly insulted friends ;)

Vish (vish)
Changed in hundredpapercuts:
assignee: nobody → mgarrido (mgarrido)
status: Confirmed → Fix Released
Revision history for this message
Manuel J. Garrido (mgarrido) wrote :

The change I did for fixing this bug has been removed in the revision 19 of indicator-me, so now this bug is not fixed. I don't know what should I do. Should I fix this bug again ?

Revision history for this message
papukaija (papukaija) wrote :

Yes, please fix it again.

Changed in indicator-me:
status: New → Confirmed
Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

Since ted has a point against this bug's fix in comment #8, this is a Won't fix for now.

Changed in hundredpapercuts:
status: Fix Released → Won't Fix
Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

Opinion is the right status.

Changed in indicator-me:
status: Confirmed → Opinion
Changed in indicator-me (Ubuntu):
status: Fix Released → Opinion
Revision history for this message
Danté (dante-ashton) wrote :

That's a bit of a shame; either way the system ends up insulting people...

Vish (vish)
Changed in hundredpapercuts:
milestone: nt3-ayatana → none
status: Won't Fix → Opinion
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions