"rebuilding software catalog" doesn't sound right

Bug #678355 reported by yman on 2010-11-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Matthew Paul Thomas
software-center (Ubuntu)
Low
Matthew Paul Thomas

Bug Description

I can't point to any screenshots, because the window disappeared on it's own before I was able to do anything. Basically, I opened USC, opened the Software Sources app from it, and edited my software sources from both app and the command line. After adding Medibuntu from the command line I used this command:
sudo apt-get --yes install app-install-data-medibuntu apport-hooks-medibuntu
after it executed it said it was doing something about some hooks and a window appeared saying "Rebuilding Software Catalogue" it was a big window with a small message. I don't like the wording either. It's too technical. It should be "Refreshing Software Catalogue".

Related branches

I would say that 'Refreshing Software Centre' would be a better option.

Changed in hundredpapercuts:
status: New → Confirmed
Matthew Paul Thomas (mpt) wrote :

What USC refers to as the "software catalogue" here is what apt calls the "apt cache". USC shows this catalog of software in the same way that a shopping site shows a catalog of things for sale.

That it's a big window with a small message is bug 605048.

yman (s-y-schwarz) wrote :

I think the text should be "Refreshing Software Catalogue". Even someone who isn't familiar with repositories and stuff like that will have a useful but vague notion of what a software catalogue is about, and have some idea from the use of web browsers of what refreshing might mean.

That's just to explain my rationale, but the solution offered in the original bug report is at least as good.

Matthew Paul Thomas (mpt) wrote :

Ok, let's change it to "Updating software catalog". "Refreshing" is a bit vague, and we already have a message elsewhere that says "To show information about this item, the software catalog needs updating.".

Changed in software-center (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Undecided → Low
status: New → In Progress
Vish (vish) on 2010-12-03
Changed in hundredpapercuts:
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Undecided → Low
milestone: none → nt7-potpourri
status: Confirmed → In Progress
Changed in hundredpapercuts:
status: In Progress → Fix Committed
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.4

---------------
software-center (3.1.4) natty; urgency=low

  [ Michael Vogt ]
  * softwarecenter/db/database.py:
    - add section and origin query parser prefixes, thanks to
      Matthew McGowan!
  * merged lp:~mvo/software-center/experimental-fastlist and
    lp:~kiwinote/software-center/experimental-fastlist, this should
    speed up the list rendering quite a lot
  * merged lp:~kelemeng/software-center/bug685467, many thanks!
    (LP: #685467)
  * softwarecenter/backend/aptd.py:
    - ported to the aptdaemon 0.40 API
  * debian/control:
    - depend on aptdaemon 0.40

  [ Kiwinote ]
  * softwarecenter/backend/channel.py:
    - only show installed packages in the 'for purchase' channel of the
      installed pane (LP: #684356)
  * softwarecenter/utils.py:
    - don't return a http proxy string if it contains no host (LP: #675186)
      thanks to Marius Gedminas
  * softwarecenter/view/appview.py:
    - don't crash in natty due to seemingly deprecated xapian.query attribute
      get_description (LP: #684887)
  * softwarecenter/view/channelpane.py:
    - don't explicitly show all pkgs for the partner channel, this is no
      longer needed because all apps now have app-install-data desktop files
  * softwarecenter/view/widgets/searchentry.py:
    - reverse the 'clear' icon for rtl as requested in (LP: #666519)
  * softwarecenter/app.py:
    - do not crash when showing a already installed package and the apt
      cache is not loaded yet

  [ Matthew Paul Thomas ]
  * data/ui/SoftwareCenter.ui:
    - improved text for software catalog update window (LP: #678355)
 -- Michael Vogt <email address hidden> Tue, 07 Dec 2010 15:02:40 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) on 2010-12-07
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers