battery critically low dialog doesn't disappear when plugged in

Bug #608770 reported by Manuel R. Ciosici on 2010-07-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

When the laptop battery is very low an alert dialog is shown to the user. If the dialog isn't dismissed, but the laptop is plugged in the dialog does not disappear automatically and could become a source of confusion for a newcomer to Ubuntu of a novice user of a PC.

See image below where the laptop has been plugged in, but the dialog is still present.

Bilal Akhtar (bilalakhtar) wrote :

It would be good to fix such a bug, but is it really possible to externally get a dialog to close? Marking confirmed, but not triaged and not milestoning it, for now.

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed
tags: added: usability
Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Neil H (neilhillen) wrote :

In addition to this, it would be great if it additionally would make clear what OK and Cancel mean. Does OK mean it will shut down? If not, there should be one "dismiss" button. If it hoes hibernate the message should indicate that or the button should say hibernate. This is a trivial change - but one that needs to be done.

Thanks a lot for reporting this, however this is not a bug since the battery indicator is designed to not disappear until the battery is fully charged. What you observe is the intended behaviour.

Changed in hundredpapercuts:
status: Confirmed → Invalid
Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Invalid
Bilal Akhtar (bilalakhtar) wrote :

This isn't invalid, but instead a bug that was fixed when bug #533652 was fixed.

Changed in hundredpapercuts:
milestone: none → nt7-potpourri
status: Invalid → Fix Released
Changed in gnome-power-manager (Ubuntu):
status: Invalid → Fix Released
Rushi Agrawal (rushiagr) wrote :

Chris, I guess there was slight misunderstanding. Manuel was intending that the 'dialog box' which says 'battery cricital, plug in charging' doesn't go away when one plugs in the charger. I think the 'dialog box' should go away as soon as battery is plugged in. You are right that the battery 'indicator' mustn't disapper, but that 'dialog box' should as soon as you plug the charger.

I am noticing the same issues even now, in Ubuntu 13.04. It would be great if this UI inconvenience is fixed.

Thanks.

Rushi Agrawal (rushiagr) wrote :

Please open this bug again for gnome-power-manager, so that the people can track and triage and later fix it?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments