Description: Akonaditray

Bug #602705 reported by Onno Steenbergen
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Akonadi
Invalid
Undecided
Unassigned
One Hundred Papercuts
Low
Unassigned
akonadi (Ubuntu)
Undecided
Unassigned
app-install-data-ubuntu (Ubuntu)
Low
Unassigned

Bug Description

Wonderfull description:
This package contains akonadi agents written using kdelibs. Any package that uses akonadi should probably pull this in as a dependency. The kres-bridges is also parts of this package.
This package is part of the kdepim-runtime module

To technical to be even listed under Provided by Ubuntu

Changed in hundredpapercuts:
status: New → Confirmed
Revision history for this message
Vish (vish) wrote :

The description certainly can be improved.
 However , in Maverick , the rest of the Akonadi items are hidden. Is this also a "technical item" which was missed ? or is this a tray utility which needs a better description.

Changed in kdepim-runtime (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → maverick-round-9-sc-metadata
tags: added: metadata
Revision history for this message
Harald Sitter (apachelogger) wrote :

Be improved? Oo
After reading this 3 times I still have no idea what you are people are talking about...

Changed in kdepim-runtime (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Vish (vish) wrote :

@Harald Sitter:
The way it presents itself in SC , it seems like a tray applet which can be installed for quick access to PIM data , but reading the description it says nothing about the application or what it does or what is can be used for.

And since I dont use Kubuntu , I dont know if is an app or just a package installed by default.
All I could guess[from the package name kdepim-runtime] is that It probably is not an application and an item which needs to be hidden.

As I mentioned earlier , If it is not a tray applet , it just needs to be hidden in SC by default.
Or if it's an applet , the description needs to have some mention of it's use.

Revision history for this message
Harald Sitter (apachelogger) wrote :

<apachelogger> AHHHHHHHHHHHHHH
<apachelogger> vish: well, I understand the problem ;)
<apachelogger> vish: and I also know why this seems confusing to you
<vish> sweet!! :)
<apachelogger> see there is this large package kdepim-runtime which among other things contains the actual application akonaditray which nests in the systray (obviously)
<apachelogger> ...now...
<apachelogger> software center drains it's package list from desktop files (where each real app should have one) ... so software center lists akonaditray (which is an actual application) but uses the description of kdepim-runtime (the large package it is part of)
<apachelogger> so it is rather a bug in software center
<vish> oh!
<apachelogger> possible the underlying data that provide the list of applications software center uses

affects: kdepim-runtime (Ubuntu) → software-center (Ubuntu)
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Ubuntu Software Center uses data provided by app-install-data (and will soon use data provided by Soyuz in the same way).
The script that produces app-install-data finds Akonaditray's .desktop file inside kdepim-runtime, and assumes that it is an application that's the most important thing in the package.

So, I can think of three practical ways of fixing this problem:
1. Design a solution to bug 539330 such that there is a defined way for USC to ignore .desktop files inside packages.
2. Move Akonaditray out of kdepim-runtime into its own package.
3. Bite the bullet and rewrite the kdepim-runtime description to cover Akonaditray only.

Changed in software-center (Ubuntu):
status: Incomplete → New
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

4. Remove Akonaditray's .desktop file, if it doesn't actually need one.

Andrew (and471)
Changed in software-center (Ubuntu):
status: New → Invalid
Revision history for this message
Harald Sitter (apachelogger) wrote :

I had a disucssion with Debian and upstream about a very similar application some time ago where we agreed that moving it into a seperate package was no option because the application does not do nearly enough (important tasks) on its own to be of any use outside the scope of kdepim-runtime.

That in mind I do not think that 2. is an option here, 3. is either because it would just be wrong limiting the description to but one part of the package (not even the most important one really). Additionally since akonaditray does not autostart by default a desktop file is absolutely necessary, which pretty much eliminates 4.

One could however enhance the description a bit more to cover akonaditray. Supposedly the description is a bit dated and akonaditray only got added to kdepim-runtime after the description was written. Of course that only improves the situation a bit, the fact that software center and the package description are talking about two completely different components remains.

Changed in software-center (Ubuntu):
status: Invalid → New
Revision history for this message
Harald Sitter (apachelogger) wrote :

Closing the upstream akonadi task - this is no upstream issue.

Changed in akonadi:
status: New → Invalid
Vish (vish)
Changed in hundredpapercuts:
milestone: maverick-round-9-sc-metadata → nt10-sc-metadata
affects: software-center (Ubuntu) → app-install-data-ubuntu (Ubuntu)
Revision history for this message
Jjed (jjed) wrote :

Hello, app-install-data-ubuntu only aggregates metadata that exists in the ubuntu archive. To fix this, please modify the desktop file shipped in `akonadi`'s debian package. Thanks

Changed in app-install-data-ubuntu (Ubuntu):
status: New → Invalid
Changed in akonadi (Ubuntu):
status: New → Invalid
Changed in app-install-data-ubuntu (Ubuntu):
status: Invalid → New
Changed in hundredpapercuts:
milestone: nt10-sc-metadata → precise-8-softwarecenter-app-descriptions
Changed in hundredpapercuts:
milestone: precise-8-softwarecenter-app-descriptions → quantal-3-software-centre-app-metadata
Changed in hundredpapercuts:
milestone: quantal-3-software-centre-app-metadata → raring-round-6
Changed in hundredpapercuts:
milestone: raring-round-6 → none
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in app-install-data-ubuntu (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers