Description: p7zip

Bug #602671 reported by Onno Steenbergen
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Akshat Jain
Baltix
Undecided
Unassigned
p7zip (Debian)
Fix Released
Unknown
p7zip (Ubuntu)
Low
Unassigned

Bug Description

Description:
"p7zip is the Unix port of 7-Zip, a file archiver that archives with very high compression ratios.

p7zip-full provides:
- /usr/bin/7za a standalone version of the 7-zip tool that handles 7z achives (implementation of the LZMA compression algorithm) and some other formats.
- /usr/bin/7z not only does it handle 7z but also ZIP,.... and DEB archives. 7z compression is 30-50% better than ZIP compression

p7zip provides 7zr, a light version of 7za, and p7zip a gzip like wrapper around 7zr."

Nerdy and not mentioning that the archive utility can be used as a GUI to extract the archive. It only mentions commandline tools.

"p7zip-full provides" is the package name and this should just be 7zip (the title on top) or 'This software"

-----
Suggested Description:

Provides utilities to pack and unpack 7z archives with File Roller and using the Terminal.
Installing 7zip allows File Roller to use the very efficient 7z compression format for packing and unpacking files and directories. Additionally, it provides you with the 7z and 7za commands at the command line.

Complete list of supported formats handled in p7zip-full:
  * Packing / unpacking: 7z, ZIP, GZIP, BZIP2 and TAR
  * Unpacking only: ARJ, CAB, CHM, CPIO, DEB, DMG, HFS, ISO, LZH, LZMA, MSI, NSIS, RAR, RPM, UDF, WIM, XAR and Z.

Revision history for this message
Onno Steenbergen (osteenbergen) wrote :

New Description:

7zip extends the Archive Utility with the possibility to handle 7zip files. Also provided are command line utilities.

Revision history for this message
Vish (vish) wrote :

The suggestion in comment #1 is an over simplification. However , the description can be improved,

Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → maverick-round-9-sc-metadata
status: New → Confirmed
Changed in p7zip (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Revision history for this message
Benjamin Geese (ben-8409) wrote :

Proposal

7zip provides utilities to pack and unpack 7z archives with File Roller and using the Terminal.
Installing 7zip allows File Roller to use the very efficient 7z compression format for packing and unpacking files and directories. Additionally, it provides you with the 7z and 7za commands at the command line.

Complete list of supported formats:
  * Packing / unpacking: 7z, ZIP, GZIP, BZIP2 and TAR
  * Unpacking only: ARJ, CAB, CHM, CPIO, DEB, DMG, HFS, ISO, LZH, LZMA, MSI, NSIS, RAR, RPM, UDF, WIM, XAR and Z.

Vish (vish)
Changed in hundredpapercuts:
milestone: maverick-round-9-sc-metadata → nt10-sc-metadata
Greg A (etulfetulf)
tags: added: metadate
tags: added: metadata
removed: metadate
Revision history for this message
Vish (vish) wrote :

The Bug still needs to be forwarded to debian.

description: updated
Changed in hundredpapercuts:
assignee: nobody → Papercuts Ninja (papercuts-ninja)
status: Confirmed → Triaged
Revision history for this message
Andrea Lazzarotto (Lazza) (andrea-lazzarotto) wrote :

Are you sure about RAR? I think 7zip needs an external library to handle that.

Revision history for this message
Micah Gersten (micahg) wrote :

The description needs to contain the essence of the current description which is why do I install p7zip over p7zip-full

Revision history for this message
Vish (vish) wrote :

Micah Gersten, p7zip package is hidden by default. And only p7zip-full package is displayed in SC when you search for 7zip.
The original description contains unnecessary reference to being an Unix port and references /usr/bin/* .
The new description, suggested in comment#3, is intended to remove jargon and make it better for everyone to understand.
If the new one is confusing too, any suggested changes ?

Also, anyone sure that RAR is part of p7zip?

Akshat Jain (akshatj)
Changed in hundredpapercuts:
assignee: Papercuts Ninja (papercuts-ninja) → Akshat Jain (ssj6akshat1234)
Akshat Jain (akshatj)
Changed in hundredpapercuts:
status: Triaged → In Progress
Vish (vish)
description: updated
Revision history for this message
Akshat Jain (akshatj) wrote :

Here is a patch that applies the proposed description.

Akshat Jain (akshatj)
Changed in hundredpapercuts:
assignee: Akshat Jain (ssj6akshat1234) → nobody
tags: added: patch
Revision history for this message
Vish (vish) wrote :

Akshat Jain, Any luck with filing the bug in debian?

If you are still having trouble, have a look at :
https://wiki.ubuntu.com/Debian/Bugs
http://www.debian.org/Bugs/Reporting

The patch needs to be forwarded upstream.

Changed in hundredpapercuts:
assignee: nobody → Akshat Jain (ssj6akshat1234)
Revision history for this message
Bhavani Shankar (bhavi) wrote :

@Akshat:

Good work but a small nitpick:

when you forward the patch please make sure you wrap around the description to 80 characters per line ideally so it appears neat and also

secondly I found a typo in the changelog "s/te/the" and a space can be left after the asterisk in the changelog to make it look something like:

* Edited the description to make it less geeky

Thirdly, as vish pointed out this is something which needs to be fixed in debian So please follow the above links in vish's comment in case you are experiencing problems doing so and please add a bugwatch here so that we can track the reported bugs' progress

Regards

Revision history for this message
Paul Sladen (sladen) wrote :

Aksat: thank you for the patch! If you get a chance, could you possibly tweak it to have word-wrapping and also a "(LP: #602671)" reference to this bug; then we can forward it to Debian.

Changed in p7zip (Debian):
status: Unknown → New
Changed in p7zip (Debian):
status: New → Fix Released
Revision history for this message
Timothy Arceri (t-fridey) wrote :

Debian Bug has been closed with a slightly improved description. If you are still not happy you might need to open a new bug.

Changed in p7zip (Ubuntu):
status: Confirmed → Fix Released
Changed in hundredpapercuts:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.