Frets on Fire description is confusing

Bug #599525 reported by Mohamed Amine Ilidrissi on 2010-06-28
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Andrew
app-install-data-ubuntu
Fix Committed
Undecided
Unassigned
fretsonfire (Debian)
Fix Released
Unknown
fretsonfire (Ubuntu)
Low
Unassigned

Bug Description

Here's the Frets on Fire description in the Software Center:

"Frets on Fire is a game of musical skill and fast fingers. The aim of the game is to play guitar with the keyboard as accurately as possible.

This is the package containing the game code. You will need working sound and an open-gl capable graphics card."

The last line is unnecessary and confusing for the end-user.

Vish (vish) on 2010-06-29
Changed in fretsonfire (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → maverick-round-9-sc-metadata
status: New → Triaged
Andrew (and471) on 2010-06-30
Changed in fretsonfire (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
Andrew (and471) on 2010-06-30
Changed in hundredpapercuts:
assignee: nobody → Andrew (and471)
Andrew (and471) wrote :

Forwarded to Debian, I shall work on it there

Vish (vish) on 2010-06-30
Changed in fretsonfire (Ubuntu):
status: Confirmed → Triaged
Changed in fretsonfire (Debian):
status: Unknown → New
Andrew (and471) wrote :

<and471> Can someone confirm this is an issue so that I can work on a debdiff? http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=587621
<pabs> mjj29 said he will probably package one of the forks and remove fretsonfire, so it probably isn't worth working on
<and471> pabs, ok
<and471> pabs, and that should make its way into ubuntu as well?
<pabs> if they autosync it yeah
<and471> pabs, cheers

So it looks like Debian is going to remove fretsonfire and package a fork.

@Vish, what do you think is the best course of action now?

Vish (vish) wrote :

Andrew: Does that mean it will be removed from the Ubuntu archive as well? If not , we might have to patch the Ubuntu package.
Also , we might have to watch out for the fork , and hope it does not have the same problem.

Andrew (and471) wrote :

I don't know, hopefully tomorrow I can speak to mjj29 (guy mentioned above) as after the conversation above, pabs said it best to talk to him as he wasn't 100% sure.

Definitely! :)

Vish (vish) wrote :

Andrew, dug deeper here and found two bugs related to fretsonfire, and will be fixing both of them:

<and471> I have just noticed a bug in app-install-data, it should point to the meta package, not just the games files
<and471> but app-install-data incorrectly points to fretsonfire-game

<and471> I shall make a merge request for app-install-data to use the metapckage, not the game code package
<and471> and just change the description for the metapackage, http://pastebin.ubuntu.com/480315/ of their slogan

Andrew (and471) wrote :

Debian hasn't given me any progress and so I have updated the ubuntu package myself. Hopefully next cycle they will have decided what they want to fork etc. and we can receive this.

Linked is the merge request for this.

Changed in fretsonfire (Ubuntu):
status: Triaged → Fix Committed
Andrew (and471) wrote :

One problem we have is that we want Software Center to show fretsonfire and point to the metapackage, not just the game package.

App-install-data (which provides the data) currently points the fretsonfire.desktop file to the game package because the .desktop file is in the game package (not the metapackage) however we don't want to move the file, as it defies the point of a metapackage.

Is there any way to provide, say, an override?

Andrew (and471) on 2010-08-20
Changed in fretsonfire (Ubuntu):
status: Fix Committed → Confirmed
Andrew (and471) wrote :

Ok, mvo has just made it so that app-install-data uses the fretsonfire metapackage now (http://bazaar.launchpad.net/~mvo/archive-crawler/mvo/revision/102)

I have now updated the branch so that it only contains the change to the description of fretsonfire. It is ready for merging! :)

Andrew (and471) on 2010-08-23
Changed in app-install-data-ubuntu:
status: New → Fix Committed
Changed in hundredpapercuts:
status: Triaged → Fix Committed
Changed in fretsonfire (Ubuntu):
status: Confirmed → Fix Committed
Stefano Rivera (stefanor) wrote :

Andrew: Please don't set fix committed on Ubuntu bugs, unless you have a pending upload.

https://wiki.ubuntu.com/Bugs/Status
Fix Committed is *not* to be used when a patch is attached to a bug

Andrew (and471) wrote :

Ah sorry Stefano, set it to In Progress and wont do it again :)

Changed in fretsonfire (Ubuntu):
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fretsonfire - 1.3.110.dfsg-2ubuntu1

---------------
fretsonfire (1.3.110.dfsg-2ubuntu1) maverick; urgency=low

  * Edited debian/control
    Better description for package 'fretsonfire' describing gameplay,
    included applications etc. and removing non-user-friendly 'this is
    a metapackage...' (LP: #599525)
 -- Andrew Higginson <email address hidden> Mon, 23 Aug 2010 11:52:55 +0200

Changed in fretsonfire (Ubuntu):
status: In Progress → Fix Released
Vish (vish) on 2010-08-23
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in fretsonfire (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.