Make printer jobs viewer HIG compliant

Bug #555213 reported by Sergey Nizovtsev on 2010-04-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
System Config Printer
Fix Released
Unknown
system-config-printer (Ubuntu)
Wishlist
Unassigned

Bug Description

Menubar in system-config-printer-applet looks ugly:
1. Application shouldn't use "File" menu if there are no files it works with.
2. "View" menu is too short.
3. User should make 2 clicks for job operation: first he opens menu, and second he clicks on an operation.

I've make a patch which replaces menubar with toolbar.
Before:
http://sites.google.com/site/snizovtsev/scpa-before.png
After:
http://sites.google.com/site/snizovtsev/scpa-after.png

Thanks.

Vish (vish) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream.
Once submitted upstream , do report back here with the upstream bug number.
Thanks in advance!

Changed in system-config-printer (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed
tags: added: patch
removed: hig usability
Changed in system-config-printer (Ubuntu):
importance: Low → Wishlist
Till Kamppeter (till-kamppeter) wrote :

Note also that your patch works and looks nice (I have tried it), but it is not a candidate for Lucid, as we are already past UI freeze. In Maverick we will adopt it, I hope simply coming from upstream.

Till Kamppeter (till-kamppeter) wrote :

Tim, I have checked again and I must have taken the master branch accidentally. What I am selling to Ubuntu users as version 1.1.17 plus a bit of GIT is in reality 1.1.91 plus a bit of GIT. Now I can explain why it had so many bugs. I am using a developemt version instead of a stable branch.

Till Kamppeter (till-kamppeter) wrote :

Tim, as I have a rather instable release (1.1.91) in Ubuntu now, I have two possibilities: Go to 1.1.18, the last stable 1.1.x release or advance to 1.2.0 or HEAD to catch all your fixes on 1.1.91. What is the least intrusive solution? If 1.1.91 --> 1.2.0 (or HEAD) is mainly bug fixes I would prefer this. If this transition is very risky, one could perhaps ship 1.1.18. WDYT?

Tim Waugh (twaugh) wrote :

Eek!

I think that 1.1.18 has fewer bugs than 1.2.0, or even master, just because there are newer features that have had little public exposure so far.

1.2 has dropped support for PolicyKit pre-1.0, so if you are still shipping the old PolicyKit you'll need 1.1.x. In addition, 1.2 will not work correctly with cups-pk-helper < 0.0.4 when cancelling jobs.

However, since 1.1.91 there have been very few new features added, mainly bug fixes (and the check-device-ids script). It all depends on your attitude to risk. ;-)

Till Kamppeter (till-kamppeter) wrote :

Sorry for the last two comments, they were for bug 557199.

Nigel Babu (nigelbabu) wrote :

Please forward the patch upstream and link the bug report here. Thanks for your work on the patch.

tags: added: patch-needswork
removed: patch
Till Kamppeter (till-kamppeter) wrote :

Tim, did you already try out this patch?

Changed in system-config-printer:
importance: Undecided → Unknown
status: New → Unknown
Changed in system-config-printer:
status: Unknown → New
Changed in system-config-printer:
status: New → Fix Released
Nigel Babu (nigelbabu) on 2010-05-08
tags: added: patch-accepted-upstream
removed: patch-needswork
Vish (vish) wrote :

Patch has been accepted and fixed upstream.

Changed in system-config-printer (Ubuntu):
status: Confirmed → Fix Committed
Vish (vish) on 2010-06-11
Changed in hundredpapercuts:
milestone: none → maverick-round-8-potpourri
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.2.3+20100713-0ubuntu1

---------------
system-config-printer (1.2.3+20100713-0ubuntu1) maverick; urgency=low

  * New upstream release
     o GIT 1.2.x snapshot from 13 July 2010
     o Version 1.2.3 plus some additional fixes and translations
     o Plug'n'Print also for Bluetooth printers now.
     o Do not automatically set up a print queue if a driver executable is
       missing.
     o Improvements on device ID handling: Discovery via SNMP, non-UTF-8
       environments, ignore the deprecated hal backend.
     o Avoid Yes/No buttons (Upstream bug #204).
     o Re-introduced and added keyboard accelerators for system-config-printer
       itself and for the job viewer.
     o New HIG-compliant job viewer UI. Thanks to Sergey Nizovtsev for the
       patch (LP: #555213, upstream bug #205).
     o Attempt to translate backend device-info strings and other fixes
       on the translation mechanism (LP: #557199).
     o Fixed markup in error pop-ups (LP: #567324).
     o Made width of "Verify" button in New Printer Wizard adapt to the length
       of the actual translation of "Verify" (LP: #575048).
     o Make Kyocera detected if it reports only the model name (Upstreamized
       LP: #564633).
     o Removed doubled-up 'translatable' attribute in UI file (LP: #571662).
     o Handle IPP failure fetching printer attrs for completed jobs
       (LP: #561082).
     o Many more bug fixes and UI improvements.
     o Translation updates.
  * debian/patches/57_backend-integration-dnssd-bluetooth.patch,
    debian/patches/67_udev_configure_printer_match_usblp_libusb_and_hplip_uris.patch,
    debian/patches/75_use-dnssd-uris-for-hplip.patch,
    debian/patches/94_cache-and-timeout-for-avahi-browse.patch
    debian/patches/96_new-printer-setup-check-for-local-drivers-first.patch:
    Regenerated to work with new upstream code.
  * debian/patches/97_add-missing-make-name-kyocera-mita.patch: Removed
    patches for upstream fixes.
  * debian/patches/57_backend-integration-dnssd-bluetooth.patch: To check for
    HP fax devices do not do an exact match of "Fax" with the model name but
    check whether the model name begins with "Fax".
  * debian/patches/44_no-runtime-error-on-missing-firewall.patch: Let the
    firewall functions exit silently if there is no firewall service on the
    D-Bus.
  * debian/patches/50_give-priority-to-hpcups.patch: Prioritize hpcups against
    HPIJS again. It should have matured enough now.
  * debian/system-config-printer-common.install: Added new dnssdresolve.py
    file.
  * debian/rules: Added directory settings for UDEV rules and scripts to the
    "make install" command line.
  * debian/control: Added libglib2.0-dev as build dependency, needed for the
    Bluetooth Plug'n'Print support.
 -- Till Kamppeter <email address hidden> Tue, 13 Jul 2010 13:21:33 +0200

Changed in system-config-printer (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) wrote :

Fixed in Maverick

Changed in hundredpapercuts:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.