"Battery Discharging" is a horribly worded message

Bug #530751 reported by Michael Forrest on 2010-03-02
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
gnome-power
New
Wishlist
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

It makes me worry that my battery is leaking 'discharge' all over the inside of my computer.

When the battery is fully charged it should say "battery full" or "battery charged".

When the power is disconnected it should say "Running on battery"

Please stop telling me about all this discharge that's going everywhere.

Related branches

Changed in hundredpapercuts:
milestone: none → lucid-round-8
Matt Perry (mp) wrote :

If someone can point me to the relevant package, I should be able to create a patch before Thursday's UI freeze.

Sense Egbert Hofstede (sense) wrote :

This is an issue in GNOME Power Manager. I'm marking this bug as Triaged because it needs to further actions from Bug Control. The status is set to Low since this is a usability issue that might discombobulate users and therefore is more than a Wishlist.

Changed in gnome-power-manager (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Triaged
Chris Coulson (chrisccoulson) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream. Thanks in advance!

Changed in gnome-power-manager (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Triaged → Incomplete
Vish (vish) wrote :

The current wording is as per the notify-osd specs > https://wiki.ubuntu.com/NotifyOSD#gnome-power-manager

Assigning to mpt , to confirm if this needs to be altered. [again]

Changed in hundredpapercuts:
assignee: nobody → Matthew Paul Thomas (mpt)
status: Triaged → Incomplete
Vish (vish) wrote :

Also see , relevant bug , Bug #399492 where the current change was done for the last papercut cycle.

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Confirmed
Angel Abad (angelabad) on 2010-03-06
Changed in gnome-power:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Triaged
Alex Launi (alexlauni) wrote :

I felt like I should add that Discharge is an awesome band, and maybe there should be an option in gconf for people who love d-beat and want to be reminded every time they unplug their laptop..

Alex Launi (alexlauni) on 2010-03-08
Changed in hundredpapercuts:
status: Incomplete → In Progress
Matthew Paul Thomas (mpt) wrote :

I'm sorry I didn't see this before User Interface Freeze. I agree that "discharging" is an unpleasant way of putting it. The original proposal in bug 399492 didn't use that word; I don't know how it ended up like that.

I agree with Michael that "Running on battery" is better. I've changed it in the NotifyOSD spec. <https://wiki.ubuntu.com/NotifyOSD?action=diff&rev2=198&rev1=197> (But if Ubuntu no longer diverges from upstream gnome-power-manager in notifications, someone please tell me, and I'll remove that section altogether. In the long run the NotifyOSD specification should be about the notification system itself, not about the exact notifications every program should have.)

Chris Coulson (chrisccoulson) wrote :

I'll take this one, as I'll probably have another change to upload tomorrow anyway. Alex - would you mind please sending an e-mail to the ubuntu-translators mailing list to make them aware of the change, as the change will require translating in every language.

Thanks

Changed in gnome-power-manager (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Chris Coulson (chrisccoulson)
Chris Coulson (chrisccoulson) wrote :

I didn't see any mail to the ubuntu-translators list yet, and we're at the stage now where this needs an ACK from the release team anyway. Someone feel free to push that along to get this change in

Changed in gnome-power-manager (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody
Flávio Etrusco (etrusco) wrote :

In some notebooks with crappy BIOS - i.e. mine - this message actually can make sense - in an annoying way -, because the ACPI (?) reports the battery is discharging even for the "natural" discharge, while the notebook is plugged.

Vish (vish) on 2010-06-10
Changed in hundredpapercuts:
milestone: lucid-round-8 → maverick-round-7-notifications+gtk
Changed in gnome-power:
importance: Unknown → Wishlist
status: Unknown → New
Vish (vish) on 2010-11-23
Changed in hundredpapercuts:
milestone: maverick-round-7-notifications+gtk → nt3-ayatana
Changed in hundredpapercuts:
assignee: Matthew Paul Thomas (mpt) → nobody
Michael Terry (mterry) wrote :

The attached branch needs fixes. I'm unsubscribing ubuntu-sponsors until it is fixed. Please resubscribe when it is!

Changed in hundredpapercuts:
status: In Progress → Confirmed
Timothy Arceri (t-fridey) wrote :

I have not seen this message since before Oneiric. I no longer get any message when unplugging my netbook. Can anyone confirm if they still get this message?

Changed in hundredpapercuts:
status: Confirmed → Incomplete
Changed in gnome-power-manager (Ubuntu):
status: Triaged → Incomplete
Timothy Arceri (t-fridey) wrote :

Looks like this message is not meant to be displayed see bug: https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/355877

My guess is this has been fixed again.

Chris Wilson (notgary) wrote :

The "Battery Discharging" message is gone. Marking as fixed.

Changed in hundredpapercuts:
status: Incomplete → Fix Released
Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.