[upstream] When overwriting a file, save dialog doesn't specify filename

Bug #525670 reported by Roshan George on 2010-02-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Wishlist
One Hundred Papercuts
Low
Papercuts Ninjas
OpenOffice
Invalid
Undecided
Unassigned
libreoffice (Ubuntu)
Low
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

When overwriting a file from the Save dialog in OpenOffice.org the Save dialog is closed and then a popup appears with the text, "The file already exists. Overwrite?" (on slower computers there is a short pause between the two things happening). This popup does not contain the name of the file that you've chosen to overwrite and so I always have to be very careful when saving the file. What if I decide to overwrite a file and accidentally select the wrong one? I will face the same error message as if I chose to overwrite the right file and so I wouldn't even notice.

In other GNOME applications (e.g. gedit), the corresponding dialog box says, “A file named "filename.extension" already exists. Do you want to replace it?”. Also, this dialog box is displayed while the folder view in the Save dialog is displayed behind it. If I so wish, I can move the dialog box and look to see if I'm in the right folder. This plus the mention of the filename means I can save files over other files in gedit without having to worry about whether I've destroyed something else.

Vish (vish) wrote :

Confirming the issue on OOo 3.2

According to HIG > http://library.gnome.org/devel/hig-book/stable/windows-alert.html.en#save-confirmation-alerts
http://library.gnome.org/devel/hig-book/stable/windows-alert.html.en#alert-button-order

The common dialogue for this for other gnome apps for "save as" :

Primary text:
A file named "Document.txt" already exists. Do you want to replace it?

Secondary text:
The file already exists in "/home/username/Dcoduments". Replacing it will overwrite its contents.

Two buttons named "Cancel" and "Replace" [not no/yes]

The diagloue needs to be improved.

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Triaged
Vish (vish) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream. Thanks in advance!

Changed in openoffice.org (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Chris Cheney (ccheney) on 2010-05-18
summary: - When overwriting a file with the OpenOffice.org save dialog the message
- popped up doesn't specify the filename
+ [upstream] When overwriting a file with the OpenOffice.org save dialog
+ the message popped up doesn't specify the filename
Changed in openoffice.org (Ubuntu):
status: Confirmed → Triaged
Vish (vish) on 2010-06-11
Changed in hundredpapercuts:
milestone: none → maverick-round-2-mail+office
Changed in openoffice.org (Ubuntu):
assignee: nobody → John Phillips (john-johnsai)
Changed in openoffice.org (Ubuntu):
assignee: John Phillips (john-johnsai) → nobody
Changed in df-libreoffice:
status: Unknown → Confirmed

Since OpenOffice is going to be replaced with LibreOffice in 11.04, this no longer counts as a paper cut. Can someone please confirm whether or not this bug is still present in the latest version of LibreOffice?

Changed in hundredpapercuts:
milestone: maverick-round-2-office → none
status: Triaged → Incomplete
Vish (vish) wrote :

Just need to launch LibO and we notice the bug still exists.. ;-)

Changed in hundredpapercuts:
milestone: none → nt5-office
status: Incomplete → Triaged
Changed in libreoffice (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in df-libreoffice:
importance: Unknown → Wishlist
Changed in df-libreoffice:
status: Confirmed → In Progress
Vish (vish) on 2011-03-07
summary: - [upstream] When overwriting a file with the OpenOffice.org save dialog
- the message popped up doesn't specify the filename
+ [upstream] When overwriting a file, save dialog doesn't specify
+ filename
Changed in hundredpapercuts:
assignee: nobody → Papercuts Ninja (papercuts-ninja)
Timothy Arceri (t-fridey) wrote :

Fix is in LibreOffice 3.4 (ubuntu Oneric) marking as released

Changed in openoffice:
status: New → Invalid
Changed in openoffice.org (Ubuntu):
status: Triaged → Invalid
Changed in hundredpapercuts:
status: Triaged → Fix Released
Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
Changed in df-libreoffice:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.