Change "Show Desktop" keybinding to Super+D

Bug #515682 reported by David Siegel on 2010-02-01
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Metacity
Invalid
Wishlist
One Hundred Papercuts
Low
Unassigned
compiz (Ubuntu)
Low
Unassigned
metacity (Ubuntu)
Low
Unassigned

Bug Description

Current "Show Desktop" keybinding is Ctrl+Alt+D. Super+D is simpler, is more consistent with other Compiz window management shortcuts (Super+E for expo, Super+W for scale, Super+A for scale all workspaces), and is a familiar keybinding for Windows users (Windows uses Super+D for the same function).

Related branches

Changed in hundredpapercuts:
milestone: none → lucid-round-9
Changed in compiz:
status: New → Confirmed
status: Confirmed → New
Changed in hundredpapercuts:
status: New → Confirmed
assignee: nobody → Travis Watkins (amaranth)
Travis Watkins (amaranth) wrote :

We sync this setting from metacity so you either need to get it changed there or we need to deviate.

Vish (vish) wrote :

David Siegel, do we change it in metacity too?

Changed in hundredpapercuts:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in metacity (Ubuntu):
importance: Undecided → Low
status: New → Triaged
status: Triaged → Confirmed
Changed in compiz (Ubuntu):
importance: Undecided → Low
status: New → Triaged

Vish, yes it should also be changed in Metacity.

Travis Watkins (amaranth) wrote :

In that case there is nothing to change in compiz, it pulls this setting from metacity.

Changed in compiz (Ubuntu):
status: Triaged → Invalid
Changed in compiz:
status: New → Invalid
Sense Egbert Hofstede (sense) wrote :

Reported upstream, subsequently marking the Ubuntu task for Metacity as Triaged.

Changed in metacity (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
assignee: Travis Watkins (amaranth) → nobody

I'm worried a bit because I don't own a keyboard with a Super key. And I'm not going to throw it away; it's an IBM Model M, I had to kill people for it. ;)

I do agree that it makes sense to have coherent key binding throughout the whole desktop, but for me it would be a regression. Would it be possible map Ctrl+Alt to Super and retain the possibility to use said key binding even if there is no Super key present?

Raphael, yes, you can remap things like this on your personal computer to
your heart's content.

Vish (vish) on 2010-03-05
tags: added: patch
Koen Verweij (kfverweij) wrote :

I guess nothing happened on upstream for this. This seems to happen a lot. A bug is discussed and then directed to upstream. Subsequently nothing happens, because GNOME bugs seem to get a lot less attention... Sorry, I know complaining doesn't really help much but I just had to say it.

Nigel Babu (nigelbabu) wrote :

Thanks andrew for the patch. Could you forward it upstream too?

tags: added: patch-needswork
removed: patch
Vish (vish) on 2010-06-10
Changed in hundredpapercuts:
milestone: lucid-round-9 → maverick-round-8-potpourri

Three months to review a one line patch that was even spec'd at UDS-L. Oh well...

@ Nigel:

You tagged this patch-needswork. Could you please elaborate on what needs work? The currently proposed branch doesn't touch upstream code at all. It patches debian/metacity-common.gconf-defaults. I suppose I could re-write it to patch metacity itself, but upstream hasn't expressed any interest. Things like setting different default keybindings seems completely acceptable to do at the distro level. That's why we even have tools like dh_gconf that make it dead simple to change a default gconf setting in the packaging without patching the upstream source.

Nigel Babu (nigelbabu) wrote :

Andrew: Sorry about that. I made a mistake in the tagging. If this was spec'd at UDS, could you also link the spec so I can get someone to sponsor this soonish

tags: added: patch-forwarded-upstream
removed: patch-needswork
Benjamin Drung (bdrung) wrote :

This bug demonstrate clearly the lack of manpower of main sponsors.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:2.30.1-2ubuntu3

---------------
metacity (1:2.30.1-2ubuntu3) maverick; urgency=low

  * Set show desktop key binding to <Super>+D. (LP: #515682)
 -- Andrew Starr-Bochicchio <email address hidden> Sat, 21 Aug 2010 23:34:31 +0200

Changed in metacity (Ubuntu):
status: Triaged → Fix Released
Vish (vish) wrote :

Lack of main sponsors and that not everyone knows the every changing patch Sponsoring process :(

Changed in hundredpapercuts:
status: Triaged → Fix Released
Changed in metacity:
importance: Unknown → Wishlist
status: Unknown → New
Changed in metacity:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.