Icon of arrow in date column in Nautilus / Gnome windows

Reported by Xavier Guillot on 2010-01-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Low
One Hundred Papercuts
Low
Unassigned
gtk+2.0 (Ubuntu)
Low
Unassigned

Bug Description

Hello,

Thanks for your work on Ubuntu to make it more nice to use.

I have a little remark, nothing really wrong, but a wish that would make life easier and could be added to Paper Cuts if you agree.

In Nautilus (Gnome) : the arrow we see in the "modification date" column if we order the files regarding their last modified date, with the most recent files on the top, this arrow is pointing up (which is logical):

http://pix.toile-libre.org/upload/original/1263475829.png

But, in any Gnome program (Totem, OpenOffice...) when we want to open / save a document for example, on the window which opens, if we want to order the files the same way, the most recent at the top, the arrow appearing here just near the text "Modified" is pointing... down !

http://pix.toile-libre.org/upload/original/1263476031.png

So this is not a major thing, but it can be confusing, sometimes reflexively I click on the "Modified" column and put arrow pointing up, but I see that files are not ordered with the newest at top as I wanted...

Thus it would be great if that arrow view could be uniform, I think there might be just a little thing to fix.

Thanks in advance. Best regards,

Xavier

Xavier Guillot (valeryan-24) wrote :
Vish (vish) wrote :

I can confirm the behavior is different in nautilus and gtk+ , but who is to change the behavior?

gtk+ behavior is consistent with windows7.

While nautilus behavior is consistent with rhythmbox , gconf and other gnome apps.

maybe we should make gtk+ consistent with gnome?

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed
Vish (vish) wrote :

This happens not only for the modified column but any sort in gtk+ has the arrows pointing opposite to gnome apps.

Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed

Hello,

Thanks for the answer.

IMHO, as a user, I agree with your proposal to make gtk+ consistent
with Gnome: Nautilus behavior is also the same as Thundebird one, for
example - most recent files on the top = arrow pointing up.

On 20/01/2010 10:43, Vish wrote:
> I can confirm the behavior is different in nautilus and gtk+ , but who
> is to change the behavior?
>
> gtk+ behavior is consistent with windows7.
>
> While nautilus behavior is consistent with rhythmbox , gconf and other
> gnome apps.
>
> maybe we should make gtk+ consistent with gnome?
>
> ** Changed in: hundredpapercuts
> Importance: Undecided => Low
>
> ** Changed in: hundredpapercuts
> Status: New => Confirmed
>

Vish (vish) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=608537

Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Vish (vish) on 2010-01-31
Changed in hundredpapercuts:
status: Confirmed → Triaged
Xavier Guillot (valeryan-24) wrote :

Hello,

Bug is still present in Ubuntu Lucid and remains unconfirmed in Gnome bugzilla since January.

Is it planned to fix it on papercuts for Maverick ?

Thanks in advance. Best regards,

Xavier

Changed in gtk:
status: Unknown → Fix Released
Vish (vish) wrote :

This has now been fixed upstream and will be available in Maverick.

Changed in gtk+2.0 (Ubuntu):
status: Triaged → Fix Committed
Changed in hundredpapercuts:
status: Triaged → Fix Committed
Vish (vish) on 2010-06-10
Changed in hundredpapercuts:
milestone: none → maverick-round-7-notifications+gtk
Sebastien Bacher (seb128) wrote :

the issue has been fixed in gtk 2.21.2 in maverick now

Changed in gtk+2.0 (Ubuntu):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in gtk:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.