"Change desktop background" dialog shows up when using "Set as desktop wallpaper" option in image viewer

Bug #503061 reported by florin on 2010-01-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Fix Released
Low
One Hundred Papercuts
Low
Unassigned
eog (Ubuntu)
Low
Unassigned

Bug Description

Distribution: Ubuntu 9.10 Karmic Koala

Input: Double click picture in Nautilus (opens the picture viewer - Eye of Gnome 2.28.1), right click on the picture and select "Set as desktop background"

Expected: Image set as desktop wallpaper

Deviation: Image is set as wallpaper, but the "Appearance preferences" dialog gets activated ("Background" tab)

Papercut: If someone wants to try several pictures as background, the system opens up multiple instances of "Appearance preferences" dialog

Related branches

Omer Akram (om26er) wrote :

yes i accept this is really annoying

Omer Akram (om26er) on 2010-01-05
Changed in hundredpapercuts:
status: New → Confirmed
Omer Akram (om26er) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=606935

Changed in eog:
importance: Undecided → Unknown
status: New → Unknown
Changed in hundredpapercuts:
importance: Undecided → Low
status: Confirmed → Triaged
Vish (vish) wrote :

I doubt that this is a trivially fixable bug. Any ideas ?

Changed in hundredpapercuts:
status: Triaged → Incomplete
description: updated
Andreas Moog (ampelbein) wrote :

For reference, eog opens the preferences window, in eog-window.c, around line 2827:

eog_window_set_wallpaper (EogWindow *window, const gchar *filename)
{
        EogWindowPrivate *priv = EOG_WINDOW_GET_PRIVATE (window);
        GdkScreen *screen;

        gconf_client_set_string (priv->client,
                                 EOG_CONF_DESKTOP_WALLPAPER,
                                 filename,
                                 NULL);

        screen = gtk_widget_get_screen (GTK_WIDGET (window));
        gdk_spawn_command_line_on_screen (screen,
                                          "gnome-appearance-properties"
                                          " --show-page=background",
                                          NULL);
}

Vish (vish) wrote :

Thanks Andreas.

Changed in hundredpapercuts:
milestone: none → lucid-round-10
status: Incomplete → Triaged

I tried removing the function call "gtk_widget_get_screen" and compiling the eog. It works as per the needs.
I have reviewed it and the patch is minor. Find the patch attached.

I am going to fix this patch. Will try to get this bug merged in the dev branch tomorrow. Need help from IRC

Changed in hundredpapercuts:
assignee: nobody → Manish Sinha (manishsinha)

I am going to work on this. Will try to get this bug merged in the dev branch tomorrow. Need help from IRC

Vish (vish) wrote :

I believe, the reason EOG devs have implemented the current behavior is , in case the user does not like the wallpaper and wants to revert the wallpaper back to the old one.

So , instead of removing the behavior , we could move the function to the ribbon EOG uses.
The ribbon can mention
" 'Fav_pic.png' has been set as Desktop wallpaper " [Revert] [OK]
 and the 'Revert' now opens the appearance prefs dialogue window.

Vish,
Check the code snippet. The wallpaper gets set and then gnome-appearance opens and not the other way round.
I am curious how [Revert] can be implemented. I haven't seen any such feature in gnome-appearance. If anyone just wants to revert back he has to memorise it. This invalided the need to open gnome-appearance.

Vish (vish) wrote :

@Manish Sinha:
Yes , wallpaper is set and only then the gnome-appearance window is brought up. We block that and move the function to the button

The revert button , brings up the gnome-appearance window and allows the user to select the wallpaper.
We dont actually have to revert it to the old wallpaper.
We could label the button 'Change' too.

Vish (vish) wrote :

Unassigning as , Fix has been committed upstream.

Changed in hundredpapercuts:
assignee: Manish Sinha (manishsinha) → nobody
status: Triaged → Fix Committed
Changed in eog (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eog - 2.29.90-0ubuntu1

---------------
eog (2.29.90-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - Further GSEAL-compatibility improvements
    - Allow switching to a random image from the collection
    - Build fixes
    - Ask user if he actually needs the Appearance capplet after setting a new
      desktop wallpaper through Eye of GNOME (lp: #503061)
    Bug fixes:
    - #606935, "Change desktop background" dialog shows up when using
      "Set as desktop wallpaper" option in image viewer
    - #609184, Build failure: doesn't look for some required libs
    New and updated translations
 -- Sebastien Bacher <email address hidden> Tue, 09 Feb 2010 23:57:36 +0100

Changed in eog (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) on 2010-02-10
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in eog:
importance: Unknown → Low
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.