Contact List is sometimes not shown when Empathy is launched

Bug #503052 reported by David Siegel on 2010-01-04
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Empathy
Expired
Medium
Messaging Menu
Invalid
Undecided
Ted Gould
One Hundred Papercuts
Undecided
Unassigned
empathy (Ubuntu)
Wishlist
Ken VanDine

Bug Description

When I launch Empathy, the contact list window is sometimes (always?) minimized to the Messaging Menu. When this happens, it is not obvious that Empathy was launched successfully -- did it crash? Am I online? I launched Empathy to call contact X, where is the contact list?

When Empathy is launched, the contact list window should be displayed.

To reproduce the behavior:
  1. Launch Empathy
  2. Close the Contact List
  3. Log out, then log back in as the same user (or restart)
  4. Launch Empathy and observe that the contact list is not shown

Changed in hundredpapercuts:
milestone: none → lucid-round-4
status: New → Confirmed
Changed in indicator-messages:
assignee: nobody → Ted Gould (ted)
description: updated
Guillaume Desmottes (cassidy) wrote :

I'm not sure about this. Lot of users always keep the contact list closed and like to have the contact list hidden when starting.
Empathy remembers the last state of the contact list, so if it was hidden when you close it, it will be hidden when restarting.

The status is displayed in the status icon and the indicator-applet.

Changed in empathy:
importance: Undecided → Unknown
status: New → Unknown
summary: - Buddy List is not shown on launch when messaging menu is present
+ Contact List is sometimes not shown when Empathy is launched
description: updated

Can there be an option that is added to Preferences to either disable/enable the 'last state of contact list' when first starting up? Default is keep current functionality, but allow users to choose if they want this kind of thing to happen. I would like to always have it pop up when I startup my login session, because I have a tendency to forget when I first get started in the morning (and it always looks like I'm late for work to my co-workers... maybe too much info huh?). Thanks.

Martin (martin615) wrote :

Judging by Guillaume's comment I'd say that Empathy already does the right thing.

Martin (martin615) wrote :

Ah, but I hadn't read this comment "When Empathy is launched [from a launcher], the contact list window should be
displayed." in the upstream bug. Always showing it when launched from the launcher but not when autostarting on login might be the right way to go.

Matthew Paul Thomas (mpt) wrote :

Déjà vu! Empathy used to have this problem, but it was fixed in 2008. <https://wiki.ubuntu.com/EmpathyVsPidginUsability#Empathy>

Changed in empathy (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Wishlist
Changed in empathy (Ubuntu):
status: New → Fix Committed
Changed in hundredpapercuts:
status: Confirmed → Fix Committed

what a waste...
this was a bug not a papercut

well, we'll work on bugfixing/development philosophy with time

On Wed, Jan 13, 2010 at 21:02, David Siegel <email address hidden>wrote:

> ** Changed in: hundredpapercuts
> Status: Confirmed => Fix Committed
>
> --
> Contact List is sometimes not shown when Empathy is launched
> https://bugs.launchpad.net/bugs/503052
> You received this bug notification because you are subscribed to The
> Ayatana Project.
>
> Status in Chat app, and Telepathy user interface: Unknown
> Status in One Hundred Paper Cuts: Fix Committed
> Status in The Messaging Menu: New
> Status in “empathy” package in Ubuntu: Fix Committed
>
> Bug description:
> When I launch Empathy, the contact list window is sometimes (always?)
> minimized to the Messaging Menu. When this happens, it is not obvious that
> Empathy was launched successfully -- did it crash? Am I online? I launched
> Empathy to call contact X, where is the contact list?
>
> When Empathy is launched, the contact list window should be displayed.
>
> To reproduce the behavior:
> 1. Launch Empathy
> 2. Close the Contact List
> 3. Log out, then log back in as the same user (or restart)
> 4. Launch Empathy and observe that the contact list is not shown
>
>
>
>

Excuse me?

frizzle21 (frederik-nnaji) wrote :

in my lucid it was a clear bug..
papercuts in my understanding are useability issues that will, once handled,
improve the user's interface experience..
am i wrong here?

On Wed, Jan 13, 2010 at 22:11, David Siegel <email address hidden>wrote:

> Excuse me?
>
> --
> Contact List is sometimes not shown when Empathy is launched
> https://bugs.launchpad.net/bugs/503052
> You received this bug notification because you are subscribed to The
> Ayatana Project.
>
> Status in Chat app, and Telepathy user interface: Unknown
> Status in One Hundred Paper Cuts: Fix Committed
> Status in The Messaging Menu: New
> Status in “empathy” package in Ubuntu: Fix Committed
>
> Bug description:
> When I launch Empathy, the contact list window is sometimes (always?)
> minimized to the Messaging Menu. When this happens, it is not obvious that
> Empathy was launched successfully -- did it crash? Am I online? I launched
> Empathy to call contact X, where is the contact list?
>
> When Empathy is launched, the contact list window should be displayed.
>
> To reproduce the behavior:
> 1. Launch Empathy
> 2. Close the Contact List
> 3. Log out, then log back in as the same user (or restart)
> 4. Launch Empathy and observe that the contact list is not shown
>
>
>
>

Ken VanDine (ken-vandine) wrote :

It wasn't actually a bug, it worked as designed. A papercut is usability nitpicks, simple things we can do to improve the user experience. Which could include fixing an actual bug, if it wasn't working as designed or make minor changes to how it was designed to work.

In this case empathy was designed to always honor it's previous state when launched, regardless of the current conditions. I would argue that when launching in the users session it should stay out of the way and be more of a "service" that is running when you need it.

Yes, it wasn't a software bug; the software was working as intended. It was a design bug: the people who designed the software to work this way overlooked the corner case where a user opens Empathy via a Launcher and expects to see their contact list.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 2.29.5.1-1ubuntu1

---------------
empathy (2.29.5.1-1ubuntu1) lucid; urgency=low

  * New upstream release
  * debian/patches/31_really_raise_window.patch
    - really raise the answer/reject dialog for incoming calls
  * debian/patches/34_start_raised_execpt_in_session.patch
    - If not started with the session, we should always raise (LP: #503052)
 -- Ken VanDine <email address hidden> Tue, 12 Jan 2010 11:46:51 -0500

Changed in empathy (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) on 2010-01-15
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

Ken, is there any reason you didn't send that change to the upstream bug for review there?

Ken VanDine (ken-vandine) wrote :

Seb, we did discuss it with upstream first and agreed they probably wouldn't accept the patch. Our design team feels this is the user experience we want in Ubuntu, which differs from upstream's opinion. We want see what kind of feedback we get.

Ted Gould (ted) on 2010-05-21
Changed in indicator-messages:
status: New → Invalid
Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
Changed in empathy:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.