Ensure that Viewport switcher appearance matches the look and feel of the default theme(s)

Bug #495687 reported by David Siegel on 2009-12-11
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
compiz-fusion-plugins-main (Ubuntu)
Wishlist
Travis Watkins

Bug Description

This bug makes some recommendations for changing the viewport switcher speed and appearance (see design document linked below).

### Design spec: http://wiki.ubuntu.com/OneHundredPaperCuts/Spec/495687

description: updated
Changed in hundredpapercuts:
milestone: none → lucid-round-9
status: New → Confirmed
assignee: nobody → David Siegel (djsiegel)
Changed in compiz (Ubuntu):
assignee: nobody → Travis Watkins (amaranth)
affects: compiz (Ubuntu) → compiz-fusion-plugins-main (Ubuntu)
Changed in compiz-fusion-plugins-main (Ubuntu):
importance: Undecided → Wishlist
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-fusion-plugins-main - 0.8.4-0ubuntu3

---------------
compiz-fusion-plugins-main (0.8.4-0ubuntu3) lucid; urgency=low

  * debian/patches/03_default_options.patch:
    - updated to include
      https://wiki.ubuntu.com/OneHundredPaperCuts/Spec/495641 (LP: #495641)
    - https://wiki.ubuntu.com/OneHundredPaperCuts/Spec/495687 (LP: #495687)
    - fix resistance_distance (LP: #495708)
    - https://wiki.ubuntu.com/OneHundredPaperCuts/Spec/495712 (LP: #495712)
    - https://wiki.ubuntu.com/OneHundredPaperCuts/Spec/478016 (LP: #478016)
    - https://wiki.ubuntu.com/OneHundredPaperCuts/Spec/495634 (LP: #495634)
 -- Michael Vogt <email address hidden> Wed, 03 Feb 2010 16:41:02 -0800

Changed in compiz-fusion-plugins-main (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) on 2010-02-04
Changed in hundredpapercuts:
status: Confirmed → Fix Released
Pavel Rojtberg (rojtberg) wrote :

As I was using that functionality a lot I do not agree with:
"Edge flipping on move is disabled because (1) it can be triggered accidentally and confuse users, (2) it is a bit awkward to use, and (3) it's not symmetrical (it's disabled on the top edge because it is too easy to perform accidentally there)"

(1) not really relevant without any numbers
(2) personal opinion? again: tests/ numbers.
(3) point, but in the default configuration ubuntu orders all desktops horizontally ;)

so please take a closer look at this particular change

Pavel, (1) is consistent with the change to disable scrolling on the desktop to switch workspaces. You're right that we don't have hard data showing that this behavior is confusing, but we should err on the side of simplicity in this case. I have seen users unfamiliar with workspace switching trigger a workspace move accidentally and it is extremely disruptive to them -- it's much less disruptive for you to enable this feature once than for inexperienced users to trigger it accidentally and have /no clue/ where their windows went. Advanced users can easily enable extra workspace switching triggers, but users who are confused by the behavior have little recourse.

(2) and (3) are not strong reasons to disable edge-flipping, you're right. I think (1) is a sufficient reason, though.

Pavel Rojtberg (rojtberg) wrote :

well as long as you have actually seen some users which got confused by it, the change is fine for me. But it still took me like 5min digging in gconf-editor to find the correct checkbox. So you could maybe include a notice in the release notes on how to revert the change...

Travis Watkins (amaranth) wrote :

If we included a line for every small change like this in the release notes they'd be so long no one would read them. There are a lot of small changes every release. The hope is the changes make things better so people don't mind.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers