OpenOffice menus still have icons which should be removed

Bug #491451 reported by Rich Jones
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Fix Released
Low
Unassigned
openoffice.org (Ubuntu)
Fix Released
Wishlist
Unassigned

Bug Description

All the GNOME apps look way better this release because the menus have the icons removed - OpenOffice did not receive this facelift, and now it looks extremely cluttered. The debate is settled - icons in menus are bad news. OO.o needs to get with the times!

A very simple fix, as well.

Tags: patch
Revision history for this message
Micah Gersten (micahg) wrote :

Wishlisting as this is an enhancement.

Changed in openoffice.org (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Chris Cheney (ccheney) wrote :

Well OOo is not a Gnome app but it appears this can be done. This currently can be done via Tools->Options->OpenOffice.org->View->"Show icons in menus", so it probably would be possible to disable this by default somehow.

Changed in openoffice.org (Ubuntu):
milestone: none → ubuntu-10.04
status: New → Triaged
Revision history for this message
Rich Jones (richwjones) wrote :

Perfect solution - who will apply this?

Revision history for this message
Rich Jones (richwjones) wrote :

Nobody gonna step up and fix this?

Revision history for this message
Rich Jones (richwjones) wrote :

Alllllloooo

Revision history for this message
Vish (vish) wrote :

Rich Jones , patience... ;-)
The bug has already been scheduled for Ubuntu 10.04. So , no need to bump bug reports.

You can help speedy the bug resolution by providing patch , Or if you aernt a hacker you can try to get the attention of people who can... :-)
We are running _really_ low on people who actually fix the papercut bugs. Thanks!

Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → lucid-round-10
status: New → Triaged
Revision history for this message
Oli (oli) wrote :

Please only apply this if it respects the gconf entry. Lots of people turned icons back on (because context icons make a lot of sense to us!) so it's going to be very annoying if some applications (like OO) start having no icons while all the other apps do.

Revision history for this message
Rich Jones (richwjones) wrote :

Oli - can you test to see if it does?

Revision history for this message
Luke Symes (allsymes) wrote :

I found the relevant source file here: http://svn.services.openoffice.org/ooo/tags/OpenOffice_3_2_0/shell/source/backends/gconfbe/gconfbackend.cxx
Although I'm not sure if this is the latest version for Ubuntu, openoffice source too big for me to download right now, but I have made a patch based on the above file.

Could someone maybe test it out with Lucid's OpenOffice source?

tags: added: patch
Revision history for this message
Chris Cheney (ccheney) wrote :

This appears to be fixed already in Lucid as we have 3.2.0 and I don't see the icons anymore by default (eg with a clean .openoffice.org directory).

Changed in openoffice.org (Ubuntu):
status: Triaged → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
Revision history for this message
Luke Symes (allsymes) wrote :

@Chris Cheney: As per Comment #7, could you please check whether OpenOffice is respecting the gconf desktop/gnome/interface/menus_have_icons setting? If not, I will look into this further to solve that related issue.

Revision history for this message
Luke Symes (allsymes) wrote :

Ok, I checked it myself. All works as it should when changing the gconf key desktop/gnome/interface/menus_have_icons

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers