Fix sort order in Group Settings.

Bug #477324 reported by Craig Hewetson on 2009-11-07
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GST
Fix Released
Medium
One Hundred Papercuts
Low
Unassigned
gnome-system-tools (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

System->Adminstration->Users and Groups->Manage Groups

Notice the list is not sorted alphabetically. Since the only thing shown in the table is the name of the group I believe it should be sorted alphabetically. Case insensitive.

Chris Johnston (cjohnston) wrote :

I can confirm that this is how it is displayed, I'm not sure however if this is something that would want to be changed.. It's in the same order as what is in the /etc/group file.

Changed in ubuntu:
status: New → Confirmed
Chris Johnston (cjohnston) wrote :

I am running 9.10 64bit.

affects: ubuntu → gnome-system-tools (Ubuntu)
Chris Johnston (cjohnston) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=603246

Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low

>>I'm not sure however if this is something that would want to be changed.. It's in the same order as what is in the /etc/group file.

I can't see how the user will benefit from having the groups displayed in the order it was created in. Looking for a group becomes a pain if its not alphabetically sorted.

Also the user can't be bothered how the developer chose to store and in what order he chose to store the groups, as long as the user can view them in a sensible/useful manner.

BTW: thanks for logging the upstream bug, I'll track the bug.

Changed in gnome-system-tools (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Milan Bouchet-Valat (nalimilan) wrote :

OK, in users-admin 2.29.90 groups will be sorted by login alphabetical order, and search-as-you-type will match on login too. So this will be fixed in Lucid.

Changed in hundredpapercuts:
status: New → Fix Released
Omer Akram (om26er) on 2010-01-30
Changed in hundredpapercuts:
status: Fix Released → Fix Committed
Changed in gnome-system-tools (Ubuntu):
status: Triaged → Fix Committed
Vish (vish) on 2010-01-31
Changed in hundredpapercuts:
importance: Undecided → Low
Milan Bouchet-Valat (nalimilan) wrote :

Fix released upstream with the gnome-system-tools 2.29.90. (Even if the upstream task is not updated correctly.)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.29.90-0ubuntu1

---------------
gnome-system-tools (2.29.90-0ubuntu1) lucid; urgency=low

  * New upstream version
  * Users
    - Fix hangs when changing own password with some PAM setups
    - Update password field to indicate whether password is empty and/or
      asked on login
    - Support disabled accounts, waiting for the backends to report this
    - Sort users and groups list, implement search (LP: #477324)
    - Don't resize window with long user names (LP: #514298)
    - Improve buttons string to be "Change..."
    - Fix "Reload Changes?" dialog shown after creating an user
    - Fix a few leaks of OobsUsers and OobsGroups
  * Services
    - Only commit changes to one service at a time, to avoid many harmful
      issues
    - Remove unlock button, ask for authentication on-the-fly
    - Improve appearance of services list, use some additional icons and
      known services
  * Shares
    - Don't create an OobsIfacesConfig object since it's not used and
      consumes memory
  * Fixes LP: #200105
  * Refreshed patches:
    - 81_gst-packages-shares-admin.patch
    - 90_relibtoolize.patch
  * debian/control:
    - Bump liboobs-dev build-depend to 2.29.90
    - Update Standards-Version to 3.8.4. No other changes required
 -- Chris Coulson <email address hidden> Sun, 14 Feb 2010 18:03:45 +0000

Changed in gnome-system-tools (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) on 2010-02-15
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in gst:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.