Change the name of "Hardware drivers"

Bug #409338 reported by Mel C on 2009-08-05
62
This bug affects 6 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Wishlist
Robert Roth
Ubuntu Documentation
Undecided
Unassigned
jockey (Ubuntu)
Low
Martin Pitt

Bug Description

System>Admin>Hardware drivers, the name is confusing me...Hardware drivers means should show all the devices like printer,webcam,etc .But Hardware driver is using for non-free drivers and not for free drivers, so plz change the name or change the software

Related branches

1./ Proprietary drivers
2./ Non-free drivers
3./ Aditional drivers
4./ Downloaded drivers

Rich Jones (richwjones) wrote :

I agree with this, it isn't just all the hardware drivers, but the non-free ones. But if you just say Non-free drivers, what are they driving?

I suggest Proprietary Hardware Drivers.

Agreed, and an easy fix as well.

My vote is for "Proprietary drivers"

Mel C (melc) wrote :

Proprietary drivers

Mel C (melc) on 2009-08-09
tags: added: drivers hardware
Vish (vish) on 2009-08-11
Changed in hundredpapercuts:
status: New → Confirmed
Melvin Garcia (virtualspectre8) wrote :

Proprietary Drivers, it sounds well.

Propietary drivers sounds OK to me

Rich Jones (richwjones) wrote :

Bump

Vish (vish) on 2009-11-28
Changed in hundredpapercuts:
status: Confirmed → Triaged
Robert Roth (evfool) on 2010-06-27
Changed in hundredpapercuts:
assignee: nobody → Robert Roth (evfool)
Robert Roth (evfool) wrote :

I've made a patch with all the 'Hardware Drivers' strings replaced with 'Proprietary Drivers' for the latest revision found in the lp:jockey branch, revision 629, but I'm unable to build it. Installed python-distutils-extra, but the ./setup.py build command fails, ./setup.py --help fails too, starting with the messages:

the following files are not recognized by DistUtilsExtra.auto
  backend/com.ubuntu.devicedriver.policy.in
  do-release
  examples/fake.modaliases
  examples/handlers/fglrx.py
  examples/handlers/madwifi.py
  examples/handlers/nonfree.py
  examples/handlers/nvidia.py
  examples/handlers/pkg.py
  examples/handlers/sl_modem.py
  examples/mini-cli.py
  examples/modalias-override-generators/fglrx_supported
  examples/modalias-override-generators/nvidia_supported
  gtk/autostart/jockey-gtk.desktop.in
  gtk/jockey-gtk.desktop.in
  kde/LicenseDialog.ui
  kde/ManagerWindowKDE4.ui
  kde/ProgressDialog.ui
  kde/autostart/jockey-kde.desktop.in
  kde/jockey-kde.desktop.in
  kde/jockey.notifyrc.in

Could you please help me with some instructions, 'cause I've never used python build tools, and to test the new strings, I'd really need it. Or should I just attach the patch and would anybody be kind to build it and test it? Thanks in advance for your help.

Vish (vish) wrote :

@Robert Roth : since jockey is hosted on launchpad , you can just propose a merge

Robert Roth (evfool) wrote :

@Vish : My question is that is replacing every occurence of Hardware drivers with Proprietary Drivers enough to fix this bug? I just wanted to test it, because I don't like committing or proposing for merge solutions that do not work :) If it is, than I'll propose for merge.

Mel C (melc) wrote :

make an interface like open solaris device drivers utility.
more info visit http://hub.opensolaris.org/bin/view/Project+driver-utility/

Note:
this not a papercut solution.i know what is "papercut"

Vish (vish) wrote :

@Robert Roth: Yes , renaming the occurrences is sufficient.

Martin Pitt (pitti) wrote :

Jockey is not just for proprietary drivers. For example, it is also used for searching printer drivers on openprinting.org, and we also had cases where we considered using jockey to install linux-backports-modules. So I veto against renaming it to "proprietary drivers", the name was deliberately chosen that way.

Vish (vish) wrote :

Martin Pitt wrote:
> Jockey is not just for proprietary drivers.

Oddly every mention of the drivers ,available via this utility, in Help documentation refers only about proprietary drivers and how they cannot be supported by Ubuntu developers. Even the topic is "Proprietary Drivers".

Maybe the documentation needs to be updated?

> For example, it is also used
> for searching printer drivers on openprinting.org, and we also had cases
> where we considered using jockey to install linux-backports-modules.

Even the mention of "No proprietary drivers... ", in bold , seems misleading as to its only function. [screenshot attached]
There is no mention of searching in the docs either. Is this a future plan or it searches already?

Vish [2010-07-01 4:24 -0000]:
> Maybe the documentation needs to be updated?

Sounds appropriate.

> Even the mention of "No proprietary drivers... ", in bold , seems
> misleading as to its only function.

That's the current status message. If you think a different wording
would be better, I'm all ears. :-)

> There is no mention of searching in the docs either. Is this a
> future plan or it searches already?

What do you mean with "searching"? If it's about the printer drivers,
system-config-printer has done this since hardy or so.

Thank you,

Martin

Robert Roth (evfool) wrote :

"Hardware drivers" is still inappropiate in my opinion, so we should find a better wording for that too.
In the first comment there are four suggestions:
1./ Proprietary drivers ----- jockey's not only about proprietary drivers, understood
2./ Non-free drivers ----- open printing drivers are free, so not ok
3./ Aditional drivers ----- this might be ok, but one might ask "additional to what?"
4./ Downloaded drivers ----- is this OK? are all the drivers installed by jockey downloaded?
Please comment.

Robert Roth (evfool) wrote :

Added the ubuntu-docs project as affected.

Martin Pitt (pitti) wrote :

Robert Roth [2010-07-01 8:44 -0000]:
> 4./ Downloaded drivers ----- is this OK? are all the drivers installed by jockey downloaded?

Usually yes. There might be cases where you would get them from a
Windows install CD (b43-fwcutter), but those are marginal.

Martin

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Robert Roth (evfool) wrote :

Ok, then I'll change it to "Downloaded drivers" in jockey. The ubuntu-docs update is a bit more complex, because just replacing the strings won't do it. It also needs rephrasing according to the discussion.

Another question @ Martin:

>If it's about the printer drivers,
>system-config-printer has done this since hardy or so.

Does this mean that printer drivers are not displayed in the Hardware Drivers window? Because I have installed a printer driver for my Canon Pixma MP640, and it's not there.

Robert Roth (evfool) wrote :

I have been thinking about it a bit before changing the strings, and Downloaded Drivers is not a good wording neither. First time when the application is started, no drivers are downloaded, just displayed as activatable, and when activating one of them, a dialog appears with "Downloading drivers", so having a window entitled Downloaded drivers, and after that, downloading a driver is not good.
Any other suggestions? Maybe we should go with the Additional Drivers wording?

Phil Bull (philbull) wrote :

Regarding the outdated docs: I'll push this as a task for the Docs team. I think the plan might be to move the documentation into the jockey package itself (IIRC, it's kept in ubuntu-docs at the moment).

Have you had any user input on the name? Rather than going for what is the most logical name, it would be better for users if you gave it the name that they expect for this sort of utility (the two don't always coincide!).

Martin Pitt (pitti) wrote :

Phil Bull [2010-07-01 11:12 -0000]:
> Regarding the outdated docs: I'll push this as a task for the Docs team.
> I think the plan might be to move the documentation into the jockey
> package itself (IIRC, it's kept in ubuntu-docs at the moment).

I agree that this would make more sense indeed.

> Have you had any user input on the name?

Not me personally.

> Rather than going for what is the most logical name, it would be
> better for users if you gave it the name that they expect for this
> sort of utility (the two don't always coincide!).

Well, in the end they expect their hardware to "just work" without
having to use such a tool at all :-)

Beyond that I can't give any input on usability testing, I'm afraid.

Martin Pitt (pitti) wrote :

Robert Roth [2010-07-01 10:12 -0000]:
> Does this mean that printer drivers are not displayed in the Hardware
> Drivers window? Because I have installed a printer driver for my Canon
> Pixma MP640, and it's not there.

The ones from openprinting.org aren't displayed if you open Jockey
directly, since there is no real handler for them. It will only appear
if system-config-printer calls Jockey with a particular printer
model, and jockey can query openprinting.org for that.

Robert Roth (evfool) wrote :

>The ones from openprinting.org aren't displayed if you open Jockey
>directly, since there is no real handler for them. It will only appear
>if system-config-printer calls Jockey with a particular printer
>model, and jockey can query openprinting.org for that.

This means that printer drivers are not displayed on the jockey window, but sometimes the jockey backend supports the system-config-printer by downloading open printing drivers. That would mean, that the title of the window could be Restricted drivers, because only those are displayed in the window, only we have to be careful to have the package description and general places describing jockey sticking with the old Hardware drivers string. Does this sound OK?

Martin Pitt (pitti) wrote :

Robert Roth [2010-07-02 7:38 -0000]:
> This means that printer drivers are not displayed on the jockey window,
> but sometimes the jockey backend supports the system-config-printer by
> downloading open printing drivers. That would mean, that the title of
> the window could be Restricted drivers, because only those are displayed
> in the window, only we have to be careful to have the package
> description and general places describing jockey sticking with the old
> Hardware drivers string. Does this sound OK?

The next time we want to use Jockey to install e. g.
linux-backports-modules we'd have to special-case/change it all over
again. Also, if we add more strings, this means increasing the load on
the translation teams, and at least at the beginning regressions in
translations.

I'm not fond of limiting the strings to "restricted" drivers upfront.

Vish (vish) wrote :

"Additional Drivers" sounds more appropriate than Downloaded Drivers, since these are additional alternative drivers to the free ones offered or in future the additional linux-backports-modules.

JaD Stepenwolf (jado92mx) wrote :

Additional Drivers is, at least for me, the best name (for end-users and
veterans). Maybe in the Main Window are displayed only propietary drivers,
but on the background the jockey tool is called ondemand for searching
another free and open source drivers. So, I think Additional Drivers should
be the right name for jockey in the Menu, Window Title and Documentation.

Greetings,
JaD!

Martin Pitt (pitti) wrote :

Jockey's current desktop file comment says "Configure third-party and proprietary drivers". So what about "Third party drivers"?

Is there some evidence (forum links, etc.) that people are actually being confused by the current description/name? I do not want to lightly break hundreds of translations for a rather gratuitous string change.

Vish (vish) wrote :

Quoting from : http://ubuntuforums.org/showthread.php?t=842590

" now the problem as I told u is that no card ever shows on harware drivers window!!!!!!!!!!! "

Vish (vish) wrote :

If we are planning to have linux-backports-modules in the future, not sure they fall under third-party drivers.
Maybe we change name again then? ;-)

But as Mel C points the window UI can be improved on the whole. (Not relevant to this bug though) :)

Vish (vish) wrote :

Robert Roth has already submitted a branch with the fix , it just needs to be reviewed. , setting bug to in-progress

Changed in hundredpapercuts:
importance: Undecided → Wishlist
status: Triaged → In Progress
Changed in jockey (Ubuntu):
importance: Undecided → Low
status: New → In Progress
Martin Pitt (pitti) wrote :

Merged with some adaptions into trunk r636, will upload to Ubuntu ASAP. Thanks!

Changed in jockey (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: In Progress → Fix Committed
Vish (vish) on 2010-08-24
Changed in hundredpapercuts:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5.10-0ubuntu1

---------------
jockey (0.5.10-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - ui --list: show auto-install flag
    - Add flag file based auto install mode
    - Add a title to the "search drivers" dialog. Thanks to Bilal Akhtar!
      (LP: #616569)
    - Rename "Hardware Drivers" to "Additional Drivers", to point out that
      Jockey is not responsible for all kinds of drivers. Thanks to Robert
      Roth for the initial patch. (LP: #409338)
    - Hide "Remove" button if a driver needs reboot. Thanks to Bilal Akhtar
      for the initial patch! (LP: #600804)
  * debian/control: Add missing ${misc:Depends}.
  * debian/control: No need to build-depend on python-dev.
  * debian/control: Fix nvidia-common dependency.
  * Add debian/source/format: "1.0", since changes are bzr maintained.
  * debian/control: Bump Standards-Version to 3.9.1.
 -- Martin Pitt <email address hidden> Tue, 24 Aug 2010 20:05:24 +0200

Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2010-08-24
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Jonathan Jesse (jjesse) wrote :

this bug has already been fixed in kubuntu-docs as the menu entity
references hardware drivers in the menu. any reference to jocky shows
hardware drivers

On Tue, Aug 24, 2010 at 2:34 PM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> ** Branch linked: lp:ubuntu/jockey
>
> --
> Change the name of "Hardware drivers"
> https://bugs.launchpad.net/bugs/409338
> You received this bug notification because you are a member of Ubuntu
> Documentation Committers, which is subscribed to Ubuntu Documentation.
>
> Status in One Hundred Paper Cuts: Fix Released
> Status in Ubuntu Documentation: New
> Status in “jockey” package in Ubuntu: Fix Released
>
> Bug description:
> System>Admin>Hardware drivers, the name is confusing me...Hardware drivers
> means should show all the devices like printer,webcam,etc .But Hardware
> driver is using for non-free drivers and not for free drivers, so plz change
> the name or change the software
>
>
>

Johan Walles (walles) wrote :

For reference, here's the original bug about this from 2008:

https://bugs.launchpad.net/ubuntu/+source/jockey/+bug/202267

In the discussion there, "Additional drivers" was voted down because of the "Additional to what?" argument.

"Third Party Drivers" was the suggestion that everybody seemed to like.

Anything is better than "Hardware drivers" though, so the new name is definitely an improvement. Great that this has finally gotten some attention!

Vish (vish) wrote :

Johan, seen that, but that suggestion does not take into account that linux-backports-modules can also be offered in jockey, which is definitely not third-party. ;-) [comment 25 and 26 here.]

TWP Marketing (markettwp) wrote :

Ok, this thread pointed me at the "system->administration->additional drivers" menu link, but the Ubuntu 10.10 desktop manual still says to look for "system->administration->hardware drivers". The manual(s) needs updating...

 It would be good to see an actual "hardware driver manager" option made available to users/admins. The learning curve had me stopped for too long on this point (2 days to find this thread).

Kevin Godby (godbyk) on 2014-01-14
Changed in ubuntu-docs:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers