Deleted Items Folder inconsistently named in en_GB localisation

Bug #406626 reported by Elliot Hughes on 2009-07-29
114
This bug affects 15 people
Affects Status Importance Assigned to Milestone
GNOME Applets
Fix Released
Undecided
Ubuntu English (United Kingdom) Translators
GNOME Common
Expired
Medium
Gnome Documentation
Expired
Medium
Nautilus
Fix Released
Undecided
Ubuntu English (United Kingdom) Translators
One Hundred Papercuts
Medium
Unassigned
Ubuntu Manual
Undecided
Ubuntu English (United Kingdom) Translators
Ubuntu Translations
Medium
Ubuntu English (United Kingdom) Translators
gvfs
Fix Released
Undecided
Ubuntu English (United Kingdom) Translators
gnome-applets (Ubuntu)
Low
Ubuntu English (United Kingdom) Translators
transmission (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

#########
This bug has been fixed and closed.
---------
If you find more applications where the Trash has not been renamed to Rubbish bin, in en_GB,
Kindly refrain from adding the bug task here.

Instead, open NEW bug reports(With a mention of this bug number).

#########

The deleted items folder is inconsistently named and is referred to as both Wastebasket and Deleted items, Ubuntu offers to 'Empty Deleted Items' but the window is headed Wastebasket. The URL to deleted items is also trash:/// in nautilus but this is possibly a seperate issue. An effect of this can be seen in #115661 also.

This could confuse new users and it should be a simple enough fix simply changing strings, so I believe it is a papercut.

-----
from the Doc Team: the recommended term is now "Rubbish Bin"!
-----

Can you supply specific examples of where these naming conflicts appear, as my system uses "Trash" in all cases as far as i am aware

Vish (vish) wrote :

Could you provide a screenshot of the problem?

Changed in hundredpapercuts:
status: New → Incomplete
Elliot Hughes (elliot-hughes) wrote :

Sure,

The inconsistencies are shown as specific examples in the screenshots attached.

Elliot Hughes (elliot-hughes) wrote :
Elliot Hughes (elliot-hughes) wrote :
Kazade (kazade) wrote :
Changed in hundredpapercuts:
status: Incomplete → Confirmed
Kazade (kazade) wrote :

It's worth noting that Wastebasket is British English, I believe in the U.S. then it's Trash + Deleted Items. I would recommend that "Deleted Items" is replaced with "Wastebasket" or "Trash" everywhere (easier to visualize).

Changed in ubuntu:
assignee: nobody → Ubuntu English (United Kingdom) Translators (ubuntu-l10n-en-gb)
Matthew Paul Thomas (mpt) wrote :

Assigning to the English (UK) Translators. <https://wiki.ubuntu.com/EnglishTranslation/WordSubstitution> says that Ubuntu in UK English should use either "rubbish", "Deleted Items", or "Deleted Items folder". But calling a folder "Deleted Items" is an oxymoron: if the items were deleted, they wouldn't be there at all.

I suggest just using "Trash" consistently. It's much shorter than any of the alternatives, it's less work for the translators, and it puts an end to the situation where a partly-translated interface comically disagrees with itself. I think these are all the strings that need fixing:
<https://translations.launchpad.net/ubuntu/karmic/+source/nautilus/+pots/nautilus/en_GB/+translate?search=trash>
<https://translations.launchpad.net/ubuntu/karmic/+source/gvfs/+pots/gvfs/en_GB/+translate?search=trash>

The reasoning is sound, but in the UK we don't have "trash" or "garbage"; we
have "rubbish". Therefore settling for Trash would be a little inaccurate.
How about a "Bin" or "Rubbish Bin" instead?

On Dec 13, 2009 2:07 AM, "Matthew Paul Thomas" <email address hidden> wrote:

Assigning to the English (UK) Translators.
<https://wiki.ubuntu.com/EnglishTranslation/WordSubstitution> says that
Ubuntu in UK English should use either "rubbish", "Deleted Items", or
"Deleted Items folder". But calling a folder "Deleted Items" is an
oxymoron: if the items were deleted, they wouldn't be there at all.

I suggest just using "Trash" consistently. It's much shorter than any of the
alternatives, it's less work for the translators, and it puts an end to the
situation where a partly-translated interface comically disagrees with
itself. I think these are all the strings that need fixing:
<
https://translations.launchpad.net/ubuntu/karmic/+source/nautilus/+pots/nautilus/en_GB/+translate?search=trash
>
<
https://translations.launchpad.net/ubuntu/karmic/+source/gvfs/+pots/gvfs/en_GB/+translate?search=trash
>

-- Deleted Items Folder inconsistently named
https://bugs.launchpad.net/bugs/406626 You received t...

This issue is the result of an ill-conceived (and I take partial responsibility for this) and inconsistently implemented policy.

The problem we face is that different upstreams have different names for their waste receptacles. To take GNOME and KDE (the largest desktop projects) as a reference:

  * http://live.gnome.org/BritishEnglish
  * http://l10n.kde.org/team-infos.php?teamcode=en_GB

As you can see, GNOME uses "wastebasket" and KDE uses "wastebin". So if we leave the strings untranslated we're going to see an inconsistency.

Using "Trash" is ill-advised for the following reasons:

  * we would have to manually rename the "wastebasket" and "wastebin" references from upstream
  * we would be introducing yet another synonym for the same thing
  * "Trash" sounds foreign (if you disagree, you can always use en_US)

Having lived through and participated in the debates that introduced the "Deleted Items" option, I now think the best way forwards is to fix things upstream. The KDE and GNOME choices are already prevalent, so I suggest that we work with the translation teams from both those projects and encourage them to agree on one. By fixing it upstream, we benefit other distributions as well and eliminate the need for the Ubuntu en_GB team to do any work.

Sridhar Dhanapalan (sridhar) wrote :

Reply to #9:

"Rubbish Bin" is my personal preference. It feels like an en_GB term, and it is similar enough to the widely-seen "Recycle Bin" to be easily understood. However, it does add yet another name to the mix.

Reiterating my last post (#10), I think that this should be fixed upstream. Anything done within Ubuntu would require constant maintenance from the en_GB translation team.

Being on the GNOME en_GB team, I feel as if there is nothing broken about "wastebasket". "Deleted items (folder)" is too clumsy a term. I'd be all for discussion with the KDE en_GB team about using a cross-desktop term however.

The only thing broken about the term "wastebasket" is that it's not a term in common use in the UK. "Bin" and "Recycle Bin" are the two prevalent terms in homes and offices I've been in, with "Rubbish" being what you put in them. Nobody I know uses the term "items" when referring to rubbish.

I'd be absolutely willing to change GNOME terminology to "Bin" if I could get agreement with the other desktops and the rest of the team.

Matthew Paul Thomas (mpt) wrote :

The British National Corpus (BNC) is a 100 million word collection of samples of written and spoken language from a wide range of sources, designed to represent a wide cross-section of British English from the later part of the 20th century, both spoken and written. <http://www.natcorp.ox.ac.uk/>

Unfortunately, the BNC Web site's search function does not seem to distinguish between parts of speech. For example, <http://bnc.bl.uk/saraWeb.php?qy=trash> returns 219 occurrences of "trash", but these are a mixture of nouns, verbs, and adjectives.

Fortunately, the BNC is collated at <http://www.kilgarriff.co.uk/bnc-readme.html>, where parts of speech are distinguished. Using the "all.al.gz" list <http://www.kilgarriff.co.uk/BNClists/all.al.gz>, we find:
* 1 occurrence of "rubbish-bin"
* 9 occurrences of "wastebasket"
* 14 occurrences of "wastebin" (and 1 of "wastebins")
* 150 occurrences of "trash" as a noun, plus 49 more where it was unclear whether it was being used as a noun, a proper noun, or a verb.

The collated list does not include non-hyphenated phrases, but going back to the main BNC Web site we can see that "rubbish bin" occurs 42 times in the corpus <http://bnc.bl.uk/saraWeb.php?qy=rubbish+bin>, and "recycle bin" doesn't occur at all <http://bnc.bl.uk/saraWeb.php?qy=recycle+bin>. ("Deleted items" is, as expected, completely absent too.)

From this I conclude that "trash" is, in UK English, far and away more common than "rubbish bin", "wastebin", or "wastebasket".

Mat Tomaszewski (mat.t.) wrote :

Mpt, you're a star.

I think this bug is triaged now.

Changed in hundredpapercuts:
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in ubuntu:
status: New → Triaged
Kazade (kazade) wrote :

I think that search is flawed. "Trash" is very rarely used in spoken UK English when referring to "Rubbish", the only time I can think of the word "trash" being used is reference to something like a TV show, or book e.g. "That book was trash" but even that itself is a rarity because I believe quite an old fashioned usage of the term.

You'll note that in that "rubbish" as a term occurs 2257 times, and "bin" 682. These are separate words normally spoken and written without hyphenation, which would explain why the hyphenated version only occurs once.

Matthew Paul Thomas (mpt) wrote :

Kazde, I would ask you for data to back up your assertion that "trash" is rarely used in spoken UK English, but it doesn't even matter, because (except for blind users) the Ubuntu interface is in written form. Also you seem to have missed the part where the non-hyphenated phrase "rubbish bin" occurs only 42 times.

Matthew Paul Thomas (mpt) wrote :

(Kazade, I meant. Sorry for the misspelling.)

Kazade (kazade) wrote :

Here's some other statistics using the search (I see what you are saying about the mixture of nouns, verbs and adjectives though) including the words when used together without hyphenation (e.g. "rubbish bin")

http://bnc.bl.uk/saraWeb.php?qy=rubbish => 2196
http://bnc.bl.uk/saraWeb.php?qy=trash => 219

http://bnc.bl.uk/saraWeb.php?qy=rubbish+bin => 42
http://bnc.bl.uk/saraWeb.php?qy=trash+can => 11
http://bnc.bl.uk/saraWeb.php?qy=trash+bin => 1

http://bnc.bl.uk/saraWeb.php?qy=wastebin => 13
http://bnc.bl.uk/saraWeb.php?qy=waste+bin => 21

http://bnc.bl.uk/saraWeb.php?qy=waste+basket => 5
http://bnc.bl.uk/saraWeb.php?qy=wastebasket => 7

Kazade (kazade) wrote :

In the UK, "rubbish" is the equivalent of the U.S. sounding "trash", they are even used in the same contexts. Comparing "rubbish" to "trash" would be a fair comparison, as it's the same thing. As would be comparing "rubbish bin" or "dustbin" to "trash can".

Comparing "trash" to "rubbish bin" is comparing two different things (the items vs the container they go in).

That said both "rubbish" and "trash" imply a certain finality about the action, you don't go digging in the rubbish to get something back, but a "bin" is a pretty generic term for a container (e.g. bargain bin, loony bin), I'd argue that "Bin" would be far more fitting than "Trash" or "Rubbish", like Popey said, the rubbish is what goes in the bin.

Dave Morley (davmor2) on 2010-03-08
Changed in hundredpapercuts:
status: Triaged → Invalid
Matt Daubney (daubers) wrote :

The OED (http://www.askoxford.com/concise_oed/trash?view=uk) says the Trash is North American, as is trash can (http://www.askoxford.com/concise_oed/trashcan?view=uk). Rubbish (http://www.askoxford.com/concise_oed/rubbish?view=uk) is defined as (in this context) "1 waste material; refuse or litter." and a bin (again in this context) is (http://www.askoxford.com/concise_oed/bin?view=uk) "1 a container for rubbish."

I normally stand by the OED and would in this case. I'd say it should be "Bin" or maybe "Rubbish Bin" in en_gb

Changed in hundredpapercuts:
status: Invalid → Triaged
Mat Tomaszewski (mat.t.) wrote :

Guys, can we agree that having one name across the whole interface, even if its correctness sparks some controversy, is better than having two different names, both controversial?

Kazade (kazade) wrote :

Yes we can agree that much. There seems to be a general consensus among the UK people in this thread that "Rubbish Bin" or "Bin" would be suitable. "Trash" would be better than the inconsistency we have now, but it's not really the term we use in British English.

I realise that gnome-common isn't correct, but it's the best I can do.

Allan Day (allanday) wrote :

I agree that the most important thing is to stick with a single consistent term. That said, I'm not sure about 'Trash' and think 'Wastebasket' is the better term.

The criteria for selecting this term shouldn't just be relative popularity or familiarity. It should also be that it communicates the meanings we want the term to communicate.

The whole idea of the Trash/Wastebasket is that it is a temporary receptical which is emptied at a later date, and which items can be retreived from. Wastebasket suggests a waste paper basket; the kind of thing that lives under a desk. Things can be easily retreived from a wastebasket. Trash suggests something different. Trash is general refuse - the bin in your kitchen or by your back door. It isn't easy or common to retreive things from your trash.

'Wastebasket' communicates the functionality we are trying to describe better than 'trash', therefore. The semantics of these two terms can be easily seen by doing a Google image seach for each one.

David Lodge (dave-cirt) wrote :

The major thing we need to aim for is consistency across all environments (including Gnome and KDE). I personally don't care as I disable the Bin (I'm old style Unix - when I delete something I expect it to be deleted), but I really dislike the Americanism of "Trash".

Is there any easy way to poll the current en_GB users (or those who care enough to respond to a poll)? Once this has been done we can make an upstream decision and have it fixed there.

summary: - Deleted Items Folder inconsistently named
+ Deleted Items Folder inconsistently named in en_GB localization
Vish (vish) on 2010-07-15
description: updated

Please change the description back.

It's simply not true that the word 'trash' is in common use in UK English for this context. It is a term from American English and is just not appropriate in a GB translation.

I think that most people would agree that the OED is a reliable source of information on this. So I quote from:
http://www.oxforddictionaries.com/view/entry/m_en_gb0878770#m_en_gb0878770

    *
      1 chiefly North American waste material; refuse
    *
      cultural items, ideas, or objects of poor quality:if they read at all, they read trash
    *
      2 North American a person or people regarded as being of very low social standing:clubs patronized by rock trash

In both contexts it is referenced as North American. The correct UK term is almost certainly Rubbish.

You could say that the assertion that Trash is used in Britain is utter rubbish.

Sorry.

Christopher Griffiths (chris) wrote :

Trash is a term very rarely used within the United Kingdom. It is very common to called the items themselves "rubbish" in such a phrase as "this can belongs in the rubbish". In reference to the folder however, as wikipedia[0] points out, in place of trashcan the British normally use the term rubbish bin or more accurately just "bin" colloquially. It is much more accurate to call the wastebasket the rubbish bin in regards to British English translations.

[0] http://en.wikipedia.org/wiki/List_of_American_words_not_widely_used_in_the_United_Kingdom#T

description: updated
Phil Bull (philbull) wrote :

Can I push for a decision on this ASAP, please? Not having a consistent naming convention causes problems for people doing user assistance (docs etc.), and this discussion has gone on for far too long. A native British English speaker should make the decision; having a non-native speaker decide (US English or otherwise) is inappropriate.

If no-one is prepared to make a decision, feel free to assign this to the docs team and we can survey some users (I'm British, so I'd probably do it).

I'd be happy top help organise such a survey (also a brit).

Kazade (kazade) wrote :

I think the general consensus among native British English speakers in this report is that "bin" or "rubbish bin" are suitable terms. e.g. "Move to the rubbish bin", "Empty the rubbish bin" etc.

Vish (vish) wrote :

@Phil , I had emailed Martin Meredith, a couple of weeks ago, to take a decision on this bug. But havent heard back from him yet.

There seems to be no consensus on this. Let's just pick one and get this fixed for Maverick :-)

Assigning to docs team as per Phil's suggestion

Changed in hundredpapercuts:
assignee: nobody → Ubuntu Documentation Project Team (ubuntu-doc)
1 comments hidden view all 116 comments
Vish (vish) wrote :

@Phil , I had emailed Martin Meredith, a couple of weeks ago, to take a decision on this bug.
But haven't heard back from him yet.

There seems to be no consensus on this. Let's just pick one and get this fixed for Maverick :-)

Assigning to docs team as per Phil's suggestion

Changed in ubuntu:
importance: Undecided → Low

If anything was decided, I could probably get this fixed for GNOME 2.32.

Vish,

I'm new to the Ubuntu Docs group. I was just assigned this new task with you
guys, but I'm not sure how to get this started, or where to log in. I was
trying to find someone under the Ubuntu mentoring program. Any information
you could off I would appreciate!

- Bryant

On Fri, Jul 30, 2010 at 8:00 AM, Vish <email address hidden> wrote:

> @Phil , I had emailed Martin Meredith, a couple of weeks ago, to take a
> decision on this bug.
> But haven't heard back from him yet.
>
> There seems to be no consensus on this. Let's just pick one and get this
> fixed for Maverick :-)
>
> Assigning to docs team as per Phil's suggestion
>
> ** Changed in: ubuntu
> Importance: Undecided => Low
>
> --
> Deleted Items Folder inconsistently named in en_GB localization
> https://bugs.launchpad.net/bugs/406626
> You received this bug notification because you are a member of Ubuntu
> Documentation Project Team, which is a bug assignee.
>
> Status in GNOME Common Scripts: Unknown
> Status in One Hundred Paper Cuts: Triaged
> Status in Ubuntu: Triaged
>
> Bug description:
> The deleted items folder is inconsistently named and is referred to as both
> Wastebasket and Deleted items, Ubuntu offers to 'Empty Deleted Items' but
> the window is headed Wastebasket. The URL to deleted items is also trash:///
> in nautilus but this is possibly a seperate issue. An effect of this can be
> seen in #115661 also.
>
> This could confuse new users and it should be a simple enough fix simply
> changing strings, so I believe it is a papercut.
>
> -----
> Quoting MPT , see comment #15 for more details:
> "trash" is, in UK English, far and away more common than "rubbish bin",
> "wastebin", or "wastebasket".
> -----
> (The accuracy of this statement is questioned, see comment #28 onwards and
> https://wiki.ubuntu.com/EnglishTranslation/WordSubstitution given in
> comment #8.)
>
>
>
>

Ryan Hoover (rhoover84) wrote :
Download full text (3.3 KiB)

Bryant,

It was sent to the Docs team in general -- not you specifically. I'm new
also and was just as confused when I first got the email :)

On Sat, Jul 31, 2010 at 1:48 PM, Bryant Lippert <email address hidden>wrote:

> Vish,
>
> I'm new to the Ubuntu Docs group. I was just assigned this new task with
> you
> guys, but I'm not sure how to get this started, or where to log in. I was
> trying to find someone under the Ubuntu mentoring program. Any information
> you could off I would appreciate!
>
> - Bryant
>
> On Fri, Jul 30, 2010 at 8:00 AM, Vish <email address hidden> wrote:
>
> > @Phil , I had emailed Martin Meredith, a couple of weeks ago, to take a
> > decision on this bug.
> > But haven't heard back from him yet.
> >
> > There seems to be no consensus on this. Let's just pick one and get this
> > fixed for Maverick :-)
> >
> > Assigning to docs team as per Phil's suggestion
> >
> > ** Changed in: ubuntu
> > Importance: Undecided => Low
> >
> > --
> > Deleted Items Folder inconsistently named in en_GB localization
> > https://bugs.launchpad.net/bugs/406626
> > You received this bug notification because you are a member of Ubuntu
> > Documentation Project Team, which is a bug assignee.
> >
> > Status in GNOME Common Scripts: Unknown
> > Status in One Hundred Paper Cuts: Triaged
> > Status in Ubuntu: Triaged
> >
> > Bug description:
> > The deleted items folder is inconsistently named and is referred to as
> both
> > Wastebasket and Deleted items, Ubuntu offers to 'Empty Deleted Items' but
> > the window is headed Wastebasket. The URL to deleted items is also
> trash:///
> > in nautilus but this is possibly a seperate issue. An effect of this can
> be
> > seen in #115661 also.
> >
> > This could confuse new users and it should be a simple enough fix simply
> > changing strings, so I believe it is a papercut.
> >
> > -----
> > Quoting MPT , see comment #15 for more details:
> > "trash" is, in UK English, far and away more common than "rubbish bin",
> > "wastebin", or "wastebasket".
> > -----
> > (The accuracy of this statement is questioned, see comment #28 onwards
> and
> > https://wiki.ubuntu.com/EnglishTranslation/WordSubstitution given in
> > comment #8.)
> >
> >
> >
> >
>
> --
> Deleted Items Folder inconsistently named in en_GB localization
> https://bugs.launchpad.net/bugs/406626
> You received this bug notification because you are a member of Ubuntu
> Documentation Project Team, which is a bug assignee.
>
> Status in GNOME Common Scripts: Unknown
> Status in One Hundred Paper Cuts: Triaged
> Status in Ubuntu: Triaged
>
> Bug description:
> The deleted items folder is inconsistently named and is referred to as both
> Wastebasket and Deleted items, Ubuntu offers to 'Empty Deleted Items' but
> the window is headed Wastebasket. The URL to deleted items is also trash:///
> in nautilus but this is possibly a seperate issue. An effect of this can be
> seen in #115661 also.
>
> This could confuse new users and it should be a simple enough fix simply
> changing strings, so I believe it is a papercut.
>
> -----
> Quoting MPT , see comment #15 for more details:
> "trash" is, in UK English, far and away more common than "rubbish bin",
...

Read more...

Download full text (4.9 KiB)

Ryan,

Thanks for the clarification. I have launchpad set up, and I think
everything is good to go. How can I help with this bug?

- Bryant

On Sat, Jul 31, 2010 at 4:49 PM, Ryan Hoover <email address hidden>wrote:

> Bryant,
>
> It was sent to the Docs team in general -- not you specifically. I'm new
> also and was just as confused when I first got the email :)
>
> On Sat, Jul 31, 2010 at 1:48 PM, Bryant Lippert
> <email address hidden>wrote:
>
> > Vish,
> >
> > I'm new to the Ubuntu Docs group. I was just assigned this new task with
> > you
> > guys, but I'm not sure how to get this started, or where to log in. I was
> > trying to find someone under the Ubuntu mentoring program. Any
> information
> > you could off I would appreciate!
> >
> > - Bryant
> >
> > On Fri, Jul 30, 2010 at 8:00 AM, Vish <email address hidden> wrote:
> >
> > > @Phil , I had emailed Martin Meredith, a couple of weeks ago, to take a
> > > decision on this bug.
> > > But haven't heard back from him yet.
> > >
> > > There seems to be no consensus on this. Let's just pick one and get
> this
> > > fixed for Maverick :-)
> > >
> > > Assigning to docs team as per Phil's suggestion
> > >
> > > ** Changed in: ubuntu
> > > Importance: Undecided => Low
> > >
> > > --
> > > Deleted Items Folder inconsistently named in en_GB localization
> > > https://bugs.launchpad.net/bugs/406626
> > > You received this bug notification because you are a member of Ubuntu
> > > Documentation Project Team, which is a bug assignee.
> > >
> > > Status in GNOME Common Scripts: Unknown
> > > Status in One Hundred Paper Cuts: Triaged
> > > Status in Ubuntu: Triaged
> > >
> > > Bug description:
> > > The deleted items folder is inconsistently named and is referred to as
> > both
> > > Wastebasket and Deleted items, Ubuntu offers to 'Empty Deleted Items'
> but
> > > the window is headed Wastebasket. The URL to deleted items is also
> > trash:///
> > > in nautilus but this is possibly a seperate issue. An effect of this
> can
> > be
> > > seen in #115661 also.
> > >
> > > This could confuse new users and it should be a simple enough fix
> simply
> > > changing strings, so I believe it is a papercut.
> > >
> > > -----
> > > Quoting MPT , see comment #15 for more details:
> > > "trash" is, in UK English, far and away more common than "rubbish bin",
> > > "wastebin", or "wastebasket".
> > > -----
> > > (The accuracy of this statement is questioned, see comment #28 onwards
> > and
> > > https://wiki.ubuntu.com/EnglishTranslation/WordSubstitution given in
> > > comment #8.)
> > >
> > >
> > >
> > >
> >
> > --
> > Deleted Items Folder inconsistently named in en_GB localization
> > https://bugs.launchpad.net/bugs/406626
> > You received this bug notification because you are a member of Ubuntu
> > Documentation Project Team, which is a bug assignee.
> >
> > Status in GNOME Common Scripts: Unknown
> > Status in One Hundred Paper Cuts: Triaged
> > Status in Ubuntu: Triaged
> >
> > Bug description:
> > The deleted items folder is inconsistently named and is referred to as
> both
> > Wastebasket and Deleted items, Ubuntu offers to 'Empty Deleted Items' but
> > the window is headed Wastebasket. The URL to ...

Read more...

Phil Bull (philbull) on 2010-08-25
Changed in hundredpapercuts:
status: Triaged → Opinion
Vish (vish) on 2010-08-25
description: updated
Changed in hundredpapercuts:
status: Opinion → Triaged
David Planella (dpm) on 2010-08-26
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Ubuntu English (United Kingdom) Translators (ubuntu-l10n-en-gb)
Changed in gnome-common:
status: Unknown → Incomplete
Michael (mf) on 2010-08-29
Changed in nautilus:
assignee: nobody → Ubuntu English (United Kingdom) Translators (ubuntu-l10n-en-gb)
Michael (mf) on 2010-08-29
summary: - Deleted Items Folder inconsistently named in en_GB localization
+ Deleted Items Folder inconsistently named in en_GB localisation
Michael (mf) on 2010-08-29
Changed in nautilus:
status: New → In Progress
Michael (mf) on 2010-08-29
Changed in nautilus:
status: In Progress → Fix Committed
36 comments hidden view all 116 comments
Michael (mf) wrote :

Updated gfvs and gnome-applets en-GB translations to "Rubbish Bin" also.

Changed in gnome-applets:
importance: Unknown → Undecided
status: Unknown → New
Michael (mf) wrote :

Translations changed to "Rubbish Bin"

Changed in gnome-applets:
assignee: nobody → Ubuntu English (United Kingdom) Translators (ubuntu-l10n-en-gb)
status: New → Fix Committed
Changed in gvfs:
assignee: nobody → Ubuntu English (United Kingdom) Translators (ubuntu-l10n-en-gb)
status: New → Fix Committed
Vish (vish) wrote :

Michael Fallows ,Nice work!. Thanks for getting the fix committed.

Changed in hundredpapercuts:
status: Triaged → Fix Committed
Michael (mf) wrote :

In the user guide (within "Using Trash", "Moving a File or Folder to Trash" and possibly more) need to be changed to using the new Rubbish Bin wording rather then trash.

Michael (mf) wrote :

Sorry just for clarification by user guide I meant the Gnome Documentation that is found in Ubuntu -> System -> Help and Support.

Michael (mf) on 2010-09-03
Changed in ubuntu-manual:
status: New → Fix Committed
assignee: nobody → Ubuntu English (United Kingdom) Translators (ubuntu-l10n-en-gb)
Changed in gnome-common:
importance: Unknown → Medium
Changed in gnome-user-docs:
importance: Unknown → Medium
status: Unknown → Incomplete

Looks like there is still two inconsistencies. Nautilus uses trash:// as the uri to the Rubbish Bin. Okay, accept that this is unlikely to be easily changeable in the same way that one wouldn't change /home to /Π΄ΠΎΠΌΠ° or whatever. However the applet at the bottom of the screen still has two entirely different names for Rubbish Bin.

See screenshot, bottom right.

Vish (vish) wrote :

@Michael Fallows: Could you check/correct the two menu items for the trash-applet that Alan has pointed out?

Michael (mf) wrote :

Yes it has been changed in the source package (gnome-applets) translations here https://translations.launchpad.net/ubuntu/maverick/+source/gnome-applets/+pots/gnome-applets-2.0/en_GB/+translate?batch=10&show=all&search=wastebasket . Does this need to be updated anywhere else to become an update within Ubuntu?

Michael (mf) on 2010-09-20
affects: ubuntu → gnome-applets (Ubuntu)
Changed in gnome-applets (Ubuntu):
status: Triaged → Fix Committed
Josh Holland (jshholland) wrote :

OK, I just emptied the Rubbish Bin and a confirmation window popped up and asked me if I really wanted to empty the Trash. So, there are obviously some strings still hiding.

Kazade (kazade) wrote :

Also, the two menu entries that appear when right-clicking the Rubbish Bin applet still show "Wastebasket" and "Deleted Items" (see Alan's comment #82)

Kazade (kazade) wrote :

Just a follow up to my previous comment, both the strings are translated in launchpad, just not yet packaged in gnome-applets.

El dv 01 de 10 de 2010 a les 08:27 +0000, en/na Kazade va escriure:
> Just a follow up to my previous comment, both the strings are translated
> in launchpad, just not yet packaged in gnome-applets.
>

We're starting to build the final language packs today, so they should
be there in a few days and include all the new translations.

If after you've updated to the latest language packs you still see any
remaining Deleted Items or Wastebasket instances, please report back and
let's investigate where they come from.

Thanks!

V A R G U X (vargux) on 2010-10-01
Changed in hundredpapercuts:
assignee: Ubuntu Documentation Project Team (ubuntu-doc) → nobody
Michael (mf) wrote :

Thanks David for the update and thanks to everyone who has worked on this! Hope we have caught every translation and that the updates come through soon :).

Looking nicely consistent now - see screenshot.

Thanks everyone.

However whilst consistent, the previous wording on the applet was:-

"Open the Wastebasket" -> "Open Rubbish Bin"
"Empty the Deleted Items folder" -> "Empty Rubbish Bin"

Seems we've lost the "the".

Kazade (kazade) wrote :

I've added suggested translations in Launchpad including the missing "the" in gnome-applets and there is already an existing one in Nautilus (for the button that appears when you view the rubbish bin). I don't have magic translation review powers so I can only suggest the change, can someone go in and review it?

Vish (vish) wrote :

In US english it is "Open Trash" and "Empty Trash" , there is no "the" , why does UK English need extra "the" ?

@vish, because it's grammatically correct ;) In the same way that we use:- "write to me" where US English uses "write me".

Charles Kerr (charlesk) on 2010-10-02
Changed in transmission (Ubuntu):
assignee: nobody → Ubuntu English (United Kingdom) Translators (ubuntu-l10n-en-gb)
Charles Kerr (charlesk) on 2010-10-02
Changed in transmission (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Dave Rice (ricey) wrote :

@popey & @Kazade,

Hi,
I've reviewed and 'saved' you're suggestions, they are correct as far as en_gb is concerned, if there are any other instances where you find this please let us know!

cheers

Ricey

Vish (vish) wrote :

I would suggest *against* adding "the" for this. Menu items are not about forming grammatically correct complete sentences.

HIG specifies not to overuse these http://library.gnome.org/devel/gdp-style-guide/stable/grammar.html.en

Also, no other menu items use "the"/"a" unnecessarily.
Eg: nautilus File menu > is Create Folder , Create Document. and everywhere else in all applications it is the same pattern.

Adding "the" here would mean bringing in a new inconsistency.

But, if the British think they invented English, then... Oh! wait! :-)

Kevin Godby (godbyk) wrote :

I concur with Vish: for menu items, the determiner 'the' should typically be omitted. Here's a list of standard menus and menu items:

  http://library.gnome.org/devel/hig-book/stable/menus-standard.html.en

None of the menu items listed contain determiners.

Michael (mf) wrote :

To be fair I think the inconsistency with the "the" came about when I was translating all of the original texts to Rubbish bin I kept a "the" when it was a wordy text such "Do you wish to send this to the Rubbish Bin" where as if it was an action/command "Send to Rubbish Bin" I missed out the "the". Could be my East London dialect that makes that sound OK without the "the"? I guess this means I aggree with Vish as he is talking mainly of the menu items (i.e. actions/commands).

Michael

Kazade (kazade) wrote :

The problem is that, "Sent to Rubbish Bin" and "Empty Rubbish Bin" sound disjointed and robotic. It's not fair to compare it to "trash" because Trash is what what goes in the bin (e.g. Empty Rubbish sounds OK).

Empty Rubbish Bin is understandable, it's just ugly.

Vish (vish) wrote :

OK, I think my reference to the gnome HIG is a bit unfair over this issue :-) [maybe a side-effect of replying at 3am on a Sat night :p ]

Because HIG is basically how the _default_ language style needs to be written in Gnome UI and the default language is US English. So everything else is just based accordingly there.

As popey mentioned, the translations need to adapt to the locale.
The local translators need to decide which sounds more apt for their locale and they weigh in on the benefits.

My non-locale view on this is that, this change *is* bringing in new inconsistent to the items from the rest of the system menus.

However, the UK translators/users might find this an absolutely necessary change to make.
If so, this needs to be done elsewhere too, to maintain a consistent UI. Kindly make the necessary changes elsewhere too.

Mostly, everwhere in HIG there is a reference of keeping labels short and for clear, consistent and concise labelling.
http://library.gnome.org/devel/hig-book/stable/language-labels.html.en

http://library.gnome.org/devel/hig-book/stable/menus-standard.html.en
Find Next, Find Previous , From FIle... , Add Bookmark , Edit Bookmarks , need to be changed
More items listed at :
http://library.gnome.org/devel/hig-book/stable/menus-design.html.en
http://library.gnome.org/devel/gdp-style-guide/stable/menu-terminology.html.en
http://library.gnome.org/devel/hig-book/stable/menus.html.en

This bug is about the inconsistent naming of wastebasket and Deleted items, and was fixed when popey confirmed with screenshot in comment #90, beyond which we have piggy-backed on this bug with another issue.
Marking this bug as fixed, while the change to add "the/a/an" can be discussed in a new a bug for all menu items.

Thanks everyone for getting this fixed! :-)

Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in gnome-applets:
status: Fix Committed → Fix Released
Changed in gnome-applets (Ubuntu):
status: Fix Committed → Fix Released
Changed in gvfs:
status: Fix Committed → Fix Released
Changed in nautilus:
status: Fix Committed → Fix Released
Changed in ubuntu-translations:
status: Triaged → Fix Released
Phil Bull (philbull) wrote :

Hi guys,

Please stick to the HIG with this. Deviating from it will introduce ambiguities when translating the documentation. I should also point out that this isn't a localisation issue, it's a stylistic one. We have this "terse" style in UK English too (newspaper headlines use something similar, for example), and it's perfectly acceptable.

It's OK for action labels, like those on buttons or in pop-up menus, to sound disjointed. They're not full sentences; rather they're "headings", so there's no need for them to flow. The role of an action label is to quickly identify a function, not to convey meaning, so there's no need for the wording to sound pleasant. This would be different if we were talking about (e.g.) the explanatory text in a dialog box, though.

David Planella (dpm) wrote :

Hi everyone,

Thanks to everyone participating in the discussions and applying the fixes, the original bug about inconsistent naming is now fixed. Good work!

For any remaining issues such as the need to add an article to the actions related to the Rubbish Bin, I'd recommend using the British translators mailing list, which is a more appropriate forum for such discussions.

Once agreement has been reached, you can modify the strings in Launchpad if necessary, and they will be picked up in the next round of stable release language pack updates, a few weeks after release.

Thanks!

melat0nin (melat0nin) wrote :

This bug isn't entirely fixed - the tooltip for Rubbish Bin in the Nautilus sidebar still says 'Open the wastebasket'.

Steve Holmes (bouncysteve) wrote :

There was also a reference to Deleted Items in the Unity sidebar in UNE, but I've corrected it now.

Charles Kerr (charlesk) wrote :

Reopening this ticket for ubuntu-translations to ask for confirmation this is resolved for Transmission? Transmission's still listed on this ticket as "triaged" rather than "fix committed" or "fix released".

Changed in ubuntu-translations:
status: Fix Released → Triaged
Vish (vish) wrote :

charles, It was marked fixed because the initial bug which was the issue here was fixed.
The transmission task was added only 2weeks ago.
It is better to file new bug rather than creating metabugs.
If such metabugs are OK for the translations team, This bug will probably take a while to fix, since "Trash" is a very common occurrence and every application in the main/universe can keep re-opening this bug and spamming everyone.

See similar bug for Unity and Trash > Bug #646669 .

Charles Kerr (charlesk) wrote :

Re-closing this ticket to avoid metabugs, and reopening bug #653529

Changed in ubuntu-translations:
status: Triaged → Fix Released
Vish (vish) wrote :

Closing Transmission task, as Bug #653529 has been un-duped and is tracked separately now.

Changed in transmission (Ubuntu):
assignee: Ubuntu English (United Kingdom) Translators (ubuntu-l10n-en-gb) → nobody
status: Triaged → Invalid
David Planella (dpm) wrote :
  • Wastebasket Edit (11.5 KiB, text/plain; name="Wastebasket"; charset="UTF-8")

El dg 10 de 10 de 2010 a les 14:08 +0000, en/na melat0nin va escriure:
> This bug isn't entirely fixed - the tooltip for Rubbish Bin in the
> Nautilus sidebar still says 'Open the wastebasket'.
>

We've dealt with the bulk of Wastebasket/Deleted Items translations now.
Apart from the ones from Unity (fix committed) and transmission
(separate bug, a step away from being fixed), there hasn't been any
other report of inconsistencies.

That particular string in Nautilus was fixed already, but a couple of
days after the language pack deadline, thus it didn't make it to the
final language packs:

https://translations.edge.launchpad.net/ubuntu/maverick/+source/nautilus/+pots/nautilus/en_GB/+translate?batch=10&show=all&search=open+the+wastebasket

The fix should be visible in the next language pack updates in a couple
of weeks.

I've attached a text file with other places where "Wastebasket" is still
present in the system. You might want to change those too. You can find
the strings in Launchpad using the same URL pattern as above. Here it
is:

https://translations.launchpad.net/ubuntu/maverick/+source/$SOURCEPACKAGE/+pots/$TEMPLATE/en_GB/+translate?batch=10&show=all&search=open+the+wastebasket

Often $SOURCEPACKAGE and $TEMPLATE are the same. If not, you can go to
the source package translations page, look at the templates and simply
click on them to go there.

Note that some will be false positives and will already have been fixed,
like the ones in Nautilus.

I hope this helps.

Matthew Gall (matthewgall) wrote :
Changed in transmission (Ubuntu):
status: Invalid → Fix Committed

Added unity to the list. When you hover over the wastebucket icon in the left hand corner, it says "Trash"

David Planella (dpm) wrote :

El dt 30 de 11 de 2010 a les 17:24 +0000, en/na David Stansby va
escriure:
> Added unity to the list. When you hover over the wastebucket icon in the
> left hand corner, it says "Trash"
>
> ** Also affects: unity (Ubuntu)
> Importance: Undecided
> Status: New
>

Note that if we're talking about Unity in Natty, I believe that this
simply because the Trash icon is either not translatable or not yet
translated (Natty translations are not yet open, and the first language
packs will be released around Alpha 1)

Vish (vish) wrote :

Unity is already tracked in Bug #646669 .
Transmission is Bug #653529

Changed in unity (Ubuntu):
status: New → Invalid
Changed in transmission (Ubuntu):
status: Fix Committed → Invalid
Vish (vish) on 2010-11-30
description: updated
Changed in gnome-common:
status: Incomplete → Expired
Changed in gnome-user-docs:
status: Incomplete → Expired
Greg A (etulfetulf) wrote :

I've reported two new bugs:
Unity at Bug #773037
Nautilus at Bug #773039

Changed in ubuntu-manual:
status: Fix Committed → Fix Released
Displaying first 40 and last 40 comments. View all 116 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.