Gedit - default file name is "unsaved document"

Bug #401692 reported by Arkadiusz Piekarz
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Bilal Akhtar
gedit
Fix Released
Wishlist
gedit (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Default name for a file created in Gedit is "unsaved document". This becomes strange when a person like me saves a couple of files without changing the default title and when he comes back to them he sees "unsaved document 1", "unsaved document 2" and so on, even though those document have been saved on the disk. This is unintuitive for new users.

In my opinion, a name "text document" would better fit such files as a default title.

Related branches

Revision history for this message
Vish (vish) wrote :

Maybe "New document" would be more appropriate.

Changed in hundredpapercuts:
status: New → Confirmed
Revision history for this message
Glennz nl (glenn-de-groot) wrote :

Unnamed document would be better

Vish (vish)
Changed in hundredpapercuts:
importance: Undecided → Low
status: Confirmed → Triaged
Revision history for this message
Andrew (and471) wrote :

Or Untitled Document, this is what a lot of other projects (FOSS and proprietary) use

Revision history for this message
lawal (talktolawal) wrote :

Untitled Document

Revision history for this message
Arvind S Raj (arvindsraj-deactivatedaccount) wrote :

I agree with "Untitled Document' and have created a patch for this. Looks better than "Unsaved Document" too. What do you think? It's a patch for lucid's gedit package since it's currently under development.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gedit (Ubuntu):
importance: Undecided → Wishlist
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Revision history for this message
Sebastien Bacher (seb128) wrote :

the new suggestion would create confusion in the case where you would save the document without changing the naming for example, it also could confuse users about documents which have a name, should the title be changed when those are edited to reflect they are not stored too?

Revision history for this message
Arvind S Raj (arvindsraj-deactivatedaccount) wrote :

Sebastien sorry but your comment made no sense to me. Could you please explain it?

tags: added: gedit
tags: removed: gedit
Angel Abad (angelabad)
Changed in gedit:
importance: Undecided → Unknown
status: New → Unknown
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Thanks for linking the upstream report

Changed in gedit (Ubuntu):
status: New → Triaged
David Futcher (bobbo)
tags: added: patch-forwarded-upstream
Vish (vish)
Changed in hundredpapercuts:
milestone: none → maverick-round-2-mail+office
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gedit - 2.30.3-0ubuntu3

---------------
gedit (2.30.3-0ubuntu3) maverick; urgency=low

  * debian/patches/11_lp_401692.patch:
    - Default name of a new document is now 'Untitled Document'. (LP: #401692)
 -- Bilal Akhtar <email address hidden> Mon, 26 Jul 2010 08:50:38 +0530

Changed in gedit (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Vish (vish) wrote :

Fixed in Maverick

Changed in hundredpapercuts:
assignee: nobody → Bilal Akhtar (bilalakhtar)
status: Triaged → Fix Released
Changed in gedit:
importance: Unknown → Low
status: Unknown → New
Revision history for this message
jpfle (jpfle) wrote :

Where can we translate the new default tab title? It's in English ("Untitled Document") in my French system (Ubuntu 10.10).

Revision history for this message
Sebastien Bacher (seb128) wrote :

it has been translated there:
https://translations.edge.launchpad.net/ubuntu/maverick/+source/gedit/+pots/gedit/fr/195/+translate

but after the current langpack export, it should be fixed between the rc image and the stable one with the next langpacks updates

Changed in gedit:
importance: Low → Wishlist
status: New → Confirmed
Changed in gedit:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.