Make the generic timezone map look like the 9.04 installer timezone map

Bug #398056 reported by Matthew McGowan on 2009-07-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
evolution (Ubuntu)
Wishlist
Unassigned
gnome-system-tools (Ubuntu)
Wishlist
Unassigned

Bug Description

As of 9.04, Ubuntu uses an attractive and IMHO more functional timezone map in its LiveCD installer [1].

A number of default GNOME apps/config-apps use the _old_ timezone map, i.e. Evolution and the Time and Date Settings app [2].

Ubuntu should work with upstream to get its new timezone widget standardized and incorporated into all GNOME default apps that make use of the old timezone map.

_______
1. http://news.softpedia.com/newsImage/Ubuntu-9-04-Alpha-6-Screenshot-Tour-2.jpg/
2. http://www.novell.com/documentation/evolution/evolution/graphics/evo_timezone_a.png

Changed in evolution (Ubuntu):
status: New → Confirmed
Changed in evolution (Ubuntu):
importance: Undecided → Wishlist
Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Wishlist
assignee: nobody → Robert Ancell (robert-ancell)
Milan Bouchet-Valat (nalimilan) wrote :

Robert: Do you know how you will implement this? I'd really like to get these changes upstream as well, instead of keeping an Ubuntu-specific patch. One of the problems I can think of is that I'm not sure time-admin and the installer use the same locations list, because time-admin only shows one point for every time zone, ignoring big cities that don't have their own zone.

Robert Ancell (robert-ancell) wrote :

Milan, I have not looking into detail about what is required to implement this but yes, it would be posted upstream as a patch.

Milan Bouchet-Valat (nalimilan) wrote :

Note that the current implementation uses the EMap widget from Evolution - you may want to have a look at this app too. ;-)

Omer Akram (om26er) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue , in the default Ubuntu 9.10 install , that affects many people and is quick and easy to fix. So this bug can't be addressed as part of the project.

For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Don't worry though, This bug has been marked as "invalid" ONLY in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
Changed in gnome-system-tools (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
Jörg Frings-Fürst (jff-de) wrote :

Bug from 2009. Version not longer supported.
Change status to Invalid (see gnome-bugs)

Changed in evolution (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-system-tools (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers