Drag-and-Drop behavior in the menu editor is inconsistent and confusing

Reported by Wes M on 2009-07-05
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Alacarte Menu Editor
New
Low
One Hundred Papercuts
Low
Mathieu Trudel-Lapierre
alacarte (Ubuntu)
Low
Unassigned

Bug Description

When reordering an item in the Gnome Main Menu (System > Preferences > Main Menu), the end position of the item you're dragging is completely different depending on whether you're dragging it up or down. If you're dragging it up from its original position, it's placed at the line it was dropped on, pushing other items down. When you're dragging an item down, though, it takes the space directly below the line you drop it on, pushing other items up. There are two ways this could easily be fixed:

1 - Place all menu items exactly where they're dropped, and push other items down, no matter which direction you're dragging.

2 - Reorder menu items as the item is being dragged, so the user can see the results of moving the item before placing it.

Related branches

Changed in alacarte:
status: Unknown → New
summary: - Drag-and-Drop Behavior in Main Menu Items is Inconsistent and Confusing
+ Drag-and-Drop behavior in the menu editor is inconsistent and confusing
Richard Liebscher (r1tschy) wrote :

Hi,
Here is a patch, which insert the menu items right after dropping.
This is my first patch. I hope my patch can help to fix the bug.

Wes M (wesm9787) wrote :

@Richard: I like the immediate feedback that your patch adds to the menu editor. It's a definite improvement, but It doesn't really solve the problem of where the items get placed once you drop them. If you open the Menu Editor and drag an item up or down, you'll notice a black line that appears when you hover between any two items. The placement of the line implies that when you drop the item, it will be placed in between those other two items, but if you're dragging downward the item directly below gets pushed up and the item you were dragging is placed below the line. When you drag an item down, the item should be placed above the black line, not below it. Dragging an item up behaves as expected, though. I'm attaching an image that demonstrates what I'm talking about just to clear up any confusion.

Richard Liebscher (r1tschy) wrote :

@Wes M: My patch fixes exactly what you have explained. :) Here the other bug report with a similar patch: http://bugzilla.gnome.org/show_bug.cgi?id=585807

Wes M (wesm9787) wrote :

@Richard: I must have done something wrong then because I'm still having the same problem in Jaunty 64-bit. I downloaded the source code for alacarte, moved the patch file into the source code folder, and applied the patch (patch -p0 < MenuEdit.patch). It said that the patch was successfully applied, so I compiled and installed it (./configure && make && sudo make install). After that I logged out, then logged back in and opened up the Menu Editor to test the patch. Is there something else I needed to do?

Richard Liebscher (r1tschy) wrote :

@Wes M: "make install" installs in /usr/local/ please use ./configure --prefix=/usr && make && sudo make install (don't worked for me).
Better is to patch the file directly. It is located in /usr/share/pyshare/Alacarte.

Wes M (wesm9787) wrote :

@Richard: I patched the file in /usr/share/pyshared/Alacarte and it works exactly as expected now. Thank you for your help, and hopefully the patch will make its way into the next release.

Changed in alacarte (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Vish (vish) on 2009-07-18
Changed in hundredpapercuts:
status: New → Confirmed
Antti Kaihola (akaihola) wrote :

I can confirm that Richard's patch fixes the issue on Lucid with alacarte 0.12.4-1ubuntu1.

Reassigning to bgo 608221 since the previous (bgo 585807) seems to have been marked Resolved even though we can clearly confirm it wasn't (or that there is a regression).

The attached debdiff applies Richard's patch which corrects the issue.

Changed in alacarte:
status: New → Unknown
Vish (vish) on 2010-01-27
Changed in hundredpapercuts:
importance: Undecided → Low
status: Confirmed → Triaged
Vish (vish) on 2010-06-11
Changed in hundredpapercuts:
milestone: none → maverick-round-8-potpourri
David Stansby (dstansby) on 2010-07-24
tags: added: patch-forwarded-upstream
Changed in alacarte:
importance: Unknown → Low
status: Unknown → New
Chris Halse Rogers (raof) wrote :

Robert: thanks for your work here!

I've provided a (non-Alacarte developer) review of the patch on the bug upstream; the patch looks correct and fixes a real bug.

I've also updated the debdiff to apply to the current Natty package, and attached it here.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alacarte - 0.13.2-1ubuntu2

---------------
alacarte (0.13.2-1ubuntu2) natty; urgency=low

  * Correct off-by-one error when dragging an item downward (LP: #395692)
    - added debian/patches/04_lp395692_downward_dragging.patch
 -- Mathieu Trudel <email address hidden> Tue, 26 Jan 2010 23:07:18 -0500

Changed in alacarte (Ubuntu):
status: Triaged → Fix Released
Changed in hundredpapercuts:
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
milestone: maverick-round-8-potpourri → nt7-potpourri
status: Triaged → Fix Released
Alessio Treglia (quadrispro) wrote :

Unsubscribing sponsors team, nothing for us here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.