Synaptic/Update manager show weird download dialogue towards end of download

Bug #393358 reported by Vish on 2009-06-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
Software Updater
Invalid
Undecided
Unassigned
Nominated for Main by Vish
synaptic
Fix Released
Undecided
Unassigned

Bug Description

To note this bug:

1: Select update / install any package
2: The initially when the download begins the dialogue is "Download rate: XX Kb/s - X secs remaining"
3: After the timer counts down to 1 sec , the the next dialogue is " Download rate: unknown "
 This makes no sense.

Even though this flashes for a few secs , this last dialogue should read " Almost done " or anything likewise.

This is also the same behavior in Karmic as of the latest update.

Vish (vish) on 2009-06-29
description: updated
Vish (vish) on 2009-07-24
Changed in hundredpapercuts:
status: New → Confirmed
Vish (vish) wrote :

mpt , Can this be fixed in the new update-manager designs?

Changed in hundredpapercuts:
assignee: nobody → Matthew Paul Thomas (mpt)
status: Confirmed → Triaged
Vish (vish) on 2009-08-20
Changed in hundredpapercuts:
milestone: none → round-10

Not a paper cut, as this the projects affected are being replaced by App Center.

Changed in hundredpapercuts:
milestone: round-10 → none
status: Triaged → Invalid
Vish (vish) wrote :

David Siegel , no , synaptic by karmic+1 , and update manager probably by karmic+2.

Software Store is replacing only Add/Remove for Karmic. [mpt , if i'm mistaken , pls invalidate this papercut.]

Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → round-10
status: Invalid → Triaged

mac_v, will you please provide a screenshot of this weird dialog?

Changed in hundredpapercuts:
status: Triaged → Incomplete
Vish (vish) wrote :

Screenshot of the Present dialogue.
Note the Download rate says> "unknown"

Changed in hundredpapercuts:
status: Incomplete → Triaged
Changed in synaptic:
status: New → Confirmed
Changed in update-manager:
status: New → Confirmed
Changed in hundredpapercuts:
milestone: round-10 → r2
Luke Symes (allsymes) wrote :

I propose we change the text from the current "Download rate: unknown" to "Waiting". Attached is a patch to this effect, however I'm not sure how to go about updating the .pot & *.po translation files.

Vish (vish) wrote :

@Luke Symes :

"Download rate: Waiting" would not make sense.

Why not just leave them as "..." or "---" ? no need translating for these ;)

Luke Symes (allsymes) wrote :

True, "..." could work well. But in the previous patch I didn't have "Download rate: waiting", it was *just* "Waiting". Perhaps that would be too jarring in the dialog to see "Download rate: #KB/s" change suddenly to "Waiting". Added a patch that uses your suggestion.

Vish (vish) on 2010-02-12
tags: added: patch
Michael Vogt (mvo) wrote :

I merged this into "lp:~mvo/synaptic/ubuntu-ui-changes" as its a string change and we require a UI freeze exception for this. This branch is meant to accumulate the UI changes so that we can just send one exception request out.

Changed in synaptic:
status: Confirmed → In Progress
Vish (vish) wrote :

Unsubscribing review team , as mvo mentions patch has been accepted and will land in Maverick

tags: added: patch-accepted-upstream
removed: patch
Changed in synaptic:
status: In Progress → Fix Committed
Vish (vish) wrote :

Not a bug in update manager

Changed in update-manager:
status: Confirmed → Invalid
Vish (vish) on 2010-06-11
Changed in hundredpapercuts:
assignee: Matthew Paul Thomas (mpt) → nobody
milestone: lucid-round-2 → maverick-round-8-potpourri
Vish (vish) wrote :

lp:~mvo/synaptic/ubuntu-ui-changes was merged and released in Maverick

Changed in synaptic:
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments