Unable to disable GDM login sound in sound preferences

Bug #392484 reported by oheohe on 2009-06-26
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
gnome-control-center (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Most users coming from a windows background or users without any deeper knowledge about the different steps the OS is taking to the final desktop will look directly at the sound options if they want to switch those effects off.

They will be disappointed when changing everything to no sound has no effect on the login ready sound. A direct link to the right place in the generell audio would be really helpful.

Przemek K. (azrael) on 2009-06-26
summary: - Disable sound at login-stage
+ Unable to disable GDM login sound in sound preferences
tags: added: usability
Vish (vish) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?
 * Does this fit the papercut criteria? If so, How?

 This will help us to find and resolve the problem.

A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

 For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Changed in hundredpapercuts:
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

the gnome-control-center dialog set user preferences not system settings

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Invalid
oheohe (ohefan) wrote :

Yes, of course it's reproducible. It's a simple question of usability - and it's something any user that dislikes system sounds will encounter. No newbie or average user will look for something sound-related in a dialog about login-screens.

 You've got similar functionality scattered to two different placed. The reason for simple from a purely technical perspectiv, as it concerns different steps in the start-up progress. However, this has no relevance for the average user - he doesn't know about gdm and gnome, he only thinks of his system as a holistic unit.

The use-case "User wants to turn off all sounds after a fresh install" is quite common. Especially on mobile computers. Being in a library without turning ALL system sounds off in advance can be quite embarrassing. So he looks for suitable items - sound preferences will be the place he looks to. Easily accessible - in contrary to the hidden option for disabling the GDM-sound. You will find matching questions in all mayor ubuntu forums.

Therefore, this is clearly a usability problem. It can be fixed easily, all users are 'affected', use-case common, and it can get a nuisance. Qualifies for a paper cut.

oheohe (ohefan) wrote :

>Sebastien Bacher wrote:
>the gnome-control-center dialog set user preferences not system settings

You are right - that's the core of the problem. But I'm afraid you a wrong in your conclusion that this has anything to do with the problem. We are talking usability here - even if you where right, this system setting won't be looked for under 'Accessibility'. So that's no solution at all.

Usability has nothing to do with technical thinking. Believe me, average users won't distinguish between user- or system settings. Therefore a better approach is needed, regardless of technical borders between settings of different levels.

Przemek K. (azrael) wrote :

I think a Policykit-enabled setting should be added to the Sound preferences applet to enable users to modify the GDM's sound settings from the same place as other sounds.

Sebastien Bacher (seb128) wrote :

gdm will be replaced by the new codebase this cycle and the sounds capplet with the new pulseaudio dialog too

Vish (vish) wrote :

As per Sebastien's comment

Changed in hundredpapercuts:
status: Incomplete → Invalid
Paul Sladen (sladen) wrote :

Marking this for 100papercuts to save re-filing it.

Changed in hundredpapercuts:
status: Invalid → Confirmed
Vish (vish) wrote :

@Paul Sladen:
It *is* possible disable login sounds in karmic.
The "alert volume" in the sound preferences can be used to reduce or mute the login sounds , but the specific option for login sounds is not present.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers