Tooltip of the Nautilus search button is misleading

Bug #392292 reported by Zelena on 2009-06-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Low
One Hundred Papercuts
Undecided
Jean-Louis Dupond
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

In the tooltip of the search button of the file browser it says: "Locate documents and folders on this computer by name or content." But it searches only files by name, not by content.

Suggestion 1 (Papercut):
Change the tooltip of the search button to "Locate documents and folders on this computer by name. Look under the menu "Places" - "Search for files" for advanced search."

Suggestion 2 (Optimal) :
Make the default search for files to search on the file and the content. Besides the search bar show a possibility to select more options, e.g. a button "Advanced Search".

-----------------[old description]-------------
Search on the file system does not look in the file content, but only in the file name. E.g. if there is a file with the name abc.txt and the content "I like gnome" and if you search for "gnome", then no results are found. If you search for "abc", the file abc.txt is found.

Related branches

Vish (vish) wrote :

Thank you for bringing this bug to our attention. Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project.

This is a feature already exists,
to access this:From Places menu > search for files > In the search window , "select more options" has this feature.

A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Don't worry though, This bug has been marked as "invalid" ONLY in the papercuts project.

If you feel that this search feature does not work properly,
For resolution of the bug, kindly identify the projects affected and assign the bug to that project, otherwise the devs of the concerned project might not be notified of this problem.

Changed in hundredpapercuts:
status: New → Invalid
Zelena (lvukelja) wrote :

In the tooltip of the search button of the file browser it says: "Locate documents and folders on this computer by name or content." But it searches only files by name, not by content.

Suggestion 1 (Papercut):
Change the tooltip of the search button to "Locate documents and folders on this computer by name. Look under the menu "Places" - "Search for files" for advanced search."

Suggestion 2 (Optimal) :
Make the default search for files to search on the file and the content. Besides the search bar show a possibility to select more options, e.g. a button "Advanced Search".

Updated the description , From the OP's latest comment.

This is a perfect example of a papercut.

description: updated
summary: - Search does not look in the file content, but only in the file name
+ Tooltip of the search button[nautilus] is misleading
Changed in hundredpapercuts:
status: Invalid → Confirmed
Vish (vish) on 2009-06-28
description: updated
Changed in hundredpapercuts:
milestone: none → round-2
Jean-Louis Dupond (dupondje) wrote :

Ok i'm going to fix this 'bug' together with making the Search button a toggle button

Changed in hundredpapercuts:
assignee: nobody → Jean-Louis Dupond (dupondje)
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

The bug should be easy to fix, the change needs to consider that nautilus optionally use tracker or beagle and search for content is such cases

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the bug and the change need to be sent to bugzilla.gnome.org too

Vish (vish) wrote :

@Zelena: it would be nice if somebody having this problem could send the bug the to the people writing the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Zelena (lvukelja) wrote :

Seems that the bug has already been resolved: http://bugzilla.gnome.org/show_bug.cgi?id=332078

Jean-Louis Dupond (dupondje) wrote :

@Zelena: Well its fixed in that patch, but didn't look @ "the change needs to consider that nautilus optionally use tracker or beagle and search for content is such cases" yet :)

Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Changed in nautilus:
status: Unknown → New
Zelena (lvukelja) wrote :

@Jean-Louis Dupond: What should I write in the ticket for gnome? I don't understand the issue completely, so I'm not sure what to write such that they understand what the problem is.

summary: - Tooltip of the search button[nautilus] is misleading
+ Tooltip of the Nautilus search button is misleading
Changed in nautilus:
status: New → Confirmed
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
ErMejo (andrea-lombardoni) wrote :

This problem remains in Ubuntu 9.10.

In a Nautilus window the search button tooltip is:
"Locate documents and folders on this computer by name or content"

But clicking on it only reveals the interface to search documents and folders by name.

hai gia' controllato... bravo!

:* :*

________________________________
Von: ErMejo <email address hidden>
An: <email address hidden>
Gesendet: Montag, den 2. November 2009, 23:34:34 Uhr
Betreff: [Bug 392292] Re: Tooltip of the Nautilus search button is misleading

This problem remains in Ubuntu 9.10.

In a Nautilus window the search button tooltip is:
"Locate documents and folders on this computer by name or content"

But clicking on it only reveals the interface to search documents and
folders by name.

--
Tooltip of the Nautilus search button is misleading
https://bugs.launchpad.net/bugs/392292
You received this bug notification because you are a direct subscriber
of the bug.

Status in One Hundred Paper Cuts: In Progress
Status in Nautilus: Confirmed
Status in “nautilus” package in Ubuntu: Triaged

Bug description:
In the tooltip of the search button of the file browser it says: "Locate documents and folders on this computer by name or content." But it searches only files by name, not by content.

Suggestion 1 (Papercut):
Change the tooltip of the search button to "Locate documents and folders on this computer by name. Look under the menu "Places" - "Search for files" for advanced search."

Suggestion 2 (Optimal) :
Make the default search for files to search on the file and the content. Besides the search bar show a possibility to select more options, e.g. a button "Advanced Search".

-----------------[old description]-------------
Search on the file system does not look in the file content, but only in the file name. E.g. if there is a file with the name abc.txt and the content "I like gnome" and if you search for "gnome", then no results are found. If you search for "abc", the file abc.txt is found.

Changed in hundredpapercuts:
milestone: round-2 → r2
black (blackborn) on 2009-11-25
Changed in hundredpapercuts:
status: In Progress → Fix Committed
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.29.1-0ubuntu1

---------------
nautilus (1:2.29.1-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - Make browser mode the default
    - Add split view mode
    - Browser UI reorganization
    - Better background support on multi-monitor setups
    - Support new "default location" on mounts
    - Add extension api to lookup NautilusFileInfo objects
    - Make the search toolbar button a toggle button (lp: #57210, #392292)
    - Change text selection when using f2 several times (lp: #55996)
    - Ctrl+shift does multiple range selection in list view (lp: #148297)
    - Correctly toggle the show hidden files option (lp: #318151)
    - Opening of unknown files types displays a list of softwares (lp: #435780)
    - Fix the end key action in the image details (lp: #448786)
    - Use correct Borders for the sidebar (lp: #380838)
    - Display tooltips over sidebar bookmarks (lp: #432485)
  * debian/control.in:
    - updated gnome-desktop requirement
  * debian/nautilus-data.gconf-defaults:
    - don't set browser mode there since that's upstream default now
  * debian/patches/01_manpage.patch:
    - the change is upstream now
  * debian/patches/91_correct_rgba_use.patch:
    - change by Cody Russell to fix rgba issue (lp: #491521)
  * debian/rules:
    - updated shlib version
 -- Sebastien Bacher <email address hidden> Wed, 06 Jan 2010 17:14:33 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) on 2010-01-06
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
X I (xandrani) wrote :

Nautilus is indeed documented to search the contents of files but doesn't.

Also there is no Places > Search for Files... (was that a suggestion or is that how it's supposed to work).

I think the Ubuntu team should be split in to teams, i.e. UI designers / programmers / testers / document authors etc. When programmers start "designing" UI's things normally go horribly wrong... no offence but designing user interfaces WELL is actually very difficult, although everyone thinks they can do it... so much so that it took Microsoft years to even start to get close. One example of people's incorrect perception of how easy it is to design UI's is the fact that most people think they can design websites... when in fact hardly anyone can!

Not everyone is a designer... people need to start focusing on their strengths and ONLY their strengths. When people go outside their area of knowledge then shit happens! lol... like if I tried cutting someone's hair it would be disastrous!!! The open source community need to start getting their act together with this. Even though it IS volunteers surely everyone wants to design better products?

Changed in nautilus:
importance: Unknown → Low
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.