"Unread Messages" icon is difficult to distinguish from default icon

Bug #392265 reported by Bradison on 2009-06-25
100
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Humanity
Undecided
Unassigned
One Hundred Papercuts
Low
Unassigned
humanity-icon-theme (Ubuntu)
Undecided
Unassigned

Bug Description

It would really be nice if the "New Mail" icon in the notification area looked more distinct from the default icon. Right now, the only difference on a Jaunty installation is a yellow star, which looks far too similar on the default white panel background. More contrast between the two icons would be great.

The bug attachment shows the default icon, the new mail icon, and a modified version that I currently use. It's not pretty, but it's obvious from across the room that you have mail and can serve as an example to illustrate the issue.
-------
For Related discussion of the present icon and why color is not used for the new message , pls read Bug #450398

summary: - [Jaunty] E-mail icon for "new mail" in notification area is too visually
+ [Jaunty] Icon for "new message" in indicator-applet is too visually
similar to default icon

Sorry, this is a theme problem, and nothing to do with indicator-applet.

Changed in indicator-applet (Ubuntu):
status: New → Invalid
summary: - [Jaunty] Icon for "new message" in indicator-applet is too visually
- similar to default icon
+ Indicator-applet icon for "new message" is too visually similar too the
+ default icon

I believe the icon is clear with Humanity icons[which is mostly probably the default icon in Karmic].

@OP: Kindly test it out and report back if you still feel this is not clear

Changed in humanity:
status: New → Fix Released
Changed in hundredpapercuts:
status: New → Confirmed
Vish (vish) on 2009-07-24
Changed in hundredpapercuts:
status: Confirmed → Fix Committed
Changed in hundredpapercuts:
status: Fix Committed → Confirmed

I don't see any difference between indicator applet states. Please, don't just use another color, change the whole icon else!

Caleb (caleb-marcus) wrote :

In Humanity, it just changes from barely-there-gray to somewhat-there-gray... I don't think this is sufficient.

Nicolò Chieffo (yelo3) wrote :

Fix released where? I'm using bzr and the only thing that changes is the color which is a bit darker.
You should definitely add something else like a star or a * to indicate that something is pending

Changed in humanity:
status: Fix Released → Confirmed
Ted Gould (ted) on 2009-09-25
affects: indicator-applet (Ubuntu) → humanity-icon-theme (Ubuntu)
Changed in humanity-icon-theme (Ubuntu):
status: Invalid → Confirmed
Vish (vish) wrote :

Fixed in rev 306

Changed in humanity:
status: Confirmed → Fix Released
Changed in humanity-icon-theme (Ubuntu):
status: Confirmed → Fix Committed
Vish (vish) on 2009-09-25
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → round-10
status: Confirmed → Fix Committed
Luca Ferretti (elle.uca) wrote :

The attachment shows the current status on karmic... Do you really think it's simple to quickly visually check it there are new messages (for example after a coffee break)? The previous envelope+star was more effective.

If you have to keep the monochrome gray, then you could make the "new message" an inverted "no message" (see proposed on attached screenshot)

Instead I would remove the black border and only keep the black envelope.
Anyway your proposal is the current default

@Luca Ferretti:

Unless I am missing something, your mockup is exactly the same icon that's in trunk

Proof: http://bazaar.launchpad.net/~elementaryart/humanity/Humanity/download/head%3A/indicatormessagesnew-20090820174107-a47ojvaafcpnbgug-1/indicator-messages-new.svg

I honestly think it's not visible enough, but if devs want to stick with monochrome-only it's hard to think something better.

I still think a red envelope would make more sense (see the attached screenshot).

As the originator of this bug, I want to log a few comments.

I do not believe the current proposed solution addresses the issue. The difference between a gray icon and slightly bolder version is still too similar. It's actually worse that the Jaunty release in my opinion. In all fairness, I'm just commenting on the screenshots and images, not the actual beta.

Is there a reason that some color cannot be used? The version in Jaunty had a yellow star, so it appears that color was acceptable in past releases.

I think the inverted icon comes much closer to achieving the desired effect, but in my opinion color would be preferable. I think the old star might even work if it were not pale yellow.

There might be design guidelines that I am not aware of for this release. If there are, certainly within those constraints it should be possible to make a visually distinct icon notifier.

I'm not a graphics person, otherwise I would submit some more ideas. Judging from the comments above, it appears that the currently proposed solution still needs work.

Loïc Minier (lool) wrote :

Are the icons in the humanity-icon-theme package in my ppa (ppa:lool/ppa) good enough? They are from end of last week and what I intend to push to karmic this week if possible.

Vish (vish) wrote :

Loic Minier, Yes. nothing more will be done for those icons.
Color is not allowed , so those are the final icons.

Nicolo:
I'v first tried as you have described , but that doesnt look good ;)

Nicolò Chieffo (yelo3) wrote :

Since I really don't like the current icon I will try another proposal

Vish (vish) wrote :

Fixed in humanity-icon-theme (0.4.1-0ubuntu1) karmic

Changed in humanity-icon-theme (Ubuntu):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Michael (michaeljt) wrote :

I was directed here because I filed a duplicate. I'm personally not too thrilled with the current (presumably final) icons for Karmic. Now that I know what to look for, I definitely notice the difference between new messages and no new messages if I explicitly look, but I actually had to observe the icon after installing Karmic to see that there was a difference, and it is definitely not something that catches the eye if you are not looking for it, and I dread to think how it would work for someone with poor eyesight. (Yes, I know, they can select another theme, but still.)

I'm afraid that I don't have any really good suggestions about how it could be improved, other than perhaps expanding it as far as it will go when there are new messages. (Well, actually I do have a suggestion - to keep a floating "You have new messages" displayed until there aren't any - but I know that that suggestion won't fare very well :) )

Michael, point taken about the Karmic icon not being loud enough to grab your attention. However, I think that's more the purpose of notifications -- the superimposition with application windows, movement, and use of a larger icon are meant to attract your attention. Indicators, on the other hand, should definitely convey information when you look at them, although I am not sure that we would want them loud enough so they attract your attention otherwise. I would hate for users to be unable to ignore indicators; for example, you have unread messages but are trying to focus on writing a document -- would a louder indicator icon begin to irritate you?

summary: - Indicator-applet icon for "new message" is too visually similar too the
- default icon
+ "Unread Messages" icon is difficult to distinguish from default icon
Vish (vish) wrote :

@ David Siegel and anyone interested in this bug : More related discussion of the icon are in Bug #450398.

Damiano Dallatana (damidalla) wrote :

Yesterday I worked for all the afternoon without even knowing there were new messages for me to read, as at a fast glance the small icon is almost the same...

As stated in bug #450825 the new notification icons are not meant to remove all the colors from there, but to use colors to grab the user attention (eg. red for errors and warnings).
Now, I think that when new messages are present and unread, the notification has to grab the user attention: it's what it is meant to do. Obviously, red is not an option, as it would not be a warning, but why can't we use yellow or green for indicator-messages-new icon? With low brightness and saturation, it would still be unobtrusive but could attract the attention of the user interested in knowing if there are new messages.

Vish (vish) on 2009-11-02
description: updated
Alden (jason-alden-benoit) wrote :

I agree with Damiano Dallatana on a color solution, but it was said earlier that color was not allowed. I like the suggestion by Michael of keeping the notification floating (Is it called notify-osd?), at least until it is clicked on if possible. That would work perfectly, at least for me. Make an option if need be.

Sérgio Almeida (mephx-x) wrote :

Indicator applet can be made a great tool. If it really indicates anything... It should not be difficult to send a notification balloon from time to time (1min) with a full report on what notifications does the user have? (I might even code this in the meanwhile...) Why is the indicator only used for mail and IM when it can also be used for other notifications like updates, errors, crashes, reports. Also i guess i'm not the only one who would love also having RSS notifications from evolution in the indicator too...

Dmik (dmik-for-maillists) wrote :

My 5 cents: the current (karmik) indication of the new messages in the indicator applet doesn't do its job here. The peripheral vision doesn't register any difference when a new message comes up. This is especially true if you select some dark theme like New Wave. This is even more true if you have a modern notebook (most of which are TN-film as far as I know) which is very sensitive to angles so that starting with some position light gray and dark gray just look the same. I was constantly missing notifications from Empathy and some people even got mad at me for the silence :) so I had to switch back to Pidgin with its big flashing smile.

My vote is that the icon should be flashing or jumping or glowing or such. The peripheral vision is much more sensitive to the dynamics than to the statics (here http://en.wikipedia.org/wiki/Troxler%27s_fading you will find some interesting info about that).

BTW adding good dynamics may let keep the current monochrome look and feel the developers are so picky about without negatively affecting the function.

Michael (michaeljt) wrote :

I don't think that this is properly fixed in Karmic.

Changed in hundredpapercuts:
status: Fix Released → Confirmed
Vish (vish) wrote :

Michael , there are plans to expand the icons used by the indicator applet for Lucid.

Changed in hundredpapercuts:
status: Confirmed → Fix Released
Dmik (dmik-for-maillists) wrote :

mac_v, sorry for breaking in again, but could you please ask the respective developers to look at #485959 in case if they haven't already done so?

Michael (michaeljt) wrote :

Vish, you said that this was due to be reworked for Lucid. My current feeling though is that this is worse in Lucid. I don't know if it is because of the darker colours used in the default theme, or because the floating notifications are no longer shown (is that intentional?) What is supposed to have changed here?

Michael (michaeljt) wrote :

And indeed I agree with bug #485959 - I was on the point of writing something similar too, just before I read it.

Vish (vish) wrote :

@Michael : The icon was fixed in Humanity and will be fixed in ubuntu-mono as well > https://lists.launchpad.net/ayatana/msg01040.html

So hang tight ;-)

Anders Nor Berle (berle) wrote :

In 12.04, using Pidgin, I often miss incoming IM messages which can sometimes be quite frustrating. So if anyone is interested, I changed the behavior of indicator-messages to blink its icon instead of merely change colors. I packaged the change and put it in a PPA, using it only requires you to add the ppa, and do an update + upgrade.

https://launchpad.net/~berle/+archive/blinking

Now for some motivation behind this change: I acknowledge that the ideal solution is for the launcher icon of pidgin to communicate this somehow, but it currently doesn't and changing indicator-messages was a lot easier than changing pidgins interaction with the launcher.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers