'Clean Up by Name' -> "Organize Desktop by Name"

Reported by VA on 2009-06-18
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Low
One Hundred Papercuts
Low
Marcus Carlson
nautilus (Ubuntu)
Wishlist
Unassigned

Bug Description

On right click on Desktop an Option of 'Clean Up by Name' would probably be interpreted closer to 'delete by...'. 'Arrange by Name' would do the trick.

Related branches

Lightbreeze (nedhoy-gmail) wrote :

Personally I think Arrange by Name sounds more like it is an option to _keep_ icons arranged by name, like Bug #20284. Which I think is a good idea.

"Clean up by name" sounds like a one time action, which is confusing because the menu item is a checkbox. "Arrange by name" gives a better idea of what the effect will be, because the desktop icons will be arranged, not cleaned per se. Even better "Keep arranged by name" makes the effect clear, and agrees with the semantics of the checkbox.

Changed in hundredpapercuts:
status: New → Confirmed
Changed in nautilus:
status: Unknown → New
Changed in hundredpapercuts:
milestone: none → round-10
Bryce Harrington (bryce) wrote :

Change as per comment #2.

Changed in hundredpapercuts:
assignee: nobody → Bryce Harrington (bryceharrington)
status: Confirmed → In Progress
Changed in hundredpapercuts:
milestone: round-10 → round-1

Bryce, I didn't realize that the "Clean up by Name" entry is not a checkbox, so it should be interpreted by the user as an action rather than a persistent state setting. I suggest "Arrange Items by _Name", but I will try to get more feedback on this.

dino99 (9d9) wrote :

My 2 cents:

Maybe : sort by (name, frequent used, size, ...)

Vish (vish) wrote :

"Arrange Items by Name" is a good option.. +1 for this...

Bryce Harrington (bryce) wrote :
Sorpigal (sorpigal) wrote :

Perhaps it should say "Rearrange Items by Name" which might reduce confusion over whether it was a persistent state setting.

vhellmet (vhellmet) wrote :

Also, it'd be wonderful if the icons rearranged by themselves whenever a drive was unmounted or mounted.
What usually happens is that a new drive icon places itself on top of an existing icon.
Existing drive icons leave an empty space when drives are unmounted.

Vish (vish) on 2009-08-10
Changed in hundredpapercuts:
assignee: Bryce Harrington (bryceharrington) → Marcus Carlson (0-launchpad-mejlamej-nu)
Bryce Harrington (bryce) on 2009-08-10
Changed in hundredpapercuts:
assignee: Marcus Carlson (0-launchpad-mejlamej-nu) → nobody
Vish (vish) on 2009-08-10
Changed in hundredpapercuts:
assignee: nobody → Bryce Harrington (bryceharrington)
status: In Progress → Fix Committed
Michael Rooney (mrooney) wrote :

Okay, since there is a patch needing review that isn't actually committed anywhere, I'll adjust the status. Let me know if it is wrong :)

Changed in hundredpapercuts:
assignee: Bryce Harrington (bryceharrington) → nobody
status: Fix Committed → Triaged

Has anyone started the discussion on the mailing list as upstream wanted? Also, maybe posting the patch upstream could help...

Vish (vish) wrote :

David , this simple bug has stalled due to lack of discussion on the nautilus mailing list as per upstream comments http://bugzilla.gnome.org/show_bug.cgi?id=530136#c1

Someone from the design team needs to bring this up in the mailing list
> http://mail.gnome.org/mailman/listinfo/nautilus-list

Changed in hundredpapercuts:
assignee: nobody → David Siegel (djsiegel)
Changed in hundredpapercuts:
status: Triaged → In Progress
Changed in hundredpapercuts:
milestone: round-1 → r1
avdzm (alecos85) wrote :

Arrange by name makes more sense.
At first i thought it would remove icons that i hardly used, until i read 'by name'.

Changed in hundredpapercuts:
assignee: David Siegel (djsiegel) → Canonical Desktop Team (canonical-desktop-team)
Sebastien Bacher (seb128) wrote :

why did you assign the bug to the canonical desktop team there? that doesn't seem a high priority issue...

Changed in hundredpapercuts:
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Martin Pitt (pitti) on 2009-12-01
Changed in hundredpapercuts:
assignee: nobody → David Siegel (djsiegel)
Vish (vish) on 2010-02-12
Changed in hundredpapercuts:
importance: Undecided → Low

Removed from the Lucid milestone for paper cuts. It's very low priority.

Changed in hundredpapercuts:
status: In Progress → Invalid
milestone: lucid-round-1 → none
status: Invalid → Confirmed
Vish (vish) on 2010-06-10
Changed in hundredpapercuts:
assignee: David Siegel (djsiegel) → nobody
milestone: none → maverick-round-1-file-management
status: Confirmed → Triaged
Changed in nautilus (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Changed in nautilus:
status: New → Confirmed
Vish (vish) wrote :

This has now been fixed upstream. Its been changed to "Organize Desktop by Name"

Changed in hundredpapercuts:
assignee: nobody → Marcus Carlson (0-launchpad-mejlamej-nu)
status: Triaged → Fix Committed
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
summary: - 'Clean Up by Name' -> 'Arrange by Name'
+ 'Clean Up by Name' -> "Organize Desktop by Name"
Sebastien Bacher (seb128) wrote :

is the change worth backporting to our version this cycle and breaking the translations?

Changed in nautilus:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.30.1-1ubuntu2

---------------
nautilus (1:2.30.1-1ubuntu2) maverick; urgency=low

  * Backport upstream changes
  * debian/patches/git_correct_delay_logic.patch:
    - git change to fix a logic error in the directory loading code which
      create a delay to have some shortcut actions to work after loading
      directory (lp: #390662)
  * debian/patches/git_correct_display_name.patch:
    - correctly display the applications names
  * debian/patches/git_correctly_set_default.patch:
    - correctly set the new default software when this one is changed
      (lp: #550004)
  * debian/patches/git_default_thumbnails.patch:
    - set default thumbnails to 64 for better layouting (lp: #497728)
  * debian/patches/git_browser_title_cleaning.patch:
    - clean the title of the file browser dialogs (lp: #439227)
  * debian/patches/git_clean_by_name_rename.patch:
    - 'Change "Clean Up by Name" to "Organize Desktop by Name"' (lp: #388949)
  * debian/patches/git_double_click_launcher.patch
    - 'Ignore > 2 clicks in the icon container' (lp: #389663)
  * debian/patches/git_ctrlq_close.patch:
    - 'Change 'Close all Windows' shortcut to Ctrl+Q.' (lp: #563226)
  * debian/patches/git_store_session_passwords.patch:
    - store the mounts passwords for the session (lp: #392589)
  * debian/patches/git_no_double_browse_entry.patch:
    - don't list a "browser" menu items in browser mode it's the default
      (lp: #388091)
 -- Sebastien Bacher <email address hidden> Wed, 07 Jul 2010 11:11:29 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) wrote :

Fixed in Maverick

Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in nautilus:
status: Fix Released → Confirmed
Vish (vish) wrote :

The previous patch had a problem ,
we need to drop
* debian/patches/git_clean_by_name_rename.patch

and apply the new one from upstream again.

Changed in nautilus (Ubuntu):
status: Fix Released → Fix Committed
Changed in hundredpapercuts:
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.30.1-1ubuntu4

---------------
nautilus (1:2.30.1-1ubuntu4) maverick; urgency=low

  * debian/patches/git_clean_by_name_rename.patch:
    - updated version to mention only "desktop" on the desktop (lp: #388949)
 -- Sebastien Bacher <email address hidden> Wed, 04 Aug 2010 17:28:08 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) wrote :

Thanks Sebastien for re-uploading this change.

Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in nautilus:
status: Confirmed → Fix Released
Changed in nautilus:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.