Downscrolling should decrease, not increase volume

Bug #387874 reported by Etienne
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
gnome-applets (Ubuntu)
Medium
Unassigned

Bug Description

Scrolling down should decrease volume, while scrolling up should increase it. Scrolling on the volume applet icon in gnome-panel behaves correctly, but if you click the applet and mouse over the slider control and scroll there, it behaves in the opposite fashion.

Only affects 9.04 Jaunty. Fix requested for 9.04 and not subsequent releases.

Revision history for this message
David Siegel (djsiegel-deactivatedaccount) wrote :

Can you please provide more information, I am confused. Maybe screenshots would help.

Changed in hundredpapercuts:
status: New → Incomplete
Revision history for this message
quentindemetz (quentindemetz) wrote :

When you click on the Volume icon on the top panel, a scrollbar appears which you can slide to adjust the volume. But scrolling UP decreases the volume (because scrolling up make the scrollbar go left - normal behavior) and scrolling DOWN increases the volume.
However changing this behavior would be bizarre, considering that in Nautilus scrolling up takes you back up or to the left.... Just providing explanations..

Revision history for this message
Etienne (etienneb35) wrote : Re: [Bug 387874] Re: Downscrolling to increase the sound

Thanks for the answer; I was not able to answer yesterday, sorry for being
late.
I know the normal Nautilus behavior and it sounds like normal for me to
scroll down to go to the right, but for newbes, it sound not logic to scroll
down to decrease the volume : the newbe doesn't consider the cursor itself,
but the effect : down = volume down, up = volume up.
Don't know what kind of user friendly solution could be found, but I think
such problem could be treated in the "100 paper cuts".

Regards,

Etienne

On Wed, Jun 17, 2009 at 8:44 PM, quentindemetz <email address hidden>wrote:

> When you click on the Volume icon on the top panel, a scrollbar appears
> which you can slide to adjust the volume. But scrolling UP decreases the
> volume (because scrolling up make the scrollbar go left - normal behavior)
> and scrolling DOWN increases the volume.
> However changing this behavior would be bizarre, considering that in
> Nautilus scrolling up takes you back up or to the left.... Just providing
> explanations..
>
> --
> Downscrolling to increase the sound
> https://bugs.launchpad.net/bugs/387874
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Lightbreeze (nedhoy-gmail) wrote : Re: Downscrolling to increase the sound

Scrolling over the icon _without_ opening the slider is opposite: scroll up increases volume while scroll down decreases. Personally I think the behavior for the slider is fine, where up = left = decrease, but maybe the two should be made consistent? I think scrolling the icon should bring up the slider as visual feedback, instead of the tooltip.

Revision history for this message
David Siegel (djsiegel-deactivatedaccount) wrote :

Scrolling up should increase volume; scrolling down should decrease volume.

Changed in hundredpapercuts:
status: Incomplete → Confirmed
Revision history for this message
markba (mark-baaijens) wrote :

This problem arises, due to the position of the scroll-bar: horizontal. Before Jaunty, the position was vertical, so operating the slider was very intuitive (up = increase). Hence, this problem could be solved by using the old positioning of the slider (= vertical).

Revision history for this message
roffik (roffik) wrote :

@David Siegel: exactly.
Everywhere else (for example "compact view" in Nautilus) scrolling up will move the content left (as expected).

For me the right side of a horizontal slider equals the top part of a vertical one.

Revision history for this message
roffik (roffik) wrote :

Oh, sorry for my previous comment, I had to be asleep. Only first line is valid. The rest should be completely opposite, but it doesn't change the fact that this bug is an serious usability issue.

I agree with @markba. I was wondering why the applet was changed: now, if I want to disable only for example Line in, I have to click twice, but in different places. I don't care about muting, as I have a button on my keyboard (both laptop and desktop) to do this.

Changed in hundredpapercuts:
milestone: none → round-5
Vish (vish)
summary: - Downscrolling to increase the sound
+ Volume change should be consistent with Scrolling direction
summary: - Volume change should be consistent with Scrolling direction
+ Downscrolling should decrease, not increase volume
Revision history for this message
Michael Rooney (mrooney) wrote :

I can confirm this in an up-to-date Jaunty, I'll test Karmic now and see if it happens to be fixed there.

Changed in gnome-applets (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
description: updated
Revision history for this message
Noel J. Bergman (noeljb) wrote :

In Karmic, the volume control is vertical on the gnome-panel, but in the sound preferences dialog is (still) horizontal.

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

This is not an issue on Karmic, as the mixer-applet is deprecated and we removed it. The replacement (gnome-volume-control) has a vertical slider from the applet, and a horizontal slider in the preferences window, both of which work correctly (scrolling up increases volume)

Changed in gnome-applets (Ubuntu):
status: Triaged → Invalid
Revision history for this message
Michael Rooney (mrooney) wrote :

I can confirm that the new applet addresses this issue in Karmic, so I'll mark it as such!

Changed in hundredpapercuts:
status: Confirmed → Fix Released
Revision history for this message
komputes (komputes) wrote :

For this to be addressed, it should be fixed in 9.04.

Ubuntu 8.10 and 9.10 both use different sound applets so what you are seeing in karmic is not a fix, it is a replacement applet.

This is a very small bug. If you use your scroll wheel on the applet icon it works fine, but if you click the applet icon and then use the scroll wheel on the volume bar, it is reversed (does not work as expected). Up should be Vol+ and down should be Vol- for it to be intuitive to users.

Attached is the requested screenshot.

Changed in hundredpapercuts:
status: Fix Released → Confirmed
Changed in gnome-applets (Ubuntu):
status: Invalid → Confirmed
description: updated
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Confirmed means that the bug still exists in the development release, which is not true. If you think that the bug should be fixed in an earlier release, please use the "Nominate for release" button

Changed in gnome-applets (Ubuntu):
status: Confirmed → Invalid
Changed in hundredpapercuts:
status: Confirmed → Fix Released
Revision history for this message
komputes (komputes) wrote :

> If you think that the bug should be fixed in an earlier release, please use the "Nominate for release" button

@Chris, I would, but I can only nominate this bug for karmic. How do you suggest I make it clear this is a 9.04 bug which is not yet fixed?

Revision history for this message
Vish (vish) wrote :

@komputes :
That's because the gnome-applets is invalid here. Kindly open a separate bug for the Jaunty issue.
This bug has no relevance to the gnome-applets since the applet is deprecated in karmic.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers