update-manager doesn't check if Internet Connection is available

Bug #387382 reported by billytalent on 2009-06-15
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Mohamed Amine Ilidrissi
Software Updater
Fix Released
Undecided
Mohamed Amine Ilidrissi
update-manager (Ubuntu)
Medium
Mohamed Amine Ilidrissi

Bug Description

update-manager doesn't check if Internet Connection is available. When the user clicks on update manager and clicks on "Check". The update-manager should check whether Internet connection is available. Currently update-manager comes back with a whole bunch of source not found errors.. ??

ShawnJGoff (shawn-goff) on 2009-06-18
Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → round-6
MCMic (mcmic) wrote :

There is the same kind of problem with a lot of applications, like almost all XMPP client I tried. (gajim, pidgin, empathy, ...)

This needs a bit more information. Some package sources are offline (users updating from DVDs) so when do we warn that the user is offline? Instead, should we clean up the "source not found" dialog, and instead mention that the user must be online for online updates?

Can you please attach screenshots and/or mockups?

Changed in hundredpapercuts:
milestone: round-6 → none
billytalent (billytalent) wrote :

I've attached a screenshot of this bug. A newbie or an average user wouldn't have any idea what failed the update. I'm not sure what the ideal solution would be.. thats for you guys to decide.

Even if there isn't a major update written to run a check for internet connectivity, at the very least the text could be changed easily to ask the user to check their connection and/or link to Ubuntu's help section for internet connection troubleshooting.

Hi,

First of all Update Manager shouldn't pop up to ask for updates if it sees that there is no connection available. After all if you put in your computer a sources CD, you will the program by yourself. The only purpose of "auto update" is to check for new versions online. If it is opened by the user there should be a red dot with the text "No connection available some sources may fail to retrieve information" and the text of the Update Manager after the user has clicked on check for updates button should show the same text.

So:
1- Only pop up for updates if the computer is connected to the internet
2- Change main window with something that shows the user that the computer is not connected and may fail with the sources
3- Change window with dialogue after pressing the "Check for updates" button

What do you guys think?

Tomas

> Date: Tue, 11 Aug 2009 15:51:34 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 387382] Re: update-manager doesn't check if Internet Connection is available
>
> This needs a bit more information. Some package sources are offline
> (users updating from DVDs) so when do we warn that the user is offline?
> Instead, should we clean up the "source not found" dialog, and instead
> mention that the user must be online for online updates?
>
> Can you please attach screenshots and/or mockups?
>
> ** Changed in: hundredpapercuts
> Milestone: round-6 => None
>
> --
> update-manager doesn't check if Internet Connection is available
> https://bugs.launchpad.net/bugs/387382
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in One Hundred Paper Cuts: Confirmed
> Status in “update-manager” package in Ubuntu: New
>
> Bug description:
> update-manager doesn't check if Internet Connection is available. When the user clicks on update manager and clicks on "Check". The update-manager should check whether Internet connection is available. Currently update-manager comes back with a whole bunch of source not found errors.. ??

_________________________________________________________________
Novo Internet Explorer 8. Baixe agora, é grátis!
http://brasil.microsoft.com.br/IE8/mergulhe/?utm_source=MSN%3BHotmail&utm_medium=Tagline&utm_campaign=IE8

Vish (vish) wrote :

assigning to mpt, as he is already working on Appcenter ,
He could add this to the user testing , or provide info from user testing if he is already aware of this issue.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Changed in hundredpapercuts:
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Undecided → Medium
Bilal Akhtar (bilalakhtar) wrote :

Matthew,
You should assign yourself to update-manager (ubuntu) as well.

Matthew Paul Thomas (mpt) wrote :

I've now written the relevant parts of the specification <https://wiki.ubuntu.com/SoftwareUpdateHandling>:
a. "Update Manager should launch automatically, in the background but not minimized, when the computer has been connected to the Internet for at least one minute, you are logged in as an administrator, and either..."
b. "Whenever the computer is not connected to the Internet, the [Install] button should be insensitive and have the tooltip “Not available because there is no Internet connection.”.

If anyone would like to implement both of those, I think that would be enough to fix this bug. There are a couple of other details I need to cover (what should happen if you get disconnected during updates, and what should happen if for example a wi-fi hotspot feeds you HTML login pages instead of software updates), but those can wait till later.

Changed in hundredpapercuts:
assignee: Matthew Paul Thomas (mpt) → nobody
Vish (vish) wrote :

Thanks mpt.

Changed in hundredpapercuts:
milestone: none → maverick-round-8-potpourri
status: Confirmed → Triaged
Changed in update-manager (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged

This has been fixed in Maverick by my window-main-alerts branch.

Changed in hundredpapercuts:
assignee: nobody → Mohamed Amine IL Idrissi (ilidrissi.amine)
status: Triaged → Fix Released
Changed in update-manager:
assignee: nobody → Mohamed Amine IL Idrissi (ilidrissi.amine)
status: New → Fix Released
Changed in update-manager (Ubuntu):
assignee: nobody → Mohamed Amine IL Idrissi (ilidrissi.amine)
status: Triaged → Fix Released
Vish (vish) wrote :

The branch was merged and released in package update-manager - 1:0.142.6

---------------
update-manager (1:0.142.6) maverick; urgency=low

 [ Mohamed Amine IL Idrissi ]
 * Implemented battery and network alerts directly in the main window.
   LP: #484249, #426708, #426710, #494772

 [ Michael Vogt ]
 * UpdateManager/Core/MyCache.py:
   - support looking for the changelog by source version
     (and add tests)
 * UpdateManager/Core/utils.py:
   - fix crash when reading the synaptic config (LP: #614170)
 -- Michael Vogt <email address hidden> Tue, 10 Aug 2010 15:16:27 +0200
----------

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers