Unmounting a drive sends Nautilus to /media instead of computer://

Bug #386517 reported by Alejandro Vidal
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Low
One Hundred Papercuts
Low
Luke Symes
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

When we unmount a device from the device folder, it switch to /media

When a device is unmounted it should switch to computer:/// instead of /media

Related branches

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Invalid
ShawnJGoff (shawnjgoff)
Changed in hundredpapercuts:
status: New → Confirmed
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Sebastien, if a bug report is a duplicate, don't mark it as Invalid, mark it as a duplicate.

Changed in nautilus (Ubuntu):
status: Invalid → New
Revision history for this message
Lightbreeze (nedhoy-gmail) wrote :

Bug #23293 reports this behavior and suggests closing the window whereas this bug suggests redirecting to computer.

Revision history for this message
Phoenix --rise-from-ashes (meindian523) wrote :

I suggest that the Send To should also allow sending files to the common folders like Documents,Pictures,Music etc,namely the folders already bookmarked in the Places menu.

Revision history for this message
Phoenix --rise-from-ashes (meindian523) wrote :

oops,please ignore the comment,it's irrelevant here.

summary: - unmounting a drive send to media folder
+ Unmounting a drive sends Nautilus to /media instead of computer://
Revision history for this message
Sebastien Bacher (seb128) wrote :

should the view go back to computer in any case or only if the mount has been opened from there?

Revision history for this message
Michele Giacomoli (michele-giacomoli) wrote : Re: [Bug 386517] Re: Unmounting a drive sends Nautilus to /media instead of computer://

In my opinion it should go back to computer in any case. Every window is
showing the mounted device should go back to computer

2009/7/21 Sebastien Bacher <email address hidden>

> should the view go back to computer in any case or only if the mount has
> been opened from there?
>
> --
> Unmounting a drive sends Nautilus to /media instead of computer://
> https://bugs.launchpad.net/bugs/386517
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Vish (vish) wrote :

This bug sounds more reasonable than Bug #23293 [which asks to close the window.]

/media has :
/media/cdrom
/media/cdrom0
/media/cdrom1
/media/.hal-mtab
/media/.hal-mtab-lock

These entires could be confusing to new users. So going back to "Computer" is a cleaner option.

Revision history for this message
Vish (vish) wrote :

Even if the hidden files are not shown, the cdrom repetitions are confusing

Also, the "Computer" shows Drive icons for the drives, while the /media only uses folders as the icons for the drives.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → round-6
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus:
status: Unknown → New
black (blackborn)
Changed in hundredpapercuts:
assignee: nobody → black (blackborn)
Revision history for this message
Vish (vish) wrote :

@black:
Seems you've assigned yourself to fix the bug , are you interested in fixing this issue?

Usually when a person assigns a bug to themselves, its ideal to leave a comment , letting others know you are interested in fixing the bug.

Revision history for this message
black (blackborn) wrote :

Yes, I'm interest in fixing the bug. Actually I already made a patch (or 2) upstream. Though the fix is rather nasty, but there is no better way (I think).

On the other hand I also proposed a totally new concept. We can change the computer:// protocol, so it handle the disks. (e.g. computer://disk-1/ ) So the /media/ folder is totally abstracted.

That should also solve following use case:
- open computer://
- double click on a drive
- click folder up
-> Now we are inside the /media/ folder

For more info, see comment 5 in upstream bug report.

Revision history for this message
black (blackborn) wrote :

I can't wait on comments/suggestions from upstream anymore. My holidays are over. (Same applies for #57210)

Changed in hundredpapercuts:
assignee: black (blackborn) → nobody
Revision history for this message
komputes (komputes) wrote :

@black
I'm not for abstracting /media or the mountpoints contained within it. The solution is much cleaner. Just closing the window or redirecting to computer:/// instead of /media would fix this issue.

As a side effect of this issue in Karmic, redirecting to /media at unmount will confuse and alienate users. It will expose them to mointpoints for unlabeled disks, now being named /media/$UUID (see Bug #390304 for details).

Revision history for this message
komputes (komputes) wrote :

After giving it some thought and reviewing Bug #23293, if unmounting from a nautilus window side pane, cosing the window may be seen as unexpected behavior as the user did not indicate they wanted it closed. Perhaps they still need the window to unmount other drives or to navigate through files.

My preference is to redirect nautilus to computer:/// when unmounting a disk from a nautilus window side pane. When unmounting a disk from the desktop, it makes sense to close all the windows that were pointing to that disk.

Revision history for this message
Alejandro Vidal (mancvso) wrote :

I do already know C, Java, C#, Vala and PHP.... so I think I can do the Job... ;D

but i need some kind of tutor, i've never seen nautilus code before... else, i don't even know how to start.

Changed in hundredpapercuts:
assignee: nobody → dael99 (dael99)
Changed in hundredpapercuts:
milestone: round-6 → lucid-round-3
Vish (vish)
Changed in hundredpapercuts:
importance: Undecided → Low
status: Confirmed → Triaged
Revision history for this message
Sense Egbert Hofstede (sense) wrote :

Removing the assignee because apparently no one seems to be actually working on this bug.

Changed in hundredpapercuts:
assignee: dael99 (dael99) → nobody
Revision history for this message
Luke Symes (allsymes) wrote :

I have submitted a new patch upstream, thus am marking this "In progress".
My patch causes window slots displaying mount contents to be redirected to computer:/// on unmount. I also included a change to the code that checks if a slot should be closed on unmount. Previously the code only checked if you were viewing a sub-directory, now it also checks if you are in the top-most directory of the mount.

Changed in hundredpapercuts:
status: Triaged → In Progress
Luke Symes (allsymes)
Changed in hundredpapercuts:
assignee: nobody → Luke Symes (allsymes)
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Luke Symes (allsymes)
Changed in hundredpapercuts:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.29.91-0ubuntu1

---------------
nautilus (1:2.29.91-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - Make it possible to have backgrounds spanning multiple monitors.
    - Better handling of closing windows when device is unmounted (lp: #386517)
    - Use GtkSpinner instead of custom widget
    - Translation updates
  * debian/control.in:
    - updated gnome-desktop and gtk requirement
  * debian/patches/90_relibtoolize.patch:
    - new version update
 -- Sebastien Bacher <email address hidden> Mon, 22 Feb 2010 15:29:11 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Luke Symes (allsymes)
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Revision history for this message
Vish (vish) wrote :

@Luke Symes , seems there is a regression caused by fixing this bug > Bug #530542

Changed in nautilus:
importance: Unknown → Low
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.