"Hardware Drivers" displays empty error dialog when not connected to the network

Bug #386375 reported by mrosati
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Jockey
Undecided
Unassigned
One Hundred Papercuts
Undecided
Unassigned
jockey (Ubuntu)
Undecided
Unassigned

Bug Description

when driver installer tries to download a driver, it gives an insignificant error and stops the installation. would be much better if the error dialog could inform about the nature of error itself.

Revision history for this message
mrosati (rosati-matteo) wrote :
mrosati (rosati-matteo)
tags: added: hundredpapercuts
Revision history for this message
wisd0m (wisd0m) wrote :

This needs to be fixed asap. I have had this happen many times and wonder how a new user might deal with it.

ShawnJGoff (shawnjgoff)
Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → round-6
Revision history for this message
Jamie Strandboge (jdstrand) wrote :

Just encountered this today. The error box simply says 'Error' with no other information.

Changed in jockey (Ubuntu):
status: New → Confirmed
summary: - driver installer gives insignificant error when not connected to the
+ "Hardware Drivers" displays empty error dialog when not connected to the
network
Revision history for this message
Kevin Hausmann (salema) wrote :

I tried to look into this one and it seems like it originates from jockey/ui.py line 622:

self.error_message('', str(e).splitlines()[-1])

This is supposed to catch a generic SystemError and should probably read something like

self.error_message(self.string_error, str(e))

I am not much of a python programmer, but this should be easy to fix if you know what you are doing. Obviously it would be even better to present a more specific error message depending on the type of exception.

Andrew (and471)
Changed in jockey:
status: New → Confirmed
Revision history for this message
Andrew (and471) wrote :

Attached is a patch for the jockey trunk branch

I fixed the empty error dialog and made the string more concise by using split('\n') instead of splitlines()

Also in the patch is a change for the jockey-gtk.ui file, it makes the progress dialog not show the text 0% (making it appear as though it was doing nothing

Can this please be applied to the jockey trunk

Changed in hundredpapercuts:
status: Confirmed → In Progress
Changed in jockey:
status: Confirmed → In Progress
Revision history for this message
Andrew (and471) wrote :

Added branch where problem is fixed, proposed for merge

Revision history for this message
Martin Pitt (pitti) wrote :

Current branch causes regressions, see merge proposal.

Changed in jockey:
status: In Progress → Incomplete
Revision history for this message
Andrew (and471) wrote :

Okay, fixed my branch, ready for merge

Changed in jockey:
status: Incomplete → In Progress
Revision history for this message
Martin Pitt (pitti) wrote :

Merged, thanks! (trunk r575)

Changed in jockey:
status: In Progress → Fix Released
Changed in jockey (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5.4-0ubuntu1

---------------
jockey (0.5.4-0ubuntu1) karmic; urgency=low

  * New upstream bug fix release:
    - Update tests for openprinting.org changes; LaserJet 3020 does not exist
      any more, replace with DesignJet 3050CP.
    - Handler: Reload module blacklist after installing a driver package,
      since it might ship blacklists.
    - setup.py: Fix DistUtilsExtra version check. (LP: #428337)
    - jockey-gtk: Check for having $DISPLAY at startup to avoid crashes.
      (LP: #204134)
  * ui.py: Fix error message parsing, thanks to rugby471! (LP: #386375)
  * Add data/handlers/dvb_usb_firmware.py: Handler for DVB USB cards which
    need to have the linux-firmware-nonfree package installed. (LP: #223212)

 -- Martin Pitt <email address hidden> Mon, 21 Sep 2009 18:31:45 +0200

Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
Andrew (and471)
Changed in hundredpapercuts:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers