Brushing right-edge of trackpad causes clipboard to paste text

Bug #386017 reported by Patrick Conway
66
This bug affects 9 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Medium
One Hundred Papercuts
Low
Unassigned
gnome-control-center (Ubuntu)
Low
Unassigned
xserver-xorg-input-synaptics (Ubuntu)
Low
Unassigned

Bug Description

I've experienced this bug on every computer that I've installed ubuntu on, I don't know whether it is specific to trackpads or not. Basically, when I read webpages, I will often highlight my way down the page. And I will frequently discover that this highlighting and clicking will copy text which is then pasted when I click on an input box--such as the google toolbar or an open office document. I recognize that this is probably a feature, but it should be disabled by default. It was the only complaint I've received about usability from the average computer users I've introduced to ubuntu

Revision history for this message
Patrick Conway (patriconway) wrote :

I don't know whether this is actually a duplicate, I think that having the middle button click paste previously highlighted text should be fixed for trackpads so that it only pastes when you click both mouse buttons, and not when you bump into the scroll bar. This would fix 'copy-paste' in ubuntu so that power users could still copy-paste without having to ctrl c, ctrl v but also keep people from accidentally pasting text while typing. I run into this accidental pasting every day. It seems like it's a feature which is pretty deeply rooted in linux, so I don't know whether it's possible to tweak it in this instance so it recognizes a distinction between middle mouse click (press both left and right buttons) and middle mouse click (touch scroll on trackpad). I am sure that other ubuntu users who use the track pad primarily also run into this issue. Thanks for your help.

Revision history for this message
Patrick Conway (patriconway) wrote :

I realize that there is an option to disable mouse clicks on the trackpad. I'm suggesting that ubuntu disable middle mouse clicks on the trackpad so that people don't accidentally paste previously highlighted text while typing. For now I'll use ubuntu with the trackpad clicking disabled.

tags: added: trackpad
removed: design
summary: - Unknown trackpad combination pastes text highlighted from different
- applications.
+ Brushing Right-edge of trackpad pastes text:
Revision history for this message
ShawnJGoff (shawnjgoff) wrote : Re: Brushing Right-edge of trackpad pastes text:

I run into this every day. Drives me crazy. Furthermore, I can't figure out what is causing it. I have tap-to-click turned off, but it still happens. I can't make it happen, it just seems to do it on it's own once in a while.

ShawnJGoff (shawnjgoff)
Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → round-6
Revision history for this message
Nicolò Chieffo (yelo3) wrote :

well it is not necessary to completely disable touchpad clicking.
this should be enough:
synclient RTCornerButton=0
synclient RBCornerButton=0

the first removes the paste, the second removes the popup menu (both when scrolling)
this is clearly a workaround, because it is a transient option

summary: - Brushing Right-edge of trackpad pastes text:
+ Brushing right-edge of trackpad causes clipboard to paste text
Revision history for this message
Martin Brook (martin.brook) wrote :

Ok, but personally I wouldn't like this feature to be disabled without there being a GUI option somewhere to re-enable it. I sometimes deliberately use this as an easy way to copy/paste text without moving from the trackpad.

Revision history for this message
Samuel G. (samuelgrantsmith-deactivatedaccount) wrote :

I don't see how this is a problem unless users are pushing both trackpad buttons. I use this feature a lot and have rarely if ever pasted this way by accident. If specific users are having a lot of trouble with this feature they can always disable 3-button mouse emulation in xorg.

Revision history for this message
Alberto Milone (albertomilone) wrote :

The only thing which can trigger a middle click event is the top right area of the touchpad. There's no need to disable the bottom right area (which currently triggers a right click event).

synclient RTCornerButton=0 should do it.

If this fixes the problem I'll modify the driver so as to make it the default behaviour.

Please let me know if that command solves the problem.

Changed in hundredpapercuts:
assignee: nobody → Alberto Milone (albertomilone)
Revision history for this message
Martin Emrich (emme) wrote :

I just stumbled on this issue via a post on Planet Ubuntu, and I just have to leave my 2¢ here :)

 I hope you just mean disabling "tapping on the right corner with a single finger issues a middle-mouse-button-click" (Which I have never encountered on any laptop I had used).

My more generic view is that I don't think disabling a user interface function is a good idea: This (or a similar) "bug" was apparently fixed in karmic two weeks ago, thus tap-to-click (and multitouch scrolling) stopped working on my Eee PC 900. Left with no scrolling or tapping at all, I went through a lot of trouble, googling for hours until I found out that it was just disabled now, and it changed even my existing profile (apparently some new gconf registry keys were introduced). After re-enabling them under Settings->Mouse I was happy again.

I thus "vote" for keeping the feature enabled, with an easy option to turn it off, with a simple reason:
When a feature works, but is annoying, people will search for a way to turn it off, and the mouse settings window is the logical place to start.
But when a previously working feature just stops working, this rather smells like a bug (Experience taught me that I can expect more features from newer Ubuntu releases, not less). And people who have never seen middle- or right-click-on-tap might never know that their hardware is capable of pasting text without either moving to the keyboard (CTRL-V) or doing a wild two-finger-button-stunt (middle-mousebutton-emulation), especially on hardware where both mouse buttons are together in one stiff piece of plastic (like some Asus laptops we have at work).

Ciao

Martin

Revision history for this message
Scott Ritchie (scottritchie) wrote :

Relatedly: there is no easy way to disable left+right mouse = middle click. This was an xorg.conf setting long ago, but there's no way to set it graphically. I'm not even sure we can set it without restarting X.

This frustrates users who use both buttons at the same time, such as when playing first person shooters.

Revision history for this message
Alberto Milone (albertomilone) wrote :

@Scott

I think it would be worth filing a separate bug report about that.

If you type:
xinput list --short

you'll see a list of input devices. Note down the one which matches your mouse and type:

xinput set-int-prop $YOUR_MOUSE_NAME "Evdev Middle Button Emulation" 8 0

and replace $YOUR_MOUSE_NAME with the name that you found.

Revision history for this message
nh2 (nh2) wrote :

@ Alberto Milone:
In 1.1.2-1ubuntu3, you successfully disabled corner tapping for middle click. Does that mean that functionality is completely gone? Since I knew it was there and a feature, I've begun to like it (especially in Firefox browsing to open a site in a new tab).
Can't we make it an option in the mouse settings so one can turn it on if needed? We could make such an option for the right click tapping in the same run, which may be also annoying for some and great for others.

Revision history for this message
Alberto Milone (albertomilone) wrote :

@nh2
Of course that feature is not gone. It's disabled by default (as in upstream) now.

You can still enable it with synclient RTCornerButton=2

Revision history for this message
Martin Brook (martin.brook) wrote :

That's not really an adequate solution for users who expect the behaviour (which has been there since... forever as far as I know) and will suddenly lose it on upgrading.

Revision history for this message
Max Bowsher (maxb) wrote :

Is there any good way to configure this to persist over multiple X sessions?

Revision history for this message
Vish (vish) wrote :

I'm a bit confused with this bug , is this bug related to pages randomly loading the selected text as an url? this happens when i'm scrolling using the right side of my touchpad.

Revision history for this message
Alberto Milone (albertomilone) wrote :

@Martin
I know. I enabled that feature (together with right click) in the driver in Ubuntu 8.10 despite upstream's decision.

@Max
One way is to add a script at startup.

A new UI to configure touchpads should be available sooner or later, not in time for Karmic though but I'll provide it in a PPA.

@mac_v
I'm not sure about that. Can you still reproduce the problem with version 1.1.2-1ubuntu3 of the driver?

Revision history for this message
Max Bowsher (maxb) wrote :

FWIW I've never had a problem with corner actions inadvertently triggering during scrolling.

However, if you're choosing to disable the right *top* corner action, how come you're leacing the right *bottom* corner action enabled? This seems inconsistent.

Revision history for this message
Vish (vish) wrote :

@Alberto Milone :
I'm using the version 1.1.2-1ubuntu3 , but as i said , I really dont know how I'm triggering the bug ! :(

It happens ,while scrolling, only at random .

Since i have FireGestures extension activated to either search the text-selected or open selected text as url.
The selected text either from a previous text select or from accidental text select triggers the new url to be opened in the same tab!

I think this is the same bug , but will let you know if the problem exists...

On another note , you mention in comment #16 about a new UI , is it the gpointing-device-settings ?

Revision history for this message
nh2 (nh2) wrote :

I've created two patches which enable turning middle click via top right cornertab and right click via bottom right cornertab on and off in the mouse settings.
(Please check they're correct since this is the first time I've worked with GTK GUIs and Xorg parts.)

Revision history for this message
nh2 (nh2) wrote :
Revision history for this message
nh2 (nh2) wrote :
Revision history for this message
Nicolò Chieffo (yelo3) wrote : Re: [Bug 386017] Re: Brushing right-edge of trackpad causes clipboard to paste text

I'd prefer a combo box, but I don't know if it's the correct solution:

Top right corner: {none, button 1, button 2, button 3,...}
Bottom right corner....

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

"Enable right clicks with the right bottom corner of the touchpad" ->
"Right-click by tapping the bottom-right corner of the touchpad"

"Enable middle clicks with the right top corner of the touchpad" ->
"Middle-click by tapping the top-right corner of the touchpad"

Revision history for this message
nh2 (nh2) wrote :
Revision history for this message
Huggie (matt-huggins) wrote :

How do I apply the patch nh2 submitted? This bug is KILLING my productivity. I keep having to search through code that I saved to see where I accidentally pasted something, then figure out what exactly I pasted that doesn't belong. How annoying!

Revision history for this message
fondle-em (mcribbb) wrote :

I also need to know how to patch gnome-control-center to add the options to kill this stupid "feature", as apparently this common-sense patch isn't making it into the 9.10 release. Accidentally triggering right-click when using the scroll wheel sucks.

Revision history for this message
fondle-em (mcribbb) wrote :

I meant the "scroll wheel" section of the touchpad - obviously.

Revision history for this message
nh2 (nh2) wrote :
Revision history for this message
nh2 (nh2) wrote :
Revision history for this message
nh2 (nh2) wrote :

I updated both patches for Karmic, try out if they work for you.

@fondle-em:
You have two options to get this into your Ubuntu (Karmic):

1st way: Install the build dependencies (sudo apt-get build-dep gnome-settings-daemon gnome-control-center), get the source (apt-get source gnome-settings-daemon gnome-control-center), copy the patches into the debian/patches directories of each package and run dpkg-buildpackage. Then install the created debs with dpkg -i.

2nd way: Install the packages from my PPA (https://launchpad.net/~nh2/+archive/ppa). Please tell me if it worked well.

Revision history for this message
fondle-em (mcribbb) wrote :

THANK YOU x1000!

I added the PPA above to my software sources, installed the PPA versions of gnome-settings-daemon and gnome-control-center (karmic-proposed's gnome-settings-daemon has a newer version number so I had to "downgrade" to the PPA), and now everything works like a champ.

This patch should be slipped into proper Karmic if at all possible - touchpad side-scrolling that easily triggers right-click even when tap-to-click is completely turned off in the Touchpad settings can't be considered anything other than a bug. Turning the "functionality" off requires the use of the command line every time the laptop is booted, or wakes from suspend. "Out of the box", a standard install of Karmic will blatantly defy my control panel settings disabling tap-to click. This does not reflect well on Ubuntu, as clearly lower right corner tap-to-right-click is still tap-to-click. I cannot count the number of times that I've ended up inadvertently clicking "back" in the right-click menu while scrolling through a web page, sometimes losing the contents of text entry fields in the process. This patch is a sanity saver.

Running Karmic 64-bit on a Dell Inspiron 1420n that shipped with Ubuntu installed.

Revision history for this message
nh2 (nh2) wrote :

> ... touchpad side-scrolling that easily triggers right-click [...] can't be considered anything other than a bug
Note that it does not behave like that on all hardware - on my Latitude 2100, I can scroll with no problems and the tap triggers only if I really tap on the corner.

> even when tap-to-click is completely turned off in the Touchpad settings
Of course, you are right, this is a bug.

I am quite sure the patch won't go into Karmic, but I think it would make sense for Lucid (and therefore maybe into Karmic proposed or backports?).

Changed in hundredpapercuts:
milestone: round-6 → none
Revision history for this message
Jacopo Moronato (jmoronat) wrote :

Is there a chance to have this papercut fixed for Lucid ?

Revision history for this message
Vish (vish) wrote :

Marking as confirmed due to the comments and dup

tags: added: patch
Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in hundredpapercuts:
importance: Undecided → Low
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Revision history for this message
Nigel Babu (nigelbabu) wrote :

If someone could forward the fix upstream too, it would be great. Thanks for the work on the patch.

tags: added: patch-needswork
removed: patch
Revision history for this message
nh2 (nh2) wrote :
Revision history for this message
nh2 (nh2) wrote :

Notebook users: Please test the patches from here: https://launchpad.net/~nh2/+archive/cornertapping

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Nigel Babu (nigelbabu)
tags: added: patch-forwarded-upstream
removed: patch-needswork
Revision history for this message
Vish (vish) wrote :
Changed in hundredpapercuts:
status: Confirmed → Triaged
Changed in gnome-settings-daemon:
status: Unknown → New
Vish (vish)
Changed in hundredpapercuts:
status: Triaged → In Progress
Revision history for this message
Vish (vish) wrote :

Alberto Milone mentioned that he is not actively working on this bug right now.

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in hundredpapercuts:
assignee: Alberto Milone (albertomilone) → nobody
status: In Progress → Triaged
Changed in gnome-settings-daemon:
importance: Unknown → Medium
Revision history for this message
Bryce Harrington (bryce) wrote :

Based on the discussion it appears the consensus is to leave the synaptics settings as is and make it configurable via g-c-c, so dropping the -synaptics task.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Sebastien Bacher (seb128) wrote :

unsubscribing the sponsors, the patches there a for karmic and the sort of things that should go upstream rather

Changed in gnome-settings-daemon:
status: New → Invalid
Revision history for this message
Sebastien Bacher (seb128) wrote :

upstream says it's fixed in GNOME3, you can set a custom command to run on hotplug with org.gnome.settings-daemon.peripherals.input-devices hotplug-command

Changed in gnome-control-center (Ubuntu):
assignee: Alberto Milone (albertomilone) → nobody
Changed in gnome-settings-daemon:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.