Suggested output when printing a file to PDF is technical and generic "~/output.pdf"

Bug #382829 reported by David Siegel on 2009-06-02
90
This bug affects 15 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
One Hundred Papercuts
Low
Timothy Arceri
gtk+3.0 (Ubuntu)
Low
Unassigned

Bug Description

In Jaunty, GNOME print dialogs have a "Print to File" printer available in the Print dialog. When you select this printer, the output file's suggested name is "output.pdf" and the suggested location is the user's home directory.

"output" is jargon, has the potential to collide with another file of the same name in the destination directory, and is difficult to remember as it has no relation to the name of the file being printed. Incorporating the source file's name in the output filename seems like a great improvement.

Saving to the user's home directory is reasonable, but the Desktop is a more accessible location. We may also want to consider saving the PDF to the same directory as the source file.

Suggestion:
 * Always default to PDF format.
 * Reuse the source filename if known, else use "Untitled" or the naming convention for unnamed files.
 * Default to saving on the Desktop rather than inside the user's home folder.

Emmet Hikory (persia) wrote :

Rather than saving to the user's desktop, consider defaulting to the user's XDG Documents directory. This helps keep the desktop spare, increases simple discoverability and access using the "Home" function from the file chooser (e.g. when attaching the PDF to email), and has a localised pathname that matches other guidance to the user on where document files should be stored.

Sebastien Bacher (seb128) wrote :

Changing the default name and location should be easy enough. What location is recommended by the design team there? The default format is already being pdf, firefox behaving differently is a firefox issue, they seem to set their own option and not use the default

krevuru (krevuru) wrote :

I have been through myriad sites and literature and I know the answer is NOT POSSIBLE, but still I want to post my questions as "Paper Cut".
Is it possible to enter a filename and a path for the PDF file generated by the PDF-printer-driver (CUPS-PDF)?

Steven Danna (ssd7) on 2009-06-16
Changed in hundredpapercuts:
status: New → Confirmed
Hein (hhanssen) wrote :

Apart from the strange location / filename there is something else worth noting. Print to file doesn't immediately ring a bell that this is the solution to print to pdf. Isn't it better to install by default a 'print to pdf' printer? I think that there is no one out there who doesn't want to have a print to pdf as a default printer pre installed.

I can imagine that there are still people out there installing additional packages as cups pdf, because the have no clue that printing to pdf is possible by selecting 'print to file'. 'Print to PDF' rings immediately a bell.

Asa Ayers (asa-ayers) wrote :

@Hein I'm one of those people. I always install cups-pdf, it always puts the documents in a consistent location from any program I run. I think I had print to file create a .ps file one time, so I've never used it since.

Changed in hundredpapercuts:
milestone: none → round-6
Zshazz (zshazz) wrote :

Instead of having it print to the desktop or to a documents folder, it should be user-configurable. I'd prefer it to print to ~/documents/printed, for instance.

Nicholas Skaggs (nskaggs) wrote :

Since this an "easy" bug, I will attempt to fix. After all it's only 2 days late already :-) Has anyone else looked into it, or could give guidance on which module needs changed for this?

pt123 (pt123) wrote :

why cant it be a little smarter like CUPS and have the title passed in. When you print a web page, the title of the web page becomes the title of the PDF.

krevuru (krevuru) wrote :

I have a bit of confusion here. I always install the CUPS-PDF, but I think the Print-To-File should be sufficient.
The Print-To-File has the feature to take a specific name, and also a directory to save, and option to save as PS/PDF.
This feature is available from almost all the applications with a Print dialog. I don't know why even need to install a CUPS-PDF package as a separate PDF-Printer.

grofaty (grofaty) wrote :

Hi,
isn't the title "Print to File" too geeky? Non-technical user would probably prefer "Save file as PDF". Why? Because saving file is what he/she is doing. If saving file process goes in some kind of printing file phase user should not be bothered with it. I suggest to use "Save file as PDF" or "Save PDF to file" or something like that.
Regards

krevuru (krevuru) wrote :

I kind of agree with you.
It should be something like "Save As ..." or "Convert to ..." and the default Option should be PDF instead of PS.

Vish (vish) wrote :

@grofaty , krevuru
A separate bug already exists> Bug #164298
my suggestions > https://bugs.launchpad.net/ubuntu/+bug/164298/comments/9

komputes (komputes) wrote :

To avoid the default name colliding with another file of the same name, it should detect existing files in the directory and propose "name-1". gnome-screenshot does this whether or not it can grab a window name.

AFAIK, this would have to be done on a per-app basis.

Changed in hundredpapercuts:
milestone: round-6 → lucid-round-3
Vish (vish) on 2010-01-26
Changed in hundredpapercuts:
importance: Undecided → Low
status: Confirmed → Triaged
Philip Muškovac (yofel) on 2010-02-07
Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → gtk+2.0 (Ubuntu)
Sebastien Bacher (seb128) wrote :

the bug described there is a combinaison of several issues, would be easier to track them in different bugs

Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
Bilal Akhtar (bilalakhtar) wrote :

Meh, by mistake I assigned this bug ti myself rather than bug #536705 !

Changed in hundredpapercuts:
assignee: nobody → Bilal Akhtar (bilalakhtar)
milestone: lucid-round-3 → maverick-round-3-social-networking
status: Triaged → In Progress
assignee: Bilal Akhtar (bilalakhtar) → nobody
status: In Progress → Triaged
milestone: maverick-round-3-social-networking → none
Changed in gtk2:
importance: Unknown → Medium
status: Unknown → Confirmed
Javier Jardón (jjardon) wrote :

There is a GnomeGoal for this here: http://live.gnome.org/GnomeGoals/PrintToFile

Changed in gtk2:
status: Confirmed → Unknown
Changed in hundredpapercuts:
assignee: nobody → Papercuts Ninja (papercuts-ninja)
Changed in gtk2:
status: Unknown → Invalid
Timothy Arceri (t-fridey) wrote :

The default folder in gtk3 seems to be Documents, and there is a drop down list that lets you choose Desktop, Home etc.

It would seem the only thing needed to close this bug would be renaming the default output

Timothy Arceri (t-fridey) wrote :

Both the output dir and and file name are set by the application using GTK.
See: http://git.gnome.org/browse/gtk+/tree/demos/gtk-demo/printing.c?id=3.1.12

Output is meant to be a fallback option for application that have not implemented this.

First things first I have filled this bug to improve the GTK api to make this simpler for applications to implement.
https://bugzilla.gnome.org/show_bug.cgi?id=657322

Once this is implemented its a matter of working through the list and creating patches for each application.
http://live.gnome.org/GnomeGoals/PrintToFile

Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
description: updated
Changed in hundredpapercuts:
assignee: Papercuts Ninja (papercuts-ninja) → Timothy Arceri (t-fridey)
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in gtk+2.0 (Ubuntu):
status: Confirmed → Triaged
Timothy Arceri (t-fridey) wrote :

I have added a patch to GTK upstream to allow for file names to be more easily applied via the api. However I always find its difficult to get the Gnome devs to review patches.

Changed in hundredpapercuts:
status: Triaged → In Progress
Sebastien Bacher (seb128) wrote :

Thanks, I will try to see if I can get it reviewed

Timothy Arceri (t-fridey) wrote :

Thanks Sebastien, let me know how you go. I'm happy to make changes, improve the testing app, and write any documentation needed for the api guide etc. I just find it hard to contact the devs as I'm in the Australian timezone. Also the people I have spoken to said that not many devs are willing to make changes to printing module as its a dark corner not many GTK devs are willing to touch.

Timothy Arceri (t-fridey) wrote :

Thanks for the feedback Lars. I have updated the patch based on you suggestions as well as other small improvements and the removal of whitespaces. I have also fixed the issue with the patch no applying to trunk I think I may have made the patch with oneiric version of GTK the first time.
Can you please review the new version.

komputes (komputes) on 2012-03-20
tags: added: css-sponsored-p
Timothy Arceri (t-fridey) wrote :

Patch to change output name easier in GTK has been committed upstream. New bugs should be filled for individual applications rather than trying to track them all here.

Changed in hundredpapercuts:
status: In Progress → Fix Committed
Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Committed
Changed in gtk:
status: New → Fix Released
affects: gtk+2.0 (Ubuntu) → ubuntu
no longer affects: gtk+3.0 (Ubuntu)
affects: ubuntu → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Committed
Changed in hundredpapercuts:
milestone: none → quantal-10-gtk
Timothy Arceri (t-fridey) wrote :

gtk+3.5.4 (which contains the fix) has been added to quantal. Marking as fix released.

As stated earlier bugs should be filled for individual applications if you what them to change the default value. I have already submitted a patch upstream for Gedit.

Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.