Gnome System Log Complains About btmp log permissions

Bug #374320 reported by nullack
90
This bug affects 19 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
gnome-utils
New
Medium
gnome-utils (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-utils

On Karmic Koala, each time I open the gnome system log viewer, the app shows the following error message:

/var/log/btmp

You don't have enough permissions to read the file.

The user can workaround the problem by closing the error dialogue so its an annoyance rather than a blocker.

nullack@PPP:~$ sudo apt-cache policy gnome-utils
[sudo] password for nullack:
gnome-utils:
  Installed: 2.26.0-0ubuntu1
  Candidate: 2.26.0-0ubuntu1
  Version table:
 *** 2.26.0-0ubuntu1 0
        500 http://archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, I'm not confirming this issue on jaunty

Changed in gnome-utils (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Revision history for this message
EzNet (zeroezezero) wrote :

Same here - confirmed on my 1000he EeePC

/var/log/btmp
You don't have enough permissions to read the file.

uname -a
Linux eznet-mobile 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

dpkg -s gnome-utils | grep Version
Version: 2.26.0-0ubuntu1

Revision history for this message
yarly (ih8junkmai1) wrote :

Confirmed also on Jaunty 9.04.

I noticed this around August 1st.

Revision history for this message
yarly (ih8junkmai1) wrote :

Ubuntu 9.04 64bit (Jaunty)
Kernel Linux 2.6.28-14-generic
GNOME 2.26.1

dpkg -s gnome-utils | grep Version
Version: 2.26.0-0ubuntu1

/var/log/btmp
You don't have enough permissions to read the file.

Revision history for this message
yarly (ih8junkmai1) wrote :

Screenshot on Jaunty 9.04

Revision history for this message
nullack (nullack) wrote :

I note that gnome 2.28 is being reported as the gnome revision for Karmic now, and this bug still exists.

IKT (ikt)
Changed in gnome-utils (Ubuntu):
status: New → Confirmed
Revision history for this message
IKT (ikt) wrote :

confirmed, and removing btmp in /var/log/ means the error changes to:

Error stating file '/var/log/btmp': No such file or directory

On top of this, going to help file:

To stop monitoring a specific log, uncheck the View ▸ Monitor option.
Check this option again to turn monitoring back on.

There is no 'monitor' option in the view menu.

Going upstream to find out what's going on.

Revision history for this message
IKT (ikt) wrote :

https://bugzilla.gnome.org/show_bug.cgi?id=567169

Appears to be the best change we can hope for.

Revision history for this message
Patrick (taishor) wrote :

Sorted the problem at my EEE PC S101...

sudo chmod +r /var/log/btmp

Now I dont get any more error messages about btmp when opening system log.

Revision history for this message
ArTaX (marco-zannoni) wrote :

This bug affects also me. I googled and I found this page:
https://issues.rpath.com/browse/RPL-1825
the problem seems to be correlated to ssh. SSH (only if there was a connection error?) change the permission of the file /var/log/btmp to 660. I often use ssh and sometimes it gives me a connection error.
Can you confirm that this problem is related to ssh?

Revision history for this message
IKT (ikt) wrote :

@ArTaX, I've installed ssh and attempted to login to multiple other computers on my network, used the wrong username, ip address, port etc, and it doesn't seem to be causing the error, is there anything specific I can do to trigger the error? Using 10.04 alpha 2.

Revision history for this message
Timothy W. Tacker (tim-tacker) wrote :

Confirmed that I receive the following error on Ubuntu 10.04 with Log Viewer 2.30.0:

/var/log/btmp
You don't have enough permissions to read the file.

This error is mentioned in the following Ubuntu Forums threads:
http://ubuntuforums.org/showthread.php?t=1458975
http://ubuntuforums.org/showthread.php?t=1444418
http://ubuntuforums.org/showthread.php?t=1283823
http://ubuntuforums.org/showthread.php?t=1324816
http://ubuntuforums.org/showthread.php?t=1143152
http://ubuntuforums.org/showthread.php?t=1315549
http://ubuntuforums.org/showthread.php?t=1280122

It appears that the /var/log/btmp file logs bad login attempts and is used with the lastb command. I have seen suggestions that the read permissions on this file can be relaxed as a workaround; however, I have also read that the information in this file contains sensitive bad login information which requires protection.

I believe that this is only a problem in Ubuntu because Log Viewer is run without superuser permissions when accessed through System > Administration > Log File Viewer. The solution may be to (1) configure Ubuntu to run Log Viewer with superuser permissions when accessed through System > Administration > Log File Viewer or (2) to remove /var/log/btmp from the list of files monitored by Log Viewer.

Unless there is a reason not run Log File Viewer with superuser permissions, I think the first option is best so that bad logins can be monitored with Log Viewer. Unfortunately, I have read that this logging only starts once the /var/log/btmp is created; and I do not know if this file is automatically created in Ubuntu. Also, I am not sure about the best approach to accomplish either the first or second options mentioned above; so if anyone has any suggestions on how to do either of these, they would be greatly appreciated.

It looks like the following error is also common in Log Viewer and perhaps related:

/var/log/btmp
This file is not a regular file or is not a text file.

This error is mentioned in the following Ubuntu Forums threads:
http://ubuntuforums.org/showthread.php?t=1458975
http://ubuntuforums.org/showthread.php?t=1443803
http://ubuntuforums.org/showthread.php?t=1210650
http://ubuntuforums.org/showthread.php?t=1339622
http://ubuntuforums.org/showthread.php?t=1320579
http://ubuntuforums.org/showthread.php?t=1143152

This error is also mentioned in the following Ubuntu Question:
https://answers.launchpad.net/ubuntu/+question/78010

Revision history for this message
libbi (libbi) wrote :

I get the same error on Ubuntu 10.10 RC with Systemlogviewer 2.31.1 on Gnome

Revision history for this message
Sam_ (and-sam) wrote :

@Timothy
regarding the "This file is not a regular file or is not a text file."
Bug #401499

Revision history for this message
IKT (ikt) wrote :

Have duped bug 401499, and am praying to zeus that someone can fix this!

Revision history for this message
IKT (ikt) wrote :

edit: haven't duped, slightly different issues.

Changed in gnome-utils:
status: Unknown → Fix Released
Revision history for this message
MountainX (dave-mountain) wrote :

This bug affects me too.
2.6.35-28-generic #49-Ubuntu SMP Tue Mar 1 14:39:03 UTC 2011 x86_64 GNU/Linux
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.10
DISTRIB_CODENAME=maverick
DISTRIB_DESCRIPTION="Ubuntu 10.10"

Changed in gnome-utils (Ubuntu):
status: Confirmed → Fix Committed
Changed in hundredpapercuts:
status: New → Fix Committed
Changed in gnome-utils (Ubuntu):
status: Fix Committed → Confirmed
Changed in hundredpapercuts:
status: Fix Committed → Confirmed
Revision history for this message
Timothy Arceri (t-fridey) wrote :

The remote watch was pointing to the wrong bug :)

Changed in gnome-utils:
status: Fix Released → Unknown
Changed in gnome-utils:
importance: Unknown → Medium
status: Unknown → New
Revision history for this message
tekstr1der (tekstr1der) wrote :

Still seeing this bug, so many releases later, on Oneiric 11.10.

Simple workaround in comment #9 "fixes" the situation. Couldn't this be a papercut for the upcoming 12.04 LTS?

Revision history for this message
Paul White (paulw2u) wrote :

Upstream bug was closed as gnome-system-log no longer developed.
gnome-utils is not included in any currently supported Ubuntu release.
So closing as this bug report is no longer valid.

Changed in gnome-utils (Ubuntu):
status: Confirmed → Invalid
Changed in hundredpapercuts:
importance: Undecided → Low
status: Confirmed → Invalid
Changed in gnome-utils (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.