"Create Document" Templates difficult to use

Bug #372132 reported by Gorka Navarrete on 2009-05-05
270
This bug affects 44 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Wishlist
Unassigned
nautilus (Ubuntu)
Wishlist
Unassigned

Bug Description

The "Create Document" right-click option has only "Empty file" as an option and a rather puzzling "No templates installed" second option.

I expected to find templates for the most common Openoffice file types.

This is confusing for non-expert users and can lead to problems. Particularly to those used to the windows behaviour.

I suggest creating a group of templates (openoffice word processor, spreadsheet, presentation) as the default set to ease the newcomers difficulties.

As a matter of fact, a friend I introduced to Linux just realized all the documents she created using that method didn't have any format. She used a simple (although wrong) method to create Openoffice files.
#1 Right Click inside folder - Create document - Empty File (Just as any windows user could do)
#2 Rename document to whatever she wanted - Ex: Doc1.odt (this is a somehow advanced behaviour but still common for windows users).
#3 Open file and ignore ASCII Filter Option message (whatever - OK)
#4 Write in the document.
#5 Save - Ignore warning about formating and Click on "Keep Current Format" instead of "Save in ODF format" (this could be seen as a huge mistake, and it is, but also a common behaviour if you are used to open DOC files with Openoffice. You end up ignoring those warnings).

What I am proposing is to put template files for the most common document formats (at least openoffice ones) into the Templates folder by default. This way, the windows newcomers would find a Create Openoffice Word file option and avoid very damaging mistakes as the one explained before. Also, this would fill an usability gap between linux and windows.

affects: ubuntu → nautilus (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Wishlist
status: New → Invalid
Gorka Navarrete (emrys) wrote :

Could you give a link to the other bug where it was reported?

Sebastien Bacher (seb128) wrote :

no, that was discussed several times on lists and bugs since warty, the rational to have no template by default is that the choice of what to put there is an user one and upstream is against giving a way for applications to put tons of useless items in there for most users

Travis Watkins (amaranth) wrote :

As this bug is marked as Invalid in Ubuntu itself there doesn't seem to be much point to having an active paper cut bug open for it.

Changed in hundredpapercuts:
status: New → Invalid
Daeng Bo (daengbo) wrote :

Travis, I'm surprised that you marked this bug is marked invalid when the upstream bug doesn't actually close the issue, just the proposed solution. In fact, the answer to this problem was proposed in the linked Ubuntu archives:

"It's perfectly supported as designed. Put some template in ~/Templates
and enjoy. If you want to push it to new users, put it in
/etc/skel/Templates and every new user gets them."

Yeah. That's all it will take. Create three or four new, empty files, and throw them in /etc/skel. No need for a patch like the one in the Gnome archives. This is an easy fix. It's a bug that bugs new users. Upstream DOESN'T oppose templates, just not ones that the standard user can't remove (like in /usr/share/templates), thus spamming his menu.

This is definitely a one-hundred-papercuts bug. Create the files. Otherwise, the "Create Document" menu item should be greyed out when no templates exist in the Templates directory.

Sancho Panza (prashanthr) wrote :

The justification for marking this bug as invalid in Nautilus is (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/372132/comments/3): "the rational to have no template by default is that the choice of what to put there is an user one and upstream is against giving a way for applications to put tons of useless items in there for most users."

If that is the rationale, how does one justify the confusion or frustration it creates to users as given in the bug description? Using the right-click menu if one creates a new document, renames it with the extension of one's choice, and opens it with the "appropriate" software, just does not work. Nor is it clear as to how one is supposed to create/add new templates. If the designers are against putting "useless templates" in there, at least provide a straightforward means to add new templates.

I have been going thru some of the bugs (and filing some myself) and have seen many bugs rejected as not "paper cut" worthy. If this does not meet ALL the requirements of being a paper cut, I dont know what does. Please clarify which specific criteria this bug fails to not qualify as a paper cut.

summary: - Create Document Templates
+ "Create Document" Templates
Changed in hundredpapercuts:
status: Invalid → New

I also think that the current behaviour of the "Create document" is a bit against usability. While it is true that some options could be very user-specific, including the most used types of files (specially OpenOffice documents) would make the system more usable for most users.

summary: - "Create Document" Templates
+ "Create Document" Templates difficult to use
Matthias Hawran (jahwork) wrote :

I agree with Sancho. This is definitely a paper cut.
The risk-of-tons-of-useless-items-in-template-menu is really NOT justified IMHO, compared to the bad user experience it gives, as reported here.
I can testify the same with user used to this behavior and bothered.

It's really not a big deal to at least have the 3 (or 4) most used OOo documents: word proc, spreadsheet, presentation and drawing.
How much ton of useless item will I have ??

And for the *really* bothered users (I'm talking about geeks), they'll know where to go to remove any so-called-annoying entries.

Changed in hundredpapercuts:
status: New → Confirmed
Martin Lettner (m.lettner) wrote :

Please also have a look at the comments in Bug #387655, thanks.

Firstly I don't want to derail this discussion in any way as some good points have been made.

However as a relative newcomer to Ubuntu this was one of the first shortfalls I noticed. Taking Gorka Navarrete's post at the top a little further, I don't see the point of creating a "new" document only to find it as a file on the desktop. For example, if I needed to create an O.O Word Doc I obviously want some text to be saved. Would it not be an idea, and in my opinion a richer experience, if when I right click and choose "Create Document -> Open Office_Word Document", the Word application opens with a blank page ready to receive my text? Thus eliminating points #1 - #3 in Gorka Navarrete's post. From here, the "New" document could be saved to your chosen destination and in the format you choose. This then also eliminates the need to manually move "New" documents off the desktop.
I agree that this menu should incorporate the most useful shortcuts and propagate, depending on the software installed.

Footnote: What I propose here is not the std behaviour of Windows out of the box, but is possible to achieve; by adding shortcuts of application "Master_Templates" to the "New" menu, e.g M$ Word. Works as I have outlined above.
I have tried this approach in Ubuntu, using "Create Launcher" but when they are placed into the Templates folder, the behaviour of the launcher defaults to Create Document.

Gorka Navarrete (emrys) wrote :

I think what bra10n is proposing could make an interesting topic for a longer discussion but that it is in fact a slightly different thing.

In my case, the goal of right click, create whatever-document is to create a document in that particular folder. If you have a complicated folder hierarchy, open a blank document and then save it in the right folder can be a lot more complicated than double clicking a new blank file created in the right folder.

Changed in hundredpapercuts:
milestone: none → round-2
Changed in hundredpapercuts:
assignee: nobody → Matthew Paul Thomas (mpt)
Sebastien Bacher (seb128) wrote :

could the design team do recommendation on what they would suggest to change to get that papercut solved?

This is a duplicate of bug 126056. Some templates that could be included are attached to that bug report.

Michael Nagel (nailor) wrote :

bug 126056 (relict of 2007) has been marked as a duplicate of this. while i appreciate that something seems to happen here, the xdg-user-dirs history of this bug should not be forgotten. there are some other problems with these...

Rodney Orpheus (rodneyorpheus) wrote :

While I understand the concerns about every app in the world sticking things in that folder, I think it makes sense that applications that are installed by default in the standard distro should have some basic templates also installed by default in the Templates folder. That would imply that some templates from OpenOffice and GIMP at least should be in there.

As well at that, I'd suggest that we create an Additional Templates package that the user could install via "Add/Remove" that might contain some more arcane OO & GIMP templates, plus perhaps some others for Scribus, Inkscape or other widely used creation applications.

Either way, the current default setup is definitely a paper cut that needs fixing.

I'll recommend some default file types to solve this problem for Ubuntu.

Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Rick Spencer (rick-rickspencer3)
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

rick note that the issue is not only a matter of shipping templates, nautilus has no system directory it can use right now for templates, the code need to be changed to support that which is something upstream argued several times again and will not be doing

Scott Ritchie (scottritchie) wrote :

Might I suggest this:

Create a ~/Templates folder by default (by placing it in /etc/skel), and populate it with symbolic links to new template files located at /usr/share/default-templates (this is a new directory, and files in here do not show up as templates by default, unlike /usr/share/templates).

This can be done entirely with a separate package (default-templates) and shouldn't bother upstream. It will allow the user to remove a template (by deleting the symbolic link), and allow us to update a template (by updating the package).

The downside is that we can't add any new templates to an existing user's folder when they upgrade, but that's also the situation today. I don't see an easy way of allowing users to delete templates while also shipping a default set, not without upstream code changes.

Sebastien Bacher (seb128) wrote :

the previous comment suggestion has already been discussed but it's an issue because non desktop users don't want they directory to be cluttered with desktop templates and server guys etc refused to do such changes

Sebastien Bacher (seb128) wrote :

we discussed the topic on IRC again yesterday, some notes:

 * where to ship the templates?
- in each application? in which case you can easily have duplicate office templates for openoffice and abiword for example
- in a template package? it's easy to install but lack granularity, what to do if the corresponding application is not installed?
- in a extra binary for each application, texteditor-template?

* in what directory to install those? using a cross desktop one or a GNOME specific dir? some people use non GNOME applications on GNOME

* do we need a way for users to mask system templates they are not using? how do we do that? do we need a template editor?

Scott Ritchie (scottritchie) wrote :

By the way it seems like lots of users have an empty but visible ~/Templates these days. It would be nice if nautilus explained what that's for when you browse inside it to at least give a clue in that context.

Martin Lettner (m.lettner) wrote :

That's what I wanted to say in a comment on a duplicate of this bug: https://bugs.launchpad.net/hundredpapercuts/+bug/387655/comments/12
The top bar of nautilus (like used in Trash) should explain what this folder is about.

tags: added: needs-design
Sebastien Bacher (seb128) wrote :

having a cluebar about how to use the folder would be nice, that would be a different issue than adding default template though it might be time to create different bugs there

Vish (vish) wrote :

If I understood this right,The proposed solution is,Just drop empty files from various apps in the templates folder?

Dropping the empty files in templates folder , just to add them to the list is *blatant abuse* of "Templates" .

*Templates are supposed to be user or company specific* , something that already has a format, and just needs an edit to be finished.
Upstream has been right to reject this and not to populate the create document option.

*Templates are not empty files* and *this is a wrong approach* .

If this option is confusing or difficult to use, its better if this item 'Create Documents' is removed!

As already pointed out, The *only* user-friendly solution is, if the a menu item actually points to the "New" of the app,
ie: when the user selects , 'New document' , the app directly opens with an empty file.

The "Windows way" of creating new documents is not user-friendly:
1: User *has to rename a file*
2: User has to open the file after the initial select of > Create Document.

No-one actually simply creates an empty files, users want to work on the new Documents.

I'd say rather than taking shortcuts and dropping files into templates , we could implement a feature which is actually user friendly.

I agree that hiding the command is better than the current experience. However, I disagree that there is any kind of "abuse" in dropping in empty documents. I think this is a totally fine discoverability mechanism, and some users might use it. If users expect to be able to create empty documents from there, I see no harm in giving them what they expect.

Rodney Orpheus (rodneyorpheus) wrote :

After looking at the current behaviour of the Create Document command I tend to agree with mac_v, in that users want to work with new documents, not just create them and leave them sitting there. Couldn't we change the way the command works so that it opens a new document within the associated app using the template selected i.e. the same thing that would happen if the user double clicked on the template file directly? That would make the command much more useful in general.

I still think that the Templates folder should come pre-populated with some good basic templates - otherwise most users will never figure out what that folder is for in the first place (I didn't, and I've been using Ubuntu for years). If non-desktop users really have such a problem with that, then perhaps make it so that each user's Templates folder is only populated on the creation of a desktop user account? To be honest, I don't think that's really necessary though... how much room do a few basic templates take up really?

mac_v didn't take care of one thing: when I'm browsing with nautilus,
and I am in a directory, if I want to create a new document inside it,
I will use the templates menu, and I will create the file INSIDE that
folder. This is the real gain of templates.
If instead of creating the file, the software is launched (as was
suggesting mac_v), this would be considered: the default save path
needs to be changed

Vish (vish) wrote :

@Nicolò Chieffo :
NO, Maybe i wasnt clear, I was suggesting that the "new file" would be opened in the location where the user chooses,
But only enters the file name , when the user selects "Save" .
So the user only saves to the directory where he had selected to open the new document.
The path definitely has to be in the nautilus location where the user selected, otherwise there is no use in providing the right click option.

If this option is available , there is no need for Ubuntu to create templates. But rather,as already suggested, a clue bar for the templates folder, is enough to inform the user .

l-x-l (labouie) wrote :

As a recent ubuntu convert I can honestly say that the current behavior of "Create Document" is completely useless. How often do "regular" users want to create an "Empty File"? At a minimum templates should be installed for creating:

1. OO Word Processor file
2. OO Spreadsheet
3. Text File (to replace the name "Empty File")

As it stands now there is zero functionality to the current behavior.

as we discussed ....

Changed in nautilus (Ubuntu):
assignee: Rick Spencer (rick-rickspencer3) → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

I discussed several design possibilities with Sebastien. We reached the following consensus:

1. Ship all templates in an ubuntu-document-templates package. Iniitally this will have templates for .odt and .ods.
    + Easy to uninstall templates package
    + existing MIME applications will automatically select abiword/OO writer/etc., whatever your preference is
    + if you don't have a matching app installed, nautilus will suggest to install that app
    + As a distro we retain tight control about which templates we ship by default, and thus avoid cluttering the menu with dozens of entries.

2. Templates are shipped in a system directory by the -templates package, and nautilus will be patched to look in that as well.
    + No dirty tricks with changing /etc/skel, and making this work on upgrades as well.
    - Harder to opt-out for a user. However, this is not serious, since it's not any worse than the rather useless default that we provide right now. We can provide a gconf key for "use system templates", or the user can uninstall ubuntu-document-templates if he wants to to do.

Martin Pitt (pitti) on 2009-07-16
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

the suggested solution seems good to me too

Tim McNamara (tim-clicks) wrote :

+1

From another user's perspective (have been using Ubuntu since 8.04), I've never worked out how to add . I have always been confused as to why there were no default options.

I don't see the big deal in having a longish list - you could have 'create oggcast' and 'create video' there too - techxperts will customize things as they want and remove things they don't need.

fig_wright (fig-wright) wrote :

The fact that this sorry argument has been going on is good evidence that the Linux community still doesnt fully "get it". Users dont expect to have to create their own templates and put them in the right place. They just expect them *to be there*. It's really not a big dealt to have ~15 or so templates in the menu. Amazingly, people can chose from 15 objects quite easily.

Oh, by the way, dropping templates into the ~Templates directory doesnt actually do anything for me. I guess something's broken somewhere, but I really dont care enough to try and fix it today...

fig_wright (fig-wright) wrote :

Ha-ha! OK, I got frustrated and did track down the fix. What did I find? Well, on my system the default "Templates" location wasnt even ~Templates, it was just ~

To fix it:
------------------
sudo gedit /home/<username>/.config/user-dirs.dirs

then edit this line
XDG_TEMPLATES_DIR="$HOME"

to
XDG_TEMPLATES_DIR="$HOME/Templates"
------------------

Seriously lame...

Michael Nagel (nailor) wrote :

fig_wrigth, see bug 285998 if that is what you experienced.

There are several problems regarding templates right now:

- there are no default templates (see this bug 372132 )
- the right click menu is pointless by default right now
- there is no obvious way to make it useful
-- (like an "click here to install some templates"-menu item instead of the "no templates installed"-menu item you cannot click)
- there is a ~/Templates folder in user's home that is of no obvious use and that is not hidden by default (bug 193689)
- things are permanently messed up if you remove that folder (bug 285998)
- in nautilus there is a Go->Templates menu item that is documented/explained poorly

that whole Templates-Thing should be overhauled and i find mac_v's post quite interesting.

PS: as another example of possible usage, i know people that put "A4-landscape.odt", "A4-portrait.odt" (and so on) in there to spare configuring format and orientation every time.

cl333r (cl333r) wrote :

Not sure which templates to add?
First and most important to most desktop users - office related templates: OpenOffice equivalents of word, excel & powerpoint of course. Both the OpenOffice and MS Office installers add these templates on Windows. So a patch to add this functionality to the Linux OpenOffice installer as well should be created and pushed upstream.

And of course, users don't add/remove templates every day, so having for that reason a separate "Templates" folder right in the home folder is overkill. This folder should obviously be moved (I'd suggest, according to the freedesktop.org traditions) to either ~/.config or ~/.local

My 0.02$

Vish (vish) wrote :

Again... this solution is not the right approach. Fixing it as is being done now , doesnt address the usability issue and we need to fix this properly, these templates are not specific to the user , one size doesnt fit all.

FWIW, I'v filed a bug upstream > http://bugzilla.gnome.org/show_bug.cgi?id=590666

Gorka Navarrete (emrys) wrote :

Being true that one size doesn't fit all, one size does fit a majority of people.

A small number of most common filetypes will fit most users. At least the non-experts. If you know that a template folder exists and what it is for, probably you will personalize it anyway.

This bug refers to a problem non-experts do have. Let's fix it. Even the temporary solution we are talking about is better than nothing. Afterwards, let's improve it.

At the bare minimum "Create Text Document" should be a default template that resides in the "Create Document" context-menu-item.

We must not let Microsoft beat Ubuntu in this regard (see attachment).

Changed in hundredpapercuts:
milestone: round-2 → r2
Changed in hundredpapercuts:
milestone: r2 → r10
DaVince (vincentbeers) wrote :

Rather than creating a seperate package for templates, wouldn't it be better to change the appropiate application packages to automatically generate these filetypes? Ex. when OOo is installed OOo templates are added during installation and the same happens for the GIMP or any other (often-used) application with its own file types.

Martin Pitt (pitti) on 2010-04-20
Changed in nautilus (Ubuntu):
assignee: Martin Pitt (pitti) → Canonical Desktop Team (canonical-desktop-team)

It is very heartening to see this discussion continue. I assumed from some of the responses that a decision in this regard had been reached, and the umpires decision was final. Not so!

To the point, and as an early commenter on this I agree wholeheartedly with Lonnie: 2009-11-12 and that viewpoint: that the links in 'create document' launch a template from the respective application, from which a file may be created and saved anywhere that the user chooses. These templates can be customised to the users preferences or style sheet thus enriching the whole task. Note that the template 'itself' cannot be saved or altered via 'create document', but merely provide a canvas or starting point, i.e open office.tmp, save as 'resume.odt' in /home/user/Documents

Atanas Atanasov (thenasko) wrote :

If each program provided its own template, then sooner or later, the user will be facing a list of 20+ templates. This could easily be seen to be an annoyance, and could actually render any work on templates useless. I would like to suggest a simple utility which will enable the user to select which templates he/she would like to see in the "Create Document" menu. In terms of implementation, packages can land their templates in one directory, and then these files would be copied to the templates folder of any particular user by the described utility.

Gorka Navarrete (emrys) wrote :

As far as I can see there are the next few options:

1) Create a standard subsets of Templates (<5) including the common Openoffice files and some other.

2) Let the programs copy their templates to the Templates directory

3) Utility to manage templates

4) Utility to mediate in template creation on installing programs (An hybrid between 2&3)

5) Standard subset of templates plus utility to mediate (as in 1&4)

6) Do nothing

I certainly think that 1 would be good enough. The Ubuntu desktop team would choose a sane number of default templates and that's it. Easy, quick, and fitting for a majority of users. Probably something in the line of 5 would be better, but a lot more difficult to implement.

In any case, a decision should me made at some point so, we could try #1, see how it goes, and if some terrible thing happens, revert to the previous state or try something else...

I would be happy if I was able to drop a shortcut or launcher into the folder. Would this not be the easiest fix?

Gorka Navarrete (emrys) wrote :

bran10n, that is the present behavior. The problem is that no one knows it.

Yes I realise this. The problem is that these launchers don't open!
If this lack of 'action' remains, well I ask what will have been the point?

If by default I need to 'create new document' in the current folder I'm browsing, then manually open that document and then possibly move it to the folder I wish to store it in, then why would I work that way?
Would I not just open O.O for example, create my document and save it in the correct location to begin with.
As I said, would not the easiest solution here be to add <5 launchers that OPEN to the templates folder for the average user with advanced users able to manipulate this functionality to open more than a blank doc, i.e a formated template file.

Dmitry Tantsur (divius) wrote :

Wow! I didn't know what "Templates" directory is designed for until now!

Vish (vish) on 2010-06-10
Changed in hundredpapercuts:
milestone: lucid-round-10 → maverick-round-1-file-management
Jean-Peer Lorenz (peer.loz) wrote :

I feel compelled to give my 2cents: As an experienced computer user it took me 3 years to figure out the meaning of the 'Template' folder in my home directory (since I don't read manuals/documentation as nobody does - except the developers when writing them) - see comment #53. Ok, I did not really investigated what it is for (you know, searching through the web and suddenly 2 hours went by) but I always wondered: 'What the heck is this folder and why is it there? Can I safely remove it? Or does it come back then? Or even worse, are things broken then?"

The obvious way of putting a file named with the Template name into this directory seemed ways to easy for me. My fault though I think a common one. Therefore I think providing the most common file types as templates (Writer, Calc...) is really important. If I then browse through my home directory and open the Template folder I see some files and maybe can figure out for what they are.
By now, I've added templates for scripting and much more and like it. Especially that I can define a template file with execution bit set (and shebang of course).

The current situation: an empty directory in my home dir and and empty submenu is not satisfactoring or user-friendly.

Tobias Wolf (towolf) wrote :

I think Vish is right. Creating a new blank file and opening it with the associated app is the same as just launching an app. That menu is not an app launcher. The app launcher is elsewhere. Making this menu an app launcher would introduce redundancy in UX.

This menu is made to hold user customized pre-filled templates, not blank files. The "Empty file" entry is just meant as a baseline.

Sebastien Bacher (seb128) wrote :

unassigning the bug for now since nobody in the team is working on it and the design is still not really clear. The suggestion listed before would lead ot a list of templates users could change which means it wouldn't reflect the softwares an user runs but rather the one the sysadmin decided to installed templates for which is suboptimal...

Changed in nautilus (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Vish (vish) wrote :

Still needs-design

Changed in nautilus (Ubuntu):
status: Triaged → Confirmed
androith (androith) wrote :

This is annoying: I have a bunch of python scripts in directories in my home folder, and they all appear in this menu, for some reason.

Gorka Navarrete (emrys) wrote :

This is the third iteration of 100 paper cuts for this bug and still no consensus.

The initial bug report assessed something quite simple. The present design of the Templates is not user-friendly, and Windows converted users get confused. The obvious solution seemed to be the more useful for those affected by the bug, that is, the new comers (from Windows usually). And that is, place a few (max 5?) empty files of the more common and used default apps (Openoffice, and the like) in the Templates directory to have those available from the right click menu.

The more savvy users know how to deal with all this and so, it is simple for them to personalize it. Also, the discoverability of the Templates functionality has been criticized (and I personally think it is an important issue), but that probably belongs to a different bug.

In any case, it seems that someone has to take over this to solve it, one way or another. It's been more than one year and the only thing left is (as far as I understand) a decision on what exact templates to put in the Templates directory by default. Is it possible that someone in the Design or Usability teams can make that decision? It should be a simple one.

And please, let's keep in mind that the goal of this is to help ease the transition from Windows and enjoy a very simple and quite popular feature (easily customizable, also).

Personally I do not see any resolution to this stand off given what appears to me to be narrow-mindedness, coupled with some fear of "redundancy in UX."
A simple quote;
"A paper cut is a trivially fixable usability bug that the average user would encounter in default installation of Ubuntu or Kubuntu Desktop Edition."
That's the brief.
I am an average user and I haven't used Windows for at least 5 years, yet this lack of functionality irks me no end. And to those who wish to argue the all mighty purpose of the Templates folder as designed and implemented as a basis for a fix, to those I ask was it designed to be a half-way house of blank files on their way to the desktop? No I thought not...
So I ask why the hesitation, the lack of inclination or stubborn refusal? to explore and develop this nuance into a shortcut of usefulness?

Quote (part): Tobias Wolf, no YOU are right (#55). The menu certainly should not be an app launcher alone. It should be a template launcher. The menu should open the app with THE TEMPLATE selected open, and any subsequent additions or alterations saved only as a generic file. The folder should include a ~/path to template.file as a means of adding future templates, rather than have software propagate their templates during installation as was discussed earlier.
To me this is a no brainer.
And lastly to all here I apologize for my tone and my frustration regarding this matter.

Chris Wilson (notgary) wrote :

mpt, is there anything happening with this?

Changed in hundredpapercuts:
milestone: maverick-round-1-file-management → none
Matthew Paul Thomas (mpt) wrote :

I don't have time to work on this, sorry.

Changed in hundredpapercuts:
assignee: Matthew Paul Thomas (mpt) → nobody
Chris Wilson (notgary) on 2011-02-01
Changed in hundredpapercuts:
importance: Undecided → Wishlist
Mathieu MD (mathieu.md) wrote :
Download full text (3.6 KiB)

This bug is more than two years long, and still nothing has been done. Maybe we forgot that the main focus of Ubuntu is to be simple and intuitive. In this light, the empty "Create Document" menu is frustrating for standard and new users (and even for advanced users, as it seems according to many of the comments in this bug) and we should do something to fix it. We can fix it quickly first, and then take the time to re-thing about its expected feature in a second time.

So, as I see it, there is two succesives steps to do: an easy step to quickly fix this bug, and a more extensive approach to rework the feature itself.

* The Quick & Easy step:
----------------------------------

It would consists in using the current mecanism of Nautilus, and we just need to create of a few empty files in ~/Templates to populate the currently empty menu and fix this bug.

We could add inside ~/Templates some symlinks to /usr/share/default-templates/{empty_files}. Doing so would still allow powerusers to add their own templates/empty files next to these symlinks, and even remove them.

The few default empty files to populate the "Create Document" menu could be:
- LibreOffice Writer.odt
- LibreOffice Calc.ods
- LibreOffice Impress.odp
And of course keep the current "Empty File"

Adding an option "Edit My Templates..." which would open Nautilus at ~/Templates is also a very nice idea.

We should also think of the translation of those entries. But using the application's name for the files may help to avoid this problem (I don't know about that, but at least on my French system, Writer, Calc and Impress are used as-is and are not translated -- wether its a good think or not is another problem)

This quick fix requires:
- to store a few templates in Nautilus package (or in its own "ubuntu-nautilus-templates" package as suggested) located in /usr/share/default-templates
- a mecanism to add the symlinks to users' ~/Templates directory if present (they should be added only once, because users may want to remove them)

* The Long & Best step:
----------------------------------
(it requires a new bug to discuss and work on it)

bra10n and Vish's points of view are very correct in term of user ergonomy IMHO. Nobody just wants to create a file without editing it (do you?). Therefore the right-click menu would be much better if it could be used to launch applications pre-opened with the chosen template (would it be an empty file or a real template) and save the file (in the current location) only after user has made changes and/or choose to save it.

Contrary to the Quick&Easy fix, this one do absolutely requires a non-hidden ~/Templates directory because the files inside it would be "real" templates made by the user for her own needs.

When viewing ~/Templates in Nautilus, it should display an info-bar (like when viewing the Trash, as suggested Martin Lettner) to notify the user that she can add her own template-files here in order to use them from the right-click menu.

Also, we should not forget that some applications have their own template system. For LibreOffice it is in ~/.libreoffice/3/user/template. This directory uses "Open Document Template" format, and becaus...

Read more...

Joel Pickett (jpickett) wrote :

Echoing comment #63, it's annoying installing Ubuntu, a full-featured desktop OS, to find that there's no document templates available. I'd much rather not have it at all than to have something that you have to actually create the templates yourself.

Jacky Alciné (jackyalcine) wrote :

This bug affects me as well! No resume templates, no letter heading,
nothing.

On Mon, Nov 28, 2011 at 08:02, Joel Pickett <email address hidden> wrote:

> Echoing comment #63, it's annoying installing Ubuntu, a full-featured
> desktop OS, to find that there's no document templates available. I'd
> much rather not have it at all than to have something that you have to
> actually create the templates yourself.
>
> --
> You received this bug notification because you are subscribed to One
> Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/372132
>
> Title:
> "Create Document" Templates difficult to use
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/372132/+subscriptions
>

--
Jacky Alcine
Blog <http://jackyalcine.co.cc/> | Launchpad<https://launchpad.net/~jackyalcine>

Chris Wilson (notgary) wrote :

One solution that comes to mind would be to add an option to the bottom of the "Create New Document" menu called "Create New Template". Here, the user could choose from a list of document types such as "LibreOffice Presentation", "LibreOffice Spreadsheet", etc. I'm not sure how the available template type would be exposed by the applications to the menu.

Once the user selects one option, a dialog could appear and ask them to name their new document, after when Nautilus could open the ~/Templates folder with the newly created and named template within. In this way, the user would figure out how the templates system was supposed to work without having to visit a website or ask someone. Perhaps the name dialog could also offer some sort of brief explanation of what happens next.

Changed in hundredpapercuts:
milestone: none → quantal-6-file-management
Martin Zoller (mzoller) wrote :

As a long-year Ubuntu and Linux Mint user, I always used to think this "Create New Document" menu was a work in progress. Since it is not an indispensable functionality, it seemed reasonable that this would be broken. But reading this bug report made me feel sad about it. Why on earth should it be wrong to add some default templates to that menu? It's just one out of many decisions that a Linux distribution makes for its users. All it takes are some templates for the default apps that come with the distribution. Once they are there, users will realize that this feature actually works, and may even figure out how to add custom templates.

V字龍(Vdragon) (vdragon) wrote :

Sorry for spamming you guys, but is there any updates on the ubuntu-document-templates package?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.